Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 21 Aug 2014, 10:02
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
hplip and hpliplite packages
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 10 [143 Posts]   Goto page: Previous 1, 2, 3, 4, ..., 8, 9, 10 Next
Author Message
lluamco

Joined: 16 Mar 2007
Posts: 207
Location: Banyoles, Spain

PostPosted: Sun 28 Sep 2008, 07:40    Post subject: hpliplite
Subject description: lite version of hplip (HP PSC Printing and Scanning)
 

disciple wrote:
What would probably be useful is an "hplip-lite" package (google it).

Thanks disciple. I have packaged the hpliplite version 2.8.9. It is only 3.1 MB
and allows printing and scanning.
The packages can be found in the first post of this threat.
Back to top
View user's profile Send private message 
disciple

Joined: 20 May 2006
Posts: 6427
Location: Auckland, New Zealand

PostPosted: Mon 29 Sep 2008, 18:23    Post subject:  

Nice - works well. It will feel much better to point people to that than to the full hplip and all its dependencies Smile

I still can't figure out what hplip is supposed to add in terms of printing support though Rolling Eyes

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send private message 
sintot


Joined: 29 Oct 2006
Posts: 57
Location: Madrid

PostPosted: Thu 02 Oct 2008, 12:37    Post subject:  

Hi:
I have an HP Photosmart C5280, that is supported with Hplip. If I install the full hplip (the "bloated" one), I can scan; but if I install hplip-lite (in another puppy installation), I can't scan. Do you know if some manual configuration is needed, or if my All-In-One is not supported by hplip-lite?

Thanks in advance

Edit: I've solved it adding "hpaio" in the file /etc/sane.d/dll.conf. Thanks for the hpliplite, it is a lot better than the bloated one!
Back to top
View user's profile Send private message 
lluamco

Joined: 16 Mar 2007
Posts: 207
Location: Banyoles, Spain

PostPosted: Thu 02 Oct 2008, 13:06    Post subject:  

Thanks sintot.
I agree that hpliplite is better: almost same functionality
and much less resources. I have a question for you. How did you install hpliplite?
Adding hpaio in the file /etc/sane.d/dll.conf should be automatically done by petget.
It is strange that it was not in your case.
(Or did you untarred the package and manually copied the files?)
Cheers
Back to top
View user's profile Send private message 
sintot


Joined: 29 Oct 2006
Posts: 57
Location: Madrid

PostPosted: Thu 02 Oct 2008, 13:24    Post subject:  

I think the problem was that I installed xsane (and sane-backend) after installing hpliplite
Back to top
View user's profile Send private message 
lluamco

Joined: 16 Mar 2007
Posts: 207
Location: Banyoles, Spain

PostPosted: Thu 02 Oct 2008, 13:29    Post subject:  

sintot wrote:
I think the problem was that I installed xsane (and sane-backend) after installing hpliplite

OK, sane packages should be previously installed.
Thanks for the feedback.
Back to top
View user's profile Send private message 
sintot


Joined: 29 Oct 2006
Posts: 57
Location: Madrid

PostPosted: Fri 03 Oct 2008, 14:05    Post subject:  

As an addition to the hpliplite package, to check ink-cartridges levels, you can try inkgui:
http://www.murga-linux.com/puppy/viewtopic.php?search_id=185221425&t=26407
Back to top
View user's profile Send private message 
lluamco

Joined: 16 Mar 2007
Posts: 207
Location: Banyoles, Spain

PostPosted: Sun 05 Oct 2008, 13:16    Post subject:  

Thanks sintot for the information about inkgui and its link, for checking the ink-cartridges levels.
I have found that it works in puppy 4.1rc provided one installs the attached library.

EDIT: First version of the attached file was not working. The present version should work.
libieee1284-3.2.pet
Description 
pet

 Download 
Filename  libieee1284-3.2.pet 
Filesize  16.46 KB 
Downloaded  729 Time(s) 
Back to top
View user's profile Send private message 
exProphecy


Joined: 05 Nov 2007
Posts: 333
Location: Bay Area, California

PostPosted: Mon 13 Oct 2008, 23:19    Post subject:  

I installed hpliplite and you said that the printer would be able to scan using xsane. I tried probing for it with xsane and it says "No devices available". It was able to print though. My HP printer is HP PSC 1315xi and it is connected with a USB. Can you assist me with this issue? Using Puppy 4.1 fyi.

EDIT: Nevermind, the USB from the printer got accidentally unplugged. Works great!

_________________
Puppy 4.3.1 + Sansa Express MP3 Player + 10GB USB Flash Drive = My triple threat OS. Wink
I consider myself a Turritopsis Nutricula.
http://www.wellminded.com/puppy/pupsearch.html
http://www.esnips.com/web/exprophecypets
Back to top
View user's profile Send private message AIM Address 
lluamco

Joined: 16 Mar 2007
Posts: 207
Location: Banyoles, Spain

PostPosted: Sun 09 Nov 2008, 15:56    Post subject: hpliplite updated to version 2.8.10  

hpliplite updated to version 2.8.10.
See first post
Back to top
View user's profile Send private message 
JB4x4

Joined: 30 Jul 2006
Posts: 256

PostPosted: Sun 09 Nov 2008, 21:34    Post subject:  

@lluamco

Will you be updating HPLIP (standard version) also??

JB
Back to top
View user's profile Send private message Yahoo Messenger 
lluamco

Joined: 16 Mar 2007
Posts: 207
Location: Banyoles, Spain

PostPosted: Tue 11 Nov 2008, 15:22    Post subject:  

JB4x4 wrote:
@lluamco

Will you be updating HPLIP (standard version) also??

JB

Hi JB4x4, I have been trying to, but with little succes. The main problem is that hp-toolbox refuses to start for user root, and if it is run as user spot, there are problems related to X windows. All in all, hp-toolbox does not work at present in puppy 4.1.1. That makes the full version useless, at least the one I have been playing with until now.
Fortunately, the lite version works and allows printing and scanning.

EDIT: Problems solved. See next and first posts

Last edited by lluamco on Wed 12 Nov 2008, 12:51; edited 1 time in total
Back to top
View user's profile Send private message 
lluamco

Joined: 16 Mar 2007
Posts: 207
Location: Banyoles, Spain

PostPosted: Wed 12 Nov 2008, 12:49    Post subject: hplip updated to version 2.8.10  

hplip updated to version 2.8.10.
See first post
Back to top
View user's profile Send private message 
seeker

Joined: 26 Nov 2008
Posts: 89
Location: Indiana, USA

PostPosted: Fri 05 Dec 2008, 10:18    Post subject:  

Iluamco,

Thank you for packaging hplip, it has made my HP printer setup chores a breeze. I am using the full hplip 2.8.5 and when I try to use the menu "Device-Setup New Device" I get this error, "Unable to find an appropriate su/sudo utility to run hp-setup." Puppy has /bin/su, so is there a symlink that should be created somewhere?

Seeker

Edit: Sorry, posted too soon. I tried hp-setup at the command line and presto, there it was.
Back to top
View user's profile Send private message 
exProphecy


Joined: 05 Nov 2007
Posts: 333
Location: Bay Area, California

PostPosted: Mon 15 Dec 2008, 05:15    Post subject:  

Hey I installed HPLIP lite and I went to the website (the one where we can see if it is supported). I did find my printer which is HP PSC 1315xi and says it is supported. Although, I installed HPLIP lite and looked for my printer when adding it in CUPs and did not find it. Am I doing something wrong? Or do I need the full HPLIP package?
_________________
Puppy 4.3.1 + Sansa Express MP3 Player + 10GB USB Flash Drive = My triple threat OS. Wink
I consider myself a Turritopsis Nutricula.
http://www.wellminded.com/puppy/pupsearch.html
http://www.esnips.com/web/exprophecypets
Back to top
View user's profile Send private message AIM Address 
Display posts from previous:   Sort by:   
Page 2 of 10 [143 Posts]   Goto page: Previous 1, 2, 3, 4, ..., 8, 9, 10 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0785s ][ Queries: 12 (0.0122s) ][ GZIP on ]