Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 16 Dec 2017, 11:26
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
(Solved) Abiword 2.4.5 cannot open RTF that opens on 2.4.4 ?
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
Jon_J


Joined: 06 Mar 2008
Posts: 76
Location: Illinois

PostPosted: Tue 11 Mar 2008, 17:35    Post subject:  (Solved) Abiword 2.4.5 cannot open RTF that opens on 2.4.4 ?  

My "Animal Shelter" is getting full of abandoned puppys
I'm on my 5th version (puppy-3.01retro-k2.6.18.1-seamonkey)

I tried to open a windows "Wordpad" file that is in *.rtf format in Abiword 2.4.5 that is included, but Abiword spits out this error:
"It appears to be an invalid document"

This same file opens with no problems in Abiword 2.4.4, (This verson is on my Zaurus)

I attached it here, its a windows *.rtf in a zip. The forum won't accept *.rtf
PET-Be-Gone-dependency.zip
Description 
zip

 Download 
Filename  PET-Be-Gone-dependency.zip 
Filesize  1.68 KB 
Downloaded  282 Time(s) 

_________________
Dell Mini-10 tri boot | Win XP, Mint 7 XFCE, Puppy 4.3-small
Intel Core2 Duo 2.80GHz 2GB Ram Win XP sp3
Pentium 3/600Mhz 256MB Ram tri boot Puppy-Full-3.01|1.0.4|Win98
Sharp Zaurus Linux devices SL-C3100 & SL-C3200


Last edited by Jon_J on Fri 14 Mar 2008, 17:57; edited 1 time in total
Back to top
View user's profile Send private message 
Dingo


Joined: 11 Dec 2007
Posts: 1433
Location: somewhere at the end of rainbow...

PostPosted: Tue 11 Mar 2008, 17:42    Post subject:  

just downloaded ant tried. My Abiword 2.4.5 on puppy 3.01 opens without any kind of problems this rtf file. I have a frugal install
_________________
replace .co.cc with .info to get access to stuff I posted in forum
dropbox 2GB free
OpenOffice for Puppy Linux
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13648
Location: Karlsruhe, Germany

PostPosted: Tue 11 Mar 2008, 17:59    Post subject:  

I installed Abiword 2.4.6 over 2.4.5 in Muppy 008 (based on Puppy 2), and it also can open your attached .rtf.
Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
Jon_J


Joined: 06 Mar 2008
Posts: 76
Location: Illinois

PostPosted: Tue 11 Mar 2008, 18:11    Post subject:  

I removed Seamonkey and replaced it with Opera and Sylpheed.
I don't know what could have gone wrong. I seem to have a lot of "little" problems with my puppy collection.
Switching to 3.01 version causes the automounter to place my mounted drives in the top-left corner (where Home is).
I can fix this by using the xvesa graphics driver.
In 2.17, the automounter placed the drives in a nice row along the right-bottom and I was using xorg graphics driver in 2.17.

EDIT:
I got it to open by launching Abiword, then using file > open, and I selected type as *.rtf
(previously I just clicked the document and associated it with Abiword)
But it is all scrambled up with a bunch of code characters.

_________________
Dell Mini-10 tri boot | Win XP, Mint 7 XFCE, Puppy 4.3-small
Intel Core2 Duo 2.80GHz 2GB Ram Win XP sp3
Pentium 3/600Mhz 256MB Ram tri boot Puppy-Full-3.01|1.0.4|Win98
Sharp Zaurus Linux devices SL-C3100 & SL-C3200

Back to top
View user's profile Send private message 
Jon_J


Joined: 06 Mar 2008
Posts: 76
Location: Illinois

PostPosted: Fri 14 Mar 2008, 17:56    Post subject:  

I may have solved my problem with Abiword and *.rtf files..
I just copied my windows 98 default TTF fonts to /usr/share/fonts/default/TTF
Restarted X, then opened Abiword and it opened a different *.rtf file from the one above.
I didn't have the file above handy, so I opened a different one.
All my notes to myself in *.rtf format, were made using windows arial fonts.
(I think) adding them to my Puppy installation fixed my above problem. Smile

_________________
Dell Mini-10 tri boot | Win XP, Mint 7 XFCE, Puppy 4.3-small
Intel Core2 Duo 2.80GHz 2GB Ram Win XP sp3
Pentium 3/600Mhz 256MB Ram tri boot Puppy-Full-3.01|1.0.4|Win98
Sharp Zaurus Linux devices SL-C3100 & SL-C3200

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0511s ][ Queries: 12 (0.0038s) ][ GZIP on ]