Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 01 Sep 2014, 15:34
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Wine 1.0 and Wine 1.1.23
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 10 [137 Posts]   Goto page: 1, 2, 3, ..., 8, 9, 10 Next
Author Message
Wolf Pup

Joined: 27 Apr 2006
Posts: 637

PostPosted: Tue 26 Feb 2008, 22:24    Post subject:  Wine 1.0 and Wine 1.1.23
Subject description: Wine for Puppy
 

Note: needs opengl, for puppy 2 here, for puppy 3 here, for puppy dingo here, and cabextract.

2nd Note: Added a "Remove Programs" Menu entry to both wines. Smile

Stable Version:
wine-1.0.pet
md5sum

Developmental Version:
wine-1.1.23.pet
md5sum

---------------------------------------------------------------
Needed Dependency:
cabextract-1.2.pet
md5sum

_________________

Visit The Repository - Helpful and hard-to-find treats for Puppy 3.
Click Here for Puppy Support Chat, + Helpful Links.

Last edited by Wolf Pup on Sat 20 Jun 2009, 22:33; edited 34 times in total
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Mon 03 Mar 2008, 13:11    Post subject:
Subject description: alpha 6 Wine 0.9.55 and KDE358.sfs
 

Quote:
WARNING
Backup your pup_save first.


As I had indeed indication for openGL in wine 0.9.55 I installed the 7.3 one being in dingo.

It installed ok, but on next boot, no way to get x running. (nor xorg nor xvesa)
Xorgwizard is configured according the machine but I always reverts to the command prompt.

So I had to learn how to go on in the cli.
I managed to save all the files created on boot in /tmp to a usb stick.
In case it's needed I can make them available.

Now the big question.

Can I undo this openGL install from this command prompt and get my situation before the install back?

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 8229

PostPosted: Thu 06 Mar 2008, 08:53    Post subject:  

Ok

I've been stuck on wine 0.9.17 for too long as anything newer would simply crash whilst complaining of the lack of TLS.

The solution lies with this overlooked post
Quote:

1. Install the glibc 2.3.6 (you don't need 2.4 other threads report it stuffs up 2 series puppys badly)
downloaded glibc-solibs-2.3.6-i486-6.tgz
from Slackware (www.slacky.eu)


Its 100% correct and resulted in the wine version 0.9.56 posted in this thread working flawlessly in puppy 2.12...yay Smile .

I manually updated the libs which was a bit hairy but it worked so I am going to make a glibc_2xx.sfs package as a 'safe' way to implement the upgrade (well its the TLS compiled libraries which are needed rather than a version update which results in two sets .... bit of a size increase but worth it to be able to keep wine updated)

Oh the joy of changing window colors and alsa sound....... Very Happy

mike


Beem

you could try booting with pfix=ram , mounting the pup_save (xfilemount) file and removing the new libraries...should revert to original version.
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Thu 06 Mar 2008, 13:11    Post subject:  

I think updating glibc also requires new locale files (/usr/lib/locale).
When I localized Muppy with utf-8, only those from slackware worked, others from Debian did not.
The package is called "glibc-i18n".
For Puppy3/Slackware12 I used this:
http://dotpups.de/diverse-tgz/glibc-i18n-2.5-noarch-4.tgz (16 MB)

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
mikeb


Joined: 23 Nov 2006
Posts: 8229

PostPosted: Thu 06 Mar 2008, 17:07    Post subject:  

Quote:
you could try booting with pfix=ram , mounting the pup_save (xfilemount) file and removing the new libraries.


this is a great technique when trying the sfs method fails miserabley because files can only be added this way and not replaced Embarassed ah well.

Quote:

I think updating glibc also requires new locale files

seems ok as it is although mine is not unicode and the update is only glibc 2.3.5 to 2.3.6....
the slackware package does include updated gconv libs of which I used a subset.

I found glibc-solibs-2.3.6-i486-6.tgz here though is available elsewhere.

mike
Back to top
View user's profile Send private message 
Wolf Pup

Joined: 27 Apr 2006
Posts: 637

PostPosted: Wed 26 Mar 2008, 20:42    Post subject:  

Wine updated to 0.9.58
_________________

Visit The Repository - Helpful and hard-to-find treats for Puppy 3.
Click Here for Puppy Support Chat, + Helpful Links.
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Mon 14 Apr 2008, 13:28    Post subject: Re: Wine-0.9.58
Subject description: Wine for Puppy
 

Wolf Pup wrote:
Note: needs opengl, for puppy 2 here, for puppy 3 here, for puppy dingo here.

wine-0.9.58.pet
md5sum
Hi,
The md5 referenced doesn't correspond with the md5 of the downloaded pet.
Some people have problems installing, but you know, as you helped on #puppylinux.
But other may have a problem too, so can you verify this issue?

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Mon 14 Apr 2008, 20:27    Post subject:  

I downloaded it a while ago and extracted manually.
Seemed to work fine.
md5sum was: 7cf3365d03e8b77fa5d765d2522a26be
Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
Caneri

Joined: 04 Sep 2007
Posts: 1580
Location: Canada

PostPosted: Mon 14 Apr 2008, 20:38    Post subject:  

oops I missed this thread.

this .pet http://puppylinux.ca/bugs/wine-0.9.58.pet
has a md5sum of ccd305487a7927905ea1256d293a0af6 wine-0.9.58.pet

and is now correct.

reference here http://www.murga-linux.com/puppy/viewtopic.php?t=28107

Eric

_________________
Be not afraid to grow slowly, only be afraid of standing still.
Chinese Proverb

Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Mon 14 Apr 2008, 20:58    Post subject:  

thanks Eric, I can confirm your md5sum for your link.
Maybe I dowloaded somewhere else.
Your package has one more file in /root/.config/rox.sourceforge.net (a mime-type).
maybe it was repackaged later.
Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Tue 15 Apr 2008, 07:42    Post subject:  

Caneri wrote:
oops I missed this thread.

this .pet http://puppylinux.ca/bugs/wine-0.9.58.pet
has a md5sum of ccd305487a7927905ea1256d293a0af6 wine-0.9.58.pet

and is now correct.

reference here http://www.murga-linux.com/puppy/viewtopic.php?t=28107

Eric
Indeed I downloaded now for the third time and now the md5 of the pet equals the md4sum announced. Great.

P.S. Today I have a 140+KB/s download, while normally I have a 25KB/s one. Great also.

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
Wolf Pup

Joined: 27 Apr 2006
Posts: 637

PostPosted: Wed 16 Apr 2008, 09:28    Post subject:  

Wine updated to 0.9.59
_________________

Visit The Repository - Helpful and hard-to-find treats for Puppy 3.
Click Here for Puppy Support Chat, + Helpful Links.
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Wed 16 Apr 2008, 10:48    Post subject:  

For your info
Today at 16:45 Brussels time I had a stream varying between 150-160KB/s for the .59 pet

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
JustGreg

Joined: 24 May 2005
Posts: 668
Location: Connecticut USA

PostPosted: Thu 17 Apr 2008, 08:08    Post subject:
Subject description: Tried Wine 0.9.59 Pet and got these library errors
 

I downloaded both the wine 0.9.59 and xorg pets. Both installed and worked. I have tried wine 0.9.59 with Quicken 2000 ( the only windows application that I can not find a suitable replacement). It works fine. In fact, Quicken works better with the version 0.9.59 than 0.9.17. During the Wine 0.9.59 pet installation the following library errors were reported:
Code:
file /usr/lib/wine/wineesd.drv.so missing libesd.so
file /usr/lib/wine/gphoto2.ds.so missing libgphoto.so.2 and libgphoto2_port.so.0
file file /usr/lib/wine/wldap32.dll.so missing libldap_r-2.3.so.0 and liblber-2.3.so.0


I did not have any run errors with Quicken for these missing library files. I hope this helps.

_________________
Enjoy life, Just Greg
Live Well, Laugh Often, Love Much
Back to top
View user's profile Send private message 
Wolf Pup

Joined: 27 Apr 2006
Posts: 637

PostPosted: Sun 20 Apr 2008, 20:35    Post subject:  

Wine updated to 0.9.60
_________________

Visit The Repository - Helpful and hard-to-find treats for Puppy 3.
Click Here for Puppy Support Chat, + Helpful Links.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 10 [137 Posts]   Goto page: 1, 2, 3, ..., 8, 9, 10 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0821s ][ Queries: 12 (0.0048s) ][ GZIP on ]