Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 29 Jul 2014, 11:21
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
HPIJS 3.9.12
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 3 [44 Posts]   Goto page: Previous 1, 2, 3
Author Message
edoc


Joined: 07 Aug 2005
Posts: 4341
Location: Southeast Georgia, USA

PostPosted: Tue 31 Mar 2009, 19:08    Post subject:  

WOOT! WOOT! WOOT!

CUPS is talking to my HP OJ-4215!

THANKS!

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
rcrsn51


Joined: 05 Sep 2006
Posts: 8919
Location: Stratford, Ontario

PostPosted: Tue 31 Mar 2009, 21:26    Post subject:  

Glad to help. This fix comes from Patriot's work with CUPS 1.3.9.
Back to top
View user's profile Send private message 
Toppy

Joined: 11 May 2009
Posts: 10

PostPosted: Wed 20 May 2009, 09:56    Post subject: HP Deskjet F380 failed  

Hello,

Wondered if anyone could help. I'm a newbie to puppy and am using Boxpup 4.1.3 which I like a lot. Unfortunately, CUPS printing doesn't seem to work.

Puppy is Boxpup 413
Installed PET package hpijs-2.8.12.pet
Printer is an HP DeskJet F380 all-in-one printer. It's connected via USB.

Symptoms: error message when trying to print via CUPS. Nothing appears on the printer.

In the CUPS browser I get this error:
HP_F380_USB_1 "/usr/lib/cups/filter/foomatic-rip-hplip failed"

Printer details are shown here as:
Description: HP Deskjet F300 series
Location: Local Printer
Printer Driver: HP Deskjet f300 Series Foomatic/hpijs, hpijs 2.8.12.26
Printer State: idle, accepting jobs, published.
Device URI: usb://HP/Deskjet%20F300%20series?serial=CN66UGK1KD04KH

Then I changed /usr/lib/cups/filter/foomatic-rip-hplip to switch debug on.
This creates a logfile in /tmp/foomtic-rip.log
I think that this is the error:
renderer command: gs -q -dBATCH -dPARANOIDSAFER -dQUIET -dNOPAUSE -sDEVICE=ijs -sIjsServer=hpijs -dDEVICEWIDTHPOINTS=595 -dDEVICEHEIGHTPOINTS=842 -sDeviceManufacturer="HEWLETT-PACKARD" -sDeviceModel="deskjet 3600" -r300 -sIjsParams=Quality:Quality=0,Quality:ColorMode=2,Quality:MediaType=0,Quality:PenSet=1 -dIjsUseOutputFD -sOutputFile=- -
Starting process 23424: "tee -a /tmp/foomatic-rip.ps | ( foomatic-gswrapper -q -dBATCH -dPARANOIDSAFER -dQUIET -dNOPAUSE -sDE..."
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.UTF8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
foomatic-gswrapper: gs '-sstdout=%stderr' '-dBATCH' '-dPARANOIDSAFER' '-dQUIET' '-dNOPAUSE' '-sDEVICE=ijs' '-sIjsServer=hpijs' '-dDEVICEWIDTHPOINTS=595' '-dDEVICEHEIGHTPOINTS=842' '-sDeviceManufacturer=HEWLETT-PACKARD' '-sDeviceModel=deskjet 3600' '-r300' '-sIjsParams=Quality:Quality=0,Quality:ColorMode=2,Quality:MediaType=0,Quality:PenSet=1' '-dIjsUseOutputFD' '-sOutputFile=%stdout' '-'
Insecure dependency in exec while running setuid at /usr/bin/foomatic-gswrapper line 73.
Process 23424 ending: "tee -a /tmp/foomatic-rip.ps | ( foomatic-gswrapper -q -dBATCH -dPARANOIDSAFER -dQUIET -dNOPAUSE -sDE..."
renderer return value: 9
renderer received signal: 9



I didn't want to post the entire log file as it's big, but can do it if required.
Anyone have any ideas on what I should do next?
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8919
Location: Stratford, Ontario

PostPosted: Wed 20 May 2009, 22:12    Post subject:  

Go to the folder /usr/lib/cups/filter
Locate the file foomatic-rip-hplip and open it in a text editor
Change the top line to #!/usr/bin/perl -U
Save it and try to print again.
Back to top
View user's profile Send private message 
Toppy

Joined: 11 May 2009
Posts: 10

PostPosted: Thu 21 May 2009, 09:22    Post subject:  

@rcrsn51,

thanks for the help. I changed the file and restarted cups - still get the error.
I then rebooted and tried again - same error.

The log file has this - wondered if the 'inappropriate ioctl' bit had any bearing on it. Sorry, managed to miss that line in my earlier post:

Closing renderer
renderer PID kid4=7582
renderer command: gs -q -dBATCH -dPARANOIDSAFER -dQUIET -dNOPAUSE -sDEVICE=ijs -sIjsServer=hpijs -dDEVICEWIDTHPOINTS=595 -dDEVICEHEIGHTPOINTS=842 -sDeviceManufacturer="HEWLETT-PACKARD" -sDeviceModel="deskjet 3600" -r300 -sIjsParams=Quality:Quality=0,Quality:ColorMode=2,Quality:MediaType=0,Quality:PenSet=1 -dIjsUseOutputFD -sOutputFile=- -
Starting process 7583: "tee -a /tmp/foomatic-rip.ps | ( foomatic-gswrapper -q -dBATCH -dPARANOIDSAFER -dQUIET -dNOPAUSE -sDE..."
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.UTF8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
foomatic-gswrapper: gs '-sstdout=%stderr' '-dBATCH' '-dPARANOIDSAFER' '-dQUIET' '-dNOPAUSE' '-sDEVICE=ijs' '-sIjsServer=hpijs' '-dDEVICEWIDTHPOINTS=595' '-dDEVICEHEIGHTPOINTS=842' '-sDeviceManufacturer=HEWLETT-PACKARD' '-sDeviceModel=deskjet 3600' '-r300' '-sIjsParams=Quality:Quality=0,Quality:ColorMode=2,Quality:MediaType=0,Quality:PenSet=1' '-dIjsUseOutputFD' '-sOutputFile=%stdout' '-'
Insecure dependency in exec while running setuid at /usr/bin/foomatic-gswrapper line 73.
Process 7583 ending: "tee -a /tmp/foomatic-rip.ps | ( foomatic-gswrapper -q -dBATCH -dPARANOIDSAFER -dQUIET -dNOPAUSE -sDE..."
renderer return value: 9
renderer received signal: 9
KID3 exited with status 1
Renderer exit stat: 1
tail process done writing data to STDOUT
Process dying with "The renderer command line returned an unrecognized error code 9.", exit stat: 1
error: Inappropriate ioctl for device (25)

Cleaning up ...
Killing process 7582 (KID4) with signal 15
Killing process 7582 (KID4) with signal 9

Closing foomatic-rip.
Renderer process finished
Process dying with "Error closing renderer", exit stat: 1
error: Bad file descriptor (9)
Cleaning up ...
Killing process 7581 (KID3) with signal 15
Killing process 7581 (KID3) with signal 9
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8919
Location: Stratford, Ontario

PostPosted: Thu 21 May 2009, 09:38    Post subject:  

It also wants the -U patch applied to the file /usr/bin/foomatic-gswrapper. Just to be safe, also apply it to /usr/bin/foomatic-rip.
Back to top
View user's profile Send private message 
Toppy

Joined: 11 May 2009
Posts: 10

PostPosted: Thu 21 May 2009, 09:57    Post subject:    

Thanks for the amazingly quick reply and I'm glad to report that it's working now! Laughing

I just changed the first file , /usr/bin/foomatic-gswrapper , then restarted cups and the test print worked. Many thanks for your help!
Back to top
View user's profile Send private message 
Wolf Pup

Joined: 27 Apr 2006
Posts: 637

PostPosted: Sat 30 May 2009, 14:58    Post subject:  

HPIJS updated to 3.9.4b
_________________

Visit The Repository - Helpful and hard-to-find treats for Puppy 3.
Click Here for Puppy Support Chat, + Helpful Links.
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Sun 31 May 2009, 14:19    Post subject:  

Cartridges went bad in my old Deskjet3930, so picked up
an even older Deskjet3650 for a few dollars; works fine with
new driver.

With the first printer I deleted the 600+ extra drivers one by one;
this time saved the one I need and trashed the rest of the package.
Saves about 5mb of space.

thanks

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
edl

Joined: 24 Sep 2009
Posts: 10

PostPosted: Wed 14 Oct 2009, 06:14    Post subject:  

sorry
I'm looking for about PET package hpijs-2.8.12.pet. everyone could help me and say me where is it?
thanks
Back to top
View user's profile Send private message 
Wolf Pup

Joined: 27 Apr 2006
Posts: 637

PostPosted: Thu 17 Dec 2009, 20:16    Post subject:  

HPIJS updated to 3.9.12
_________________

Visit The Repository - Helpful and hard-to-find treats for Puppy 3.
Click Here for Puppy Support Chat, + Helpful Links.
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4341
Location: Southeast Georgia, USA

PostPosted: Fri 08 Jan 2010, 19:35    Post subject:  

I did a clean reload of my laptop and now my HP LJ P-1006 is not working.

I tried the hplite app and nothing.

I tried the latest HPIJS 3.9.12 and still no joy.

It all looks OK, no errors, I just get nothing when I tell it to send a Test page.

The job seems to be sent into the ether as it doesn't show up as Active or Competed.

I am running Puppy 4.31

WDYT?

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
edoc


Joined: 07 Aug 2005
Posts: 4341
Location: Southeast Georgia, USA

PostPosted: Sat 09 Jan 2010, 16:35    Post subject:  

Just observed this in CUPS:

Quote:
HP LaserJet p1006 hpijs, 3.9.12.29, requires proprietary plugin


The driver challenge for Linux is described and solved here:
http://www.foo2xqx.rkkda.com/

Puppy is not mentioned so I will look around for the Puppy PET - since using stuff for other distros often does not work ... or breaks things. Rolling Eyes

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
edoc


Joined: 07 Aug 2005
Posts: 4341
Location: Southeast Georgia, USA

PostPosted: Sat 09 Jan 2010, 16:54    Post subject:  

Solution is here:

http://www.murga-linux.com/puppy/viewtopic.php?t=33057&search_id=1885611597

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 3 of 3 [44 Posts]   Goto page: Previous 1, 2, 3
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0778s ][ Queries: 11 (0.0038s) ][ GZIP on ]