Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 18 Dec 2014, 07:33
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Touchpad scrolling on the Eeepc?
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Minnie

Joined: 01 Feb 2008
Posts: 3

PostPosted: Fri 08 Feb 2008, 21:39    Post_subject:  Touchpad scrolling on the Eeepc?  

Another person asked about how to get the touchpad to scroll. Alas, that's the same problem I'm having. We got Puppy installed on SD cards and it's running fine on the Eeepc (which is a great feat for Linux newbies!). Please, does someone know how to get the touchpad to scroll? THANKS! And thanks to the creator of the Puppy for the Eeepc - it's awesome! Very Happy
Back to top
View user's profile Send_private_message 
dvw86


Joined: 04 May 2005
Posts: 636
Location: Washington State

PostPosted: Mon 11 Feb 2008, 17:58    Post_subject:  

JustGreg found a solution to this.

Quote:
If you track pad stops working then try:
modprobe evdev
and then restart x-server from the shutdown entry in menu (menu button).

If the track pad starts working after the "modprobe evdev" command, then evdev module is not being loaded at startup. Open the file /etc/rc.d/rc.local in a text editor and check to see if the last line of the file is:"modprobe evdev". If it is not, then enter it.

I just checked with evdev loaded, the track pad will scroll.

Another way is to use the Xorg Video Wizard to re-build and re-set all the xorg files. This will reset the track pad configuration. I hope this helps.


I may write or install a gui configuration tool for the trackpad, but for now JustGreg's solution works well.
Back to top
View user's profile Send_private_message 
ricstef

Joined: 01 Aug 2006
Posts: 52
Location: Woodstock, ON. Canada

PostPosted: Tue 12 Feb 2008, 12:19    Post_subject: Touchpad scrolling on Eeepc
Sub_title: scrolling works but "tap" to select is lost.
 

Ok, tried JustGregs fix, my touchpad "scrolling" now works, but the "tap" to select feature has disappeared. "Tap to select" was working out of the box.

The mouse configurator does not have an option for "tap" to select.
Any suggestions ?

Richard.
Back to top
View user's profile Send_private_message 
Ray MK


Joined: 05 Feb 2008
Posts: 771
Location: UK

PostPosted: Tue 12 Feb 2008, 18:09    Post_subject:  

Try this - it works on both my laptops.

Go to - /root/etc/X11/xorg.conf --- Scroll way down to

Where it says Option MaxTapTime

the setting now is probably set to 0 --- change the setting to 220

Save the file and exit - Magic - mouse tap function works

Section "InputDevice"
Identifier "Synaptics Mouse"
Driver "synaptics"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "LeftEdge" "1700"
Option "RightEdge" "5300"
Option "TopEdge" "1700"
Option "BottomEdge" "4200"
Option "FingerLow" "25"
Option "FingerHigh" "30"
Option "MaxTapTime" "220" <<<<<<<<<<<<<<<<<<<<<<
Option "MaxTapMove" "220"
Option "VertScrollDelta" "100"
Option "MinSpeed" "0.10"
Option "MaxSpeed" "0.30"
Option "AccelFactor" "0.0030"
Option "SHMConfig" "on"
#Option "Repeater" "/dev/ps2mouse"
EndSection


Hope that does it - regards Ray MK
Back to top
View user's profile Send_private_message 
ricstef

Joined: 01 Aug 2006
Posts: 52
Location: Woodstock, ON. Canada

PostPosted: Tue 12 Feb 2008, 18:52    Post_subject: Touchpad scrolling on Eeepc
Sub_title: The return of the "tap" function.
 

@Ray MK

Thanks, it works again ...
After locating and editing /etc/X11/xorg.conf
I had to restart the X-server, then it worked.
ie. >Menu >Shutdown >Restart X server.

Cool, good instructions. Cool

Cheers,
Richard.
Back to top
View user's profile Send_private_message 
Minnie

Joined: 01 Feb 2008
Posts: 3

PostPosted: Sat 16 Feb 2008, 23:01    Post_subject:  Thank you all!  

Thank you all so much! I got the touchpad scrolling and then tapping again with all your help! For a linux pup I feel so proud of myself. Cool
Back to top
View user's profile Send_private_message 
dale5351

Joined: 26 Apr 2008
Posts: 5

PostPosted: Sun 27 Apr 2008, 00:01    Post_subject:  

I came here from the EeePC forum for help on a problem. I have installed Breezy (a pupeee derivative/variant) on my SDHC card. It is working fairly well but I have a problem with the touchpad. The setting is such that I am getting far too many false clicks as I attempt to navigate. I'd like to turn tapping off totally.

What I was told was to edit xorg.conf and to edit the section under input devices for synaptics touchpad to result in a line that says:
Option "MaxTapTime" "0"

I've seen similar statements in this thread. My problem is that my xorg.conf does not have a section under input devices for any sort of touchpad, only for Mouse0.

How do I get Breezy to recognize that I am using a touchpad and not a PS2 mouse like it seems to think? Under the mouse/keyboard wizard -> choose type of mouse, the only choices are PS2, serial and USB.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0624s ][ Queries: 11 (0.0039s) ][ GZIP on ]