Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 18 Apr 2014, 18:47
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Shockware in firefox (Windows) with Wine
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [7 Posts]  
Author Message
john biles


Joined: 17 Sep 2006
Posts: 1379
Location: Australia

PostPosted: Thu 07 Feb 2008, 10:00    Post subject:  Shockware in firefox (Windows) with Wine  

Hello everyone,
If you need to use Shockwave and haven't been able this is one way to do it. It's not my idea, I just read on the net that someone had done it this way and it worked.

It's not hard at all, really.
All you need to do is download the Wine version 9.17 dotpup from MU's site and install it.
Note: I tried Version 9.28 from MU's site. While it installed fine, it wouldn't install any Windows Apps I tried? where version 9.17 did?
I found I could successfully install version 1.5 of Firefox, but not version 2 or later.
Once you have Firefox installed, download flash and shockwave into your wine folder and install them by clicking on the exe.
I open wine by navigating to /usr/bin and click on the "wine file" file. I've dragged that file to my desktop for use later.

Note: This test was done in Puppy 2.14

I know that the latest version of Wine 9.54 works in Puppy 3.01 so you'd most likely be able to install a later version of Firefox.

Lastly I'm writing this using the Firefox 1.5 Windows version under Wine.

_________________
Legacy OS 2.1 LTS Released! Install me on a new! EXT2 Partition with 500Mb of swap and I'll be happy. Razz
Legacy OS 4 Released! Install to newer legacy hardware / early EeePC's Very Happy
Back to top
View user's profile Send private message Visit poster's website 
john biles


Joined: 17 Sep 2006
Posts: 1379
Location: Australia

PostPosted: Thu 07 Feb 2008, 19:43    Post subject:  

Hello Everyone,
I will continue to experiment to see if I can get Firefox 2.0 working with Wine.
If anyone else has success with Puppy 2 series and gets Firefox 2.0 going, please post how here!

_________________
Legacy OS 2.1 LTS Released! Install me on a new! EXT2 Partition with 500Mb of swap and I'll be happy. Razz
Legacy OS 4 Released! Install to newer legacy hardware / early EeePC's Very Happy
Back to top
View user's profile Send private message Visit poster's website 
john biles


Joined: 17 Sep 2006
Posts: 1379
Location: Australia

PostPosted: Thu 07 Feb 2008, 22:52    Post subject:  

Hello Everyone,
More experimenting has led to Firefox 2.0 Portable Version (Windows) working with Wine 9.17 until I changed the font sizes and it crashed and wouldn't re-open even after re-install?
Also Thunderbird 1.5.0.7 (Windows Version) appears to install fine if anyone is interested.
If anyone reading this knows of a version of Wine later than version 9.17 or (9.28 which appears to have a bug in it and will install but won't install programs) that they have got running in Puppy version 2.14 can you please list the version here.

Also does anyone know of a website that still has Firefox themes for version 1.5 as Firefox's own site only appears to list for download themes for Firefox 2.0 and later.

Lastly you maybe thinking of why do you want a Windows version of Firefox running in Linux. Basically I want "Shockwave" support which isn't available at the moment in Linux. Also it interesting to experiment in seeing what other Windows based plugins will work. I installed Flash and it works. Java didn't install and errored out, but it's early days yet. Shockwave works and that's the main thing.

_________________
Legacy OS 2.1 LTS Released! Install me on a new! EXT2 Partition with 500Mb of swap and I'll be happy. Razz
Legacy OS 4 Released! Install to newer legacy hardware / early EeePC's Very Happy
Back to top
View user's profile Send private message Visit poster's website 
john biles


Joined: 17 Sep 2006
Posts: 1379
Location: Australia

PostPosted: Fri 08 Feb 2008, 19:29    Post subject:  

Hello Again,
While I couldn't install Firefox Version 2 after surfing the net for 10 minutes or so Firefox asked if I wanted to update to version 2.0.6 and expecting problems I tried it and it worked!
I've added themes and entensions and so far so good.

If your going to to try this, remember to link your fonts in /usr/share to ~/.wine/drive_c/windows/fonts as there are no fonts included in Wine in version 9.17

Again writing this using Firefox 2.0.6 Windows version.
Firefox 2.0.6 with shockwave plugin.jpg
Description 
jpg

 Download 
Filename  Firefox 2.0.6 with shockwave plugin.jpg 
Filesize  117.57 KB 
Downloaded  441 Time(s) 

_________________
Legacy OS 2.1 LTS Released! Install me on a new! EXT2 Partition with 500Mb of swap and I'll be happy. Razz
Legacy OS 4 Released! Install to newer legacy hardware / early EeePC's Very Happy
Back to top
View user's profile Send private message Visit poster's website 
john biles


Joined: 17 Sep 2006
Posts: 1379
Location: Australia

PostPosted: Fri 08 Feb 2008, 22:49    Post subject:  

Hello Everyone,
Sorry to say upon restarting Firefox 2.0.6 it would begin to open and then crash.
It's interesting that the update went fine and Firefox appeared to work normally. So what ever is missing in the Wine Libs is most likely only required to start Firefox 2.0.6 and may not be required to keep it running?

OH Well, back to Firefox 1.5.0.7
Back to more experimenting

_________________
Legacy OS 2.1 LTS Released! Install me on a new! EXT2 Partition with 500Mb of swap and I'll be happy. Razz
Legacy OS 4 Released! Install to newer legacy hardware / early EeePC's Very Happy
Back to top
View user's profile Send private message Visit poster's website 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Sat 09 Feb 2008, 05:38    Post subject:  

john biles wrote:
Hello Again,
While I couldn't install Firefox Version 2 after surfing the net for 10 minutes or so Firefox asked if I wanted to update to version 2.0.6 and expecting problems I tried it and it worked!
I've added themes and entensions and so far so good.

If your going to to try this, remember to link your fonts in /usr/share to ~/.wine/drive_c/windows/fonts as there are no fonts included in Wine in version 9.17

Again writing this using Firefox 2.0.6 Windows version.

Hi,
Your uploaded picture is way to wide for small screens.
Can you please upload images which are not larger then 700 pixel.
Thank you.

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
john biles


Joined: 17 Sep 2006
Posts: 1379
Location: Australia

PostPosted: Sun 10 Feb 2008, 09:58    Post subject:  

Hello Everyone,
After days of testing this is what I can recommend.
Wine dotpup version 9.17 works. Wine dotpup version 9.28 had problems and by the postings on this forum at the time it was posted, not many got it to work, which is a real shame.
Checking at the Wine site showed that from version 9.27 Firefox 2 appeared to work.
So if your using Puppy 2 series then install Wine version 9.17 from MU's site. Then find a copy of Firefox 1.5 for Windows and install it.
Now as above in earlier postings link your fonts to wine or Firefox's fonts looks really ugly.
Now you'll be able like a Windows User to easily install Flash when you visit Youtube and install shockwave for Adobe. The later you'll need to download first.
I've had enough in trying to get Firefox 2 working and after days working on and off on this I feel like smashing this screen with a hammer.
To tell you the true there is much to love about Linux. But until I can install a program by just clicking on a exe file like the average Windows user can and expect it to work, Linux is going to be used by the selected few who use it now.
One great advantage about this is Linux will still be the number one OS for surfing the net and not have to worry about many nasties EG Virus's
As before writing this from Firefox 1.5 running in Wine

_________________
Legacy OS 2.1 LTS Released! Install me on a new! EXT2 Partition with 500Mb of swap and I'll be happy. Razz
Legacy OS 4 Released! Install to newer legacy hardware / early EeePC's Very Happy
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [7 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0561s ][ Queries: 12 (0.0065s) ][ GZIP on ]