Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Oct 2014, 13:58
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
New Pup for the Eeepc based on Puppy 301
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 29 [422 Posts]   Goto page: 1, 2, 3, ..., 27, 28, 29 Next
Author Message
dvw86


Joined: 04 May 2005
Posts: 636
Location: Washington State

PostPosted: Tue 29 Jan 2008, 23:20    Post subject:  New Pup for the Eeepc based on Puppy 301
Subject description: dvw86 makes a iso just for the Eeepc (and Intel Classmate)
 


***UPDATE 2/17/08***
I have changed the main server location. Thanks goes to 1ColdBeer. The new location is:
http://epc.waltonpond.com

You can still download from the mirror hosted by Caneri.
http://puppylinux.ca/members/Pupeee/
********************


Well here it is. The first release of ... What do I call it? Pupeee? Whatever the name, this is an iso that I put together for the Asus Eeepc. It should work for the Intel Classmate as well, but I can not test that since I don't have one. It is a basic install of 301 with all the needed drivers installed. It should boot right up without asking for keyboard layout or screen resolution. Sound works right out of the box (the mic works as well). The webcam modules are installed but I have not been able to get it to work. The wireless card will show up the first time you run the connect wizard. The built in Ethernet port drivers are installed but not loaded. It is listed in the "load module" screen though. ACPI drivers are installed for the numlock and scroll lock keys. Volume up, down, mute, and print screen keys work but you have to use the alt key instead of the function key. The screen brightness keys work with the function key. Other additional items include:

Batmon the battery monitor.
A custom JWM-Tray file with auto hide on to help make use of the small screen.
gtkpod
xmms
xine-ui
xine extra codecs
GQview
English dictionary for Abiword.
A few wallpapers that I liked. My wife took the picture of the default background from our back porch.
A few other things that I may have forgotten.


***UPDATED 2/4/08***
New iso uploaded.

Updates include:
Webcam works! (Be sure to enable it in the bios)
Skype Beta 2 with webcam support.
Better startup script for batmon. (no popup box on first boot)
Rox icons set to automatic size instead of large.
More apps added to the "open with" menu.


***UPDATE 2/21/2008***
New iso uploaded.
It still has the little JWM bug where you have to re-choose the black Vista theme after your second boot (first boot from your pupsave file). This has some requested features and it's not that serious of a bug so I wanted to post it anyways. Updates include:

Trackpad scroll and tap enabled by default.
Asapm battery monitor replaces Batmon.
The shut down bug eliminated (hopefully).
The wireless driver rt2570 is blacklisted since it causes problems on the Classmate. (thanks to Caneri).
New JWM look.

***UPDATE 3/16/2008***
New iso uploaded

Skype is still installed but it is no longer on the desktop. I put it in the start menu instead.
Cleaned up the rest of the start menu a bit. Some of the .desktop files needed modified.
Added icons for the "Open With" menu.
Xmms has been updated to work with ACC files also known as MP4. It still will not work with Apples protected (DRM) ACC files though.
New default wallpaper. (Thanks to Lobster)
Audacity is installed.
Handbrake is installed.
Xplns is installed.
Puppy Control Panel is installed along with murgaLua. This changes a lot of things both now and in the future.
The new Puppy Control Panel gets rid of that annoying JWM bug of having to re-choose the theme.
My Simple Calculator is installed.
sysmsg is installed.
Removed the current gftp server tool as this is now part of the control panel.
Removed the current JWM configuration tool from the start menu since it is now part of the control panel. (It is still in the iso since it is small, but it is not listed in the start menu)
Removed the firewall wizard from the start menu since it is now part of the control panel.
Removed the "Connect" icon from the desktop since it is now part of the control panel.
Removed the network wizard from the start menu since it is now part of the control panel.

Be sure to use a fresh pupsave and delete or rename the old pup_301-eee.sfs file.

md5sum
150a1d9f61160babc04a772b7d3b25dc

Mirrors are welcome Wink
Size is 139MB
http://waltonpond.com/eeepc/2008-3-16/pupeee-b4.iso

Last edited by dvw86 on Sun 16 Mar 2008, 22:37; edited 7 times in total
Back to top
View user's profile Send private message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Wed 30 Jan 2008, 00:30    Post subject:  

Very Happy Congratulations

Any pics of it running?
Who is gonna try it on the Classmate?

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
dvw86


Joined: 04 May 2005
Posts: 636
Location: Washington State

PostPosted: Wed 30 Jan 2008, 00:54    Post subject:  

Here you go.
Back to top
View user's profile Send private message 
dvw86


Joined: 04 May 2005
Posts: 636
Location: Washington State

PostPosted: Wed 30 Jan 2008, 01:02    Post subject:  

And another.
Back to top
View user's profile Send private message 
vabene06

Joined: 25 Apr 2006
Posts: 36

PostPosted: Wed 30 Jan 2008, 15:23    Post subject:  

Hallo,
i tried the iso, it works fine. only the webcam does not work. when i try to modprobe uvcvideo i get the error "unknown symbol v4l_compat_ioctl32
'.
i used the uvcvideo.pet from the forum. can you compile the uvcvideo from your distro? vabene
Back to top
View user's profile Send private message 
dvw86


Joined: 04 May 2005
Posts: 636
Location: Washington State

PostPosted: Wed 30 Jan 2008, 18:11    Post subject:  

vabene06 wrote:
Hallo,
i tried the iso, it works fine. only the webcam does not work. when i try to modprobe uvcvideo i get the error "unknown symbol v4l_compat_ioctl32
'.
i used the uvcvideo.pet from the forum. can you compile the uvcvideo from your distro? vabene


As I mentioned in the first post, the correct webcam drivers are already installed. However I have not been able to get it to work. I will update the iso when the issue is resolved. If someone finds a way of getting it to work please let me know. Thanks
Back to top
View user's profile Send private message 
klu9

Joined: 27 Jun 2007
Posts: 345

PostPosted: Wed 30 Jan 2008, 20:19    Post subject: Re: New Pup for the Eeepc based on Puppy 301
Subject description: dvw86 makes a iso just for the Eeepc (and Intel Classmate)
 

dvw86 wrote:
Mirrors are welcome Wink

http://www.vanwormerfamily.com/usb-linux/puppy/puppy-eee.iso

I'll try to download and then share via BitTorrent, to save your server some hits.
Quote:
I will update the iso when the issue is resolved.

When you do, try releasing an xdelta patch, so those with the previous ISO can just download the small patch & upgrade, rather than downloading a whole new ISO.

http://puppylinux.org/wikka/XdeltA

PS Congratulations on your puplet! I can't wait till my money comes in; I desperately want to buy an EeePC or a CloudBook.
Back to top
View user's profile Send private message 
dvw86


Joined: 04 May 2005
Posts: 636
Location: Washington State

PostPosted: Wed 30 Jan 2008, 20:48    Post subject:  

Will do. thanks for the mirror.
Back to top
View user's profile Send private message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Wed 30 Jan 2008, 22:50    Post subject:  

Any newshounds available to place it here Question
http://www.puppylinux.org/wikka/LatestNews

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
klu9

Joined: 27 Jun 2007
Posts: 345

PostPosted: Thu 31 Jan 2008, 23:37    Post subject:  

Damn, my download failed during the night.

Well here's one instant way of "mirroring": CoBlitz

Here's a CoBlitzed download link for your ISO, if you get people to use this instead, the burden should be shared out over the PlanetLab network.

http://coblitz.codeen.org/www.vanwormerfamily.com/usb-linux/puppy/puppy-eee.iso
Back to top
View user's profile Send private message 
dvw86


Joined: 04 May 2005
Posts: 636
Location: Washington State

PostPosted: Fri 01 Feb 2008, 00:50    Post subject:  

Thanks to Caneri, we now have a mirror Very Happy


http://puppylinux.ca/members/Pupeee/
Back to top
View user's profile Send private message 
vabene06

Joined: 25 Apr 2006
Posts: 36

PostPosted: Fri 01 Feb 2008, 11:00    Post subject:  

i got the webcam working, but only with videoview. I did
modprobe videodev, modprobe uvcvideo and started videoview.
vabene
Back to top
View user's profile Send private message 
JustGreg

Joined: 24 May 2005
Posts: 694
Location: Connecticut USA

PostPosted: Fri 01 Feb 2008, 15:54    Post subject:
Subject description: Tried it!
 

I downloaded the iso and installed it manually to a SD card. It works well. Both audio and wifi did work. It was nice to be able to connect to my wpa2 home wifi network without a problem.

I did the webcam using vabene06 procedure. When using "modprobe uvcvideo", I got missing module error. I installed the uvcvideo-20070706-k2.pet. I got the same error as vabene06, v4l_compat_ioctl32. There was a forum post (Asus EEE webcam woes) where this was talked about. I tried the following:
Code:
modprobe videodev
modprobe compat_ioctl32
modprobe uvcvideo

and everything installed without any error messages. I tried to use videoview (worked for vabene06) in a terminal window and got no such command. Videoview is an add on that I found after a google search. 4 February 2008, I have removed the attachment due to a license restriction on distribution. I do not want to cause any trouble for the board operator. Here is the location, where one can download videoview:
http://www.linux-projects.org/modules/mydownloads/viewcat.php?cid=5

However, when I run videoview, no video devices are detected. I checked /dev/ and video Ilink to video0), video0 and video1 exists. Any ideas? Thanks in advance for any help!

Here are some suggestions for the next build: Have Rox use small icons rather than large. It makes the file manager window easier to see. Please consider using the new battery monitor in Dingo. It looks nicer than batmon. Since the Eee PC does not have a CDROM, it is easier to use a zip file than an iso, especially with Xandros. Raffy's breeezy version of Puppy does this.

This is a nice version of Puppy for the Eee PC.

_________________
Enjoy life, Just Greg
Live Well, Laugh Often, Love Much

Last edited by JustGreg on Mon 04 Feb 2008, 16:15; edited 2 times in total
Back to top
View user's profile Send private message 
JustGreg

Joined: 24 May 2005
Posts: 694
Location: Connecticut USA

PostPosted: Fri 01 Feb 2008, 20:02    Post subject:
Subject description: The problem with Videoview was a BIOS setting
 

I think some the Eee PC come with the web camera disabled in the BIOS. This has no effect on web camera application that comes with Xandros. However, it prevents Puppy from having an active web camera. I enable the web camera using the BIOS setup. Videoview now works well. I can see my face as I type. If you are having problems with the web camera then check the BIOS setup (Press F2 at boot screen) to see if the web camera is disabled.

The sequence of modprobes in the above post is correct to get everything working.

_________________
Enjoy life, Just Greg
Live Well, Laugh Often, Love Much
Back to top
View user's profile Send private message 
nyu


Joined: 14 Mar 2006
Posts: 110
Location: good earth

PostPosted: Sat 02 Feb 2008, 01:00    Post subject:  

Hi dvw86,

Thanks for making pupeee3.01. I downloaded it and installed it in my
1GB SD card. It booted without any problem. 800x480 display was
fantastic! Wireless setup was a snap. One problem I am facing is
the Touchpad. I can't scroll up/down of web pages. Does anyone
know how to solve this problem?

Thanks,
nyu
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 29 [422 Posts]   Goto page: 1, 2, 3, ..., 27, 28, 29 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0921s ][ Queries: 12 (0.0088s) ][ GZIP on ]