Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 22 Aug 2014, 11:41
All times are UTC - 4
 Forum index » Advanced Topics » Hardware
invisible/defective mouse cursor under XOrg
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
prehistoric


Joined: 23 Oct 2007
Posts: 1265

PostPosted: Wed 23 Jan 2008, 17:09    Post subject:  invisible/defective mouse cursor under XOrg  

Hi Folks,

This is an old issue that keeps returning after I assume it has been put to rest. On some machines the XOrg wizard sets everything correctly, except that the cursor is either invisible or messsed up. (I am not talking about what happens if you set "autohide mouse cursor".) In some cases the cursor is totally invisible, all the time. In others it looks OK until you try to move it. In some old machines the cursor appears as a block instead of its usual shape. Here are two comments typical of the problem:
Quote:
I had some problems with an invisible mouse cursor when using the "nv"-driver. Has somebody else similar problems or does somebody know how to fix this?

Here's a fix from the KDE board.
Quote:
"On Friday 26 January 2007 10:27, Marcelo Magno T. Sales wrote:
> Is your video card an nvidia one? If so, there's a bug in nvidia driver
> that causes exactly this problem with some nvidia cards (not all). The
> workaround is to disable hardware cursor in xorg.conf.
> Add the following line in the device section for your video card:
> Option "HWCursor" "off"

I added that line and have not had the problem since.

(Note: In different versions the flag may be "HW_cursor" or "HW_Cursor". The flags are usually in the file, but commented out.)
These were problems which surfaced with the nv driver, not nVidia's official driver. I have also seen this with an early nForce2 motherboard and a recent board with nVidia 6150 graphics, both of these are embedded graphics processors which use shared ram. In the past there were problems with some (not all) i810 chipsets. (The problem here is that there were so many steppings of the i810 you can't be sure you are running the exact same chips in the same way unless you check carefully.)

I mentioned this to rerwin while he was working on a new XOrg wizard. I have learned to move the mouse during the test to make sure the cursor tracks it properly and felt this should be in the test message. At present both machines on which I could demonstrate the problem are dead (zapped by lightning.) Can anyone else give rerwin an example where it was necessary to make the change to the conf file to turn off the hardware cursor?

If we can eliminate this problem without requiring people to edit the conf file themselves we remove one more stumbling block for newbies.

Regards,

prehistoric
Back to top
View user's profile Send private message 
bvjones59


Joined: 06 May 2007
Posts: 76

PostPosted: Sun 27 Jan 2008, 22:37    Post subject: Me Too!
Subject description: invisible mouse problem
 

I have run into this problem off and on since I first started playing with Puppy at version 2.14. It happened pretty consistently while using some of the stripped down variants I was testing on older machines. I ran into it again just today, while "upgrading" from Puppy 3.0 to PCPuppy 3.01. My regular Puppy had not had trouble, but when running PCpup from RAM I lost the mouse. Two reboots later, it worked, and I clean-installed it over the previous Puppy and it's working fine now.

I do have an NVidia "card" as part of my motherboard, and never realized that might be the problem (and yes, I am a newbie to Linux, but getting better)! The problem for me seems very sporadic and I'm not sure I could reliably reproduce it.

My observations at the time were that Puppy was not consistently detecting my USB mouse. I believe those were not always found in some of the earlier pre-2.15 versions. So I switched to an old PS2 mouse I had lying around - easier than curing the "bug" for me at that point. I have NEVER had a problem with a PS2 mouse in Puppy.

So, I can possibly eliminate this problem by moving the mouse a bit during boot-up? Or by changing a line in xorg.conf? One caveat to the "line-change" solution: if you are already not seeing the mouse curser, navigation is pretty much impossible. Wink I do agree that putting some mention of the NVidia bug in the xorg setup wizard would be helpful. Which reminds me, I did notice that on the times I lost my mouse cursor, I also did not see it on the "Test" screen during the setup. Perhaps that could be an early warning!

B
Back to top
View user's profile Send private message 
prehistoric


Joined: 23 Oct 2007
Posts: 1265

PostPosted: Mon 28 Jan 2008, 09:35    Post subject: not just nVidia  

@bvjones59,

This isn't peculiar to nVidia graphics, I have also seen it on some Intel embedded graphics systems, and even Via UniChrome. I haven't been using a USB mouse so the problem I'm reporting couldn't be due to that.

My guess is that it is due to subtle differences in timing when using shared video memory, where the chip designer assumed one thing and the manufacturer or customer put in memory with different characteristics. (Not always cheap memory, just different timing.) And, yes, now I always move the mouse during XOrg test to make sure the cursor is visible and tracks the mouse. I don't know that moving the mouse during boot up affects this.
Quote:
One caveat to the "line-change" solution: if you are already not seeing the mouse curser, navigation is pretty much impossible.

As an old Unix type who predates this new-fangled GUI stuff, I have the habit of going to the command line with control-alt-backspace, making the edit there, then restarting XOrg with "xwin". Very Happy

There is actually a place in the xorgwizard where you can edit the conf file, if you know how to get there. (I must also confess to sometimes flying blind while running X and just moving the invisible mouse until a right click brings up the main menu, from which I can launch a text editor and use the arrow keys then restart the X window system. Not a good newbie solution.) The best solution would be a check box or button in the wizard to disable hardware mouse cursor acceleration before you run the test again. (This is the solution in XFdrake, used by Mandriva and PCLinuxOS.)

prehistoric
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0667s ][ Queries: 11 (0.0159s) ][ GZIP on ]