Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 17 Dec 2014, 22:42
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
fluxbox-1.0.0 - window manager
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
plinej

Joined: 13 Aug 2006
Posts: 1522

PostPosted: Tue 20 Nov 2007, 00:13    Post_subject:  fluxbox-1.0.0 - window manager  

I couldn't get fluxbox to compile in 4.0-alpha-1 but the slackware binaries seem to work fine so here they are packaged for puppy. This package was probably compiled w/o imlib2 since there are no menu icons. I also modified the fluxbox xdg menu package that I found on MU's site to work correctly with Puppy's xdg menus.

instructions:

Install the fluxbox dotpet & the fluxbox xdg dotpet, exit to prompt and enter:

# xwin startfluxbox

Open up a terminal in fluxbox and enter:

# fluxbox_menu_refresh

Now your puppy menu should be working.
fluxbox-xdg-plinej-0.7.6.pet
Description 
pet

 Download 
Filename  fluxbox-xdg-plinej-0.7.6.pet 
Filesize  3.53 KB 
Downloaded  850 Time(s) 
fluxbox-1.0.0.pet
Description 
pet

 Download 
Filename  fluxbox-1.0.0.pet 
Filesize  803.8 KB 
Downloaded  840 Time(s) 
Back to top
View user's profile Send_private_message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15122
Location: Paradox Realm

PostPosted: Tue 20 Nov 2007, 06:22    Post_subject:  


Very Happy Worked perfectly in Puppy 3.01 puplet Tmxxine

For those who are wondering . . . it is a window manager (themes)
that allows access to the menu options with a right mouse click

Fast and efficient. Many experienced Linux users prefer it.

I like it. See what you think. It is free after all . . .

Update:
I used it for a week - more than happy with it
Fast efficient - different true enough - makes use of the right mouse click
I changed - just for a change - never been a fan of fluxbox but now my opinion is much more favourable

If you are a Windows user then JWM (Puppy default) and IceWM will be more familiar. xfce is easy for most people to pick up. Fluxbox is probably faster on older machines were speed is more of an issue but I can not vouch for that

Many thanks plinej Smile

_________________
Puppy WIKI
Back to top
View user's profile Send_private_message Visit_website 
zygo

Joined: 08 Apr 2006
Posts: 211
Location: UK

PostPosted: Thu 03 Jan 2008, 02:16    Post_subject: Restart X left me with a picture of nothing
Sub_title: Restart X left me with a picture of nothing
 

Thanks for this plinej. I'm using puppy 301 and vesa. Very nice... But I was trying to get my transparency settings to show and nothing seemed to work. When I finally selected Restart X something strange happened. I was left with a picture of nothing. The monitor didn't turn off because it was still getting a signal. The caps lock key and LED were working but typing ctrl+alt+bkspc did nothing and nor did "xwin ENTER". I had to reboot.

Anyone else had this or know how to fix it (or it's cause)?
Back to top
View user's profile Send_private_message 
playdayz


Joined: 25 Apr 2008
Posts: 3789

PostPosted: Thu 12 Jun 2008, 13:52    Post_subject: Thanks 2  

Yes indeed, thanks for making this--it was very useful to me. Here's why. I had a particular look in mind, I had always liked the Results and some other blackbox styles and I want to use them and a dock in the middle right with just 3 or 4 icons. Except blackbox-0.70 had to be patched to work right with bbdock--and when I patched it and compiled the size went from ~334K to 3300K--yes, ten times bigger. Man that was some kind of patch! It worked fine but a huge blackbox kind of defeated the purpose. So I tried fluxbox. Fluxbox did compile for me on Dingo 4, but it was 11MB!!! I barely know enough to compile things--I have no clue about why this happens. Openbox compiled right at 250K and ran nicely but something was screwey about the backgrounds--and it doesn't use the same styule format. Fluxbox is bigger, as you know, smaller would make me happier, but it runs well and the size is the same on some other distors. Plus, I didn't know how to do the nice thing you did to update the menu.

Since we have some Buddhist puppies around here I would say the look is serene and empty--it is nice to have something so totally different. and usable too thanks again for makjing it happen.
Back to top
View user's profile Send_private_message 
plinej

Joined: 13 Aug 2006
Posts: 1522

PostPosted: Thu 12 Jun 2008, 16:47    Post_subject:  

Your binaries were probably that large because they need to be stripped. Change into the directory where your blackbox executable is and type:

Code:

# strip -s blackbox


Do the same for all the executables & libraries.
Back to top
View user's profile Send_private_message 
shankargopal

Joined: 03 Dec 2005
Posts: 295

PostPosted: Mon 23 Jun 2008, 10:11    Post_subject:  

Having strange problems with fluxbox on puppy 3.00...

My main WM is Enlightenment DR17, but since I occasionally use a really low mem computer I installed this dotpet too. It looks great. But there are some really odd problems I'm experiencing:

Fluxbox runs fine for the first few minutes. But after I start running a few programs, it stops responding to right-click, Alt-Tab, mouse wheel on desktop, etc. - in fact it does not respond to any input at all except in the form of mouse actions over the toolbar (e.g. switching between programs or workspaces) - which continue to work fine. Alt-Tabs in programs are conveyed to the programs as inputs. But even in workspaces that are completely empty (i.e. nothing running), right click, mouse wheel, etc. still don't work.

Is some setting wrong? If it is of help, I am using fbsetbg to set a different background. I am not able to identify if the problems start with any particular software - it could be when running a Curses program in an rxvt window, but not sure. Could anyone help?
Back to top
View user's profile Send_private_message 
Paolo


Joined: 09 Dec 2005
Posts: 17
Location: Italy

PostPosted: Fri 27 Jun 2008, 08:43    Post_subject:  

Hello ! I follow all the istruction of the first post and all is ok (Fluxbox+ menu icons)

But when I restart the laptop the menu icons disappears and I must write
on the terminal "jwm2fluxbox".

Can someone help me please ?

I think Fluxbox is the best for Puppy Laughing

I have now Puppy 4.0+Ezpup v.3 + Conky 1.5.1 +Fluxbox

Thanxxx !!!!!!!!!!!

Paolo

_________________
Notebook Dell Latitude c6oo ... all for Fire Hydrant Inferno Smile
Back to top
View user's profile Send_private_message 
trapster


Joined: 28 Nov 2005
Posts: 2030
Location: Maine, USA

PostPosted: Sun 29 Jun 2008, 07:23    Post_subject:  

Paolo,

I'm not sure why jwm2fluxbox doesn't stick but you can put the command in the hidden /root/.fluxbox/startup file

_________________
trapster
Maine, USA

Asus eeepc 1005HA PU1X-BK
Frugal install: Puppeee4.31 + 1.0, Puppy4.10 + Lupu52
Currently using Slacko AND lupu52 w/ fluxbox
Back to top
View user's profile Send_private_message Visit_website 
Paolo


Joined: 09 Dec 2005
Posts: 17
Location: Italy

PostPosted: Sun 29 Jun 2008, 16:52    Post_subject:  

hello Trapster,

You mean I can write "jwm2fluxbox" in that file ?

Paolo

_________________
Notebook Dell Latitude c6oo ... all for Fire Hydrant Inferno Smile
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0679s ][ Queries: 12 (0.0041s) ][ GZIP on ]