Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 15 Sep 2014, 20:55
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
devx_301.sfs Bug
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
mohan34u


Joined: 14 Nov 2007
Posts: 67

PostPosted: Wed 14 Nov 2007, 03:34    Post subject:  devx_301.sfs Bug
Subject description: Can't compile a C program
 

After Download and mount devx_301.sfs, I can't compile a C program. the full typescript is here..

#cat test.c

#include<stdio.h>
int main(){
printf("\nHello World");
return(0);
}

#gcc test.c

In file included from /usr/include/features.h:346,
from /usr/include/stdio.h:28,
from test.c:1:
/usr/include/gnu/stubs.h:11:3: error: #error "unexpected value for __WORDSIZE macro"
In file included from /usr/include/stdio.h:72,
from test.c:1:
/usr/include/libio.h:296: error: expected specifier-qualifier-list before '_G_off_t'
/usr/include/libio.h:360: error: expected '=', ',', ';', 'asm' or '__attribute__' before '__io_read_fn'
/usr/include/libio.h:368: error: expected '=', ',', ';', 'asm' or '__attribute__' before '__io_write_fn'
/usr/include/libio.h:377: error: expected declaration specifiers or '...' before '_G_off64_t'
/usr/include/libio.h:415: error: expected '=', ',', ';', 'asm' or '__attribute__' before '__wunderflow'
/usr/include/libio.h:416: error: expected '=', ',', ';', 'asm' or '__attribute__' before '__wuflow'
/usr/include/libio.h:417: error: expected '=', ',', ';', 'asm' or '__attribute__' before '__woverflow'
/usr/include/libio.h:481: error: expected declaration specifiers or '...' before '_G_va_list'
/usr/include/libio.h:483: error: expected declaration specifiers or '...' before '_G_va_list'
/usr/include/libio.h:484: error: expected '=', ',', ';', 'asm' or '__attribute__' before '_IO_padn'
/usr/include/libio.h:485: error: expected '=', ',', ';', 'asm' or '__attribute__' before '_IO_sgetn'
/usr/include/libio.h:487: error: expected '=', ',', ';', 'asm' or '__attribute__' before '_IO_seekoff'
/usr/include/libio.h:488: error: expected '=', ',', ';', 'asm' or '__attribute__' before '_IO_seekpos'
In file included from test.c:1:
/usr/include/stdio.h:88: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'fpos_t'
In file included from test.c:1:
/usr/include/stdio.h:341: error: expected declaration specifiers or '...' before '_G_va_list'
/usr/include/stdio.h:346: error: expected declaration specifiers or '...' before '_G_va_list'
/usr/include/stdio.h:349: error: expected declaration specifiers or '...' before '_G_va_list'
/usr/include/stdio.h:360: error: expected declaration specifiers or '...' before '_G_va_list'
/usr/include/stdio.h:672: error: expected declaration specifiers or '...' before '__off_t'
/usr/include/stdio.h:677: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'ftello'
/usr/include/stdio.h:697: error: expected declaration specifiers or '...' before 'fpos_t'
/usr/include/stdio.h:702: error: expected ';', ',' or ')' before '*' token

#

the system I compiled..

Intel Pentium D 2.66GHz(1GB RAM)
linux 2.6.21.7
gcc 4.1.2
Back to top
View user's profile Send private message Visit poster's website 
mohan34u


Joined: 14 Nov 2007
Posts: 67

PostPosted: Wed 14 Nov 2007, 03:37    Post subject: Aditional Info
Subject description: Puppy Version
 

Sorry to mention..

Puppy Version : Puppy 3.01(Seamonkey)..
Back to top
View user's profile Send private message Visit poster's website 
HairyWill


Joined: 26 May 2006
Posts: 2949
Location: Southampton, UK

PostPosted: Wed 14 Nov 2007, 07:33    Post subject: Re: devx_301.sfs Bug
Subject description: Can't compile a C program
 

this works fine for me in 3.01
have you checked the md5 of your devx file

if this is ok you might want to post the lines in the header files that gcc is complaining about.

_________________
Will
contribute: community website, screenshots, puplets, wiki, rss
Back to top
View user's profile Send private message 
mohan34u


Joined: 14 Nov 2007
Posts: 67

PostPosted: Thu 15 Nov 2007, 01:38    Post subject: devx_301.sfs not downloaded correctly
Subject description: the problem occurred because of incorrect download
 

Thanks mate,

This is my download fault. Once again, I downloaded and checked the md5. After that I mounted and check for a simple C program. Its working.
Back to top
View user's profile Send private message Visit poster's website 
HairyWill


Joined: 26 May 2006
Posts: 2949
Location: Southampton, UK

PostPosted: Thu 15 Nov 2007, 02:39    Post subject:  

glad its working
_________________
Will
contribute: community website, screenshots, puplets, wiki, rss
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0539s ][ Queries: 11 (0.0093s) ][ GZIP on ]