Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 19 Dec 2014, 04:04
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
SOLVED Problem printing via turboprint to Canon S520 inkjet
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
r__hughes

Joined: 13 Apr 2006
Posts: 343
Location: Canada

PostPosted: Thu 08 Nov 2007, 15:41    Post subject:  SOLVED Problem printing via turboprint to Canon S520 inkjet
Subject description: seamonkey prints but not abiword, gnumeric or notepad
 

Live CD puppy 3.01 on an AMD K6 3D 476MHz/384MBram
Trying to print to a Canon S520 inkjet using turboprint-1.96-3.tgz. Installation went OK with printer installed as device CUPS/tp0 which is defined as Device URI: parallel:/dev/lp0
- but I have 2 problems:-

1) I can print from seamonkey but not from abiword, gnumeric or notepad - first 2 crash if printer dev is changed from lpr to CUPS/tp0 & hang if lpr is changed to /dev/lp0---- Any ideas? Do I need devx_301.sfs?

2) using http://localhost:631 I can see my Canon-s520 printer definition but the pdf-printer is the default. If I try to set the canon as the default I get a username/password box - this appears twice for anything I enter (is there a correct puppy secret username/password?) then I get a blank seamonkey page:
http://localhost:631/admin/?op=set-as-default&printer_name=tp0
--- nothing I try will change the canon to default printer.

Last edited by r__hughes on Wed 21 Nov 2007, 14:27; edited 1 time in total
Back to top
View user's profile Send private message 
r__hughes

Joined: 13 Apr 2006
Posts: 343
Location: Canada

PostPosted: Thu 15 Nov 2007, 15:43    Post subject:  

I found the answer in this post - many thanks to bucehohl

http://www.murga-linux.com/puppy/viewtopic.php?t=23286

briefly - there is a command line option that lets you (re)define the default CUPS printer- and bypass the localhost:631 password barrier. Once this is done Abiword and Gnumeric will print via lpr to the newly defined default printer.

I forgot to use the turboprint xtpsetup to set tp0 as default at the start since xtpsetup changes the CUPS printer page directly and this led to a comedy of errors because once you use the commandline lpoption -d it locks out further CUPS page attempts.- so ----

1) If the commandline -
Code:
lpoptions -d tp0

has been used to set the default printer it will have created a file
/etc/cups/lpoptions which will override any subsequent CUPS localhost:631
printer page selection - REMOVE IT!!!

2) Get CUPS localhost:631 print select page to work properly by defining the root password to a new value using the commandline -
Code:
passwd root

then enter a new password (like root) at the prompt.

3) Use CUPS localhost:631 printer page selection to set the default printer, now the username/password can be entered (root root) and the selection will work. This will be confirmed by the commandline -
Code:
lpstatus -d

which will now track the CUPS page selections.
-------------------------------------------
edited 21nov07
I find I have to use the lpoptions command to print to a networked pup301 printer e.g.
lpoptions -d tp0@192.168.0.101
but when the networked pup is offline, lpstat -d still shows it as default - - - so I put the following lines in /etc/rc.d/rc.local to remove any old manual printer default settings at bootup ---

Code:
# remove any old manual lp defaults
if [ -e /etc/cups/lpoptions ];then
  rm /etc/cups/lpoptions
fi
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0461s ][ Queries: 11 (0.0041s) ][ GZIP on ]