Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Oct 2014, 00:22
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Tecra/Protege stops booting at Xvesa and Xorg (SOLVED)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 12 of 12 [167 Posts]   Goto page: Previous 1, 2, 3, ..., 10, 11, 12
Author Message
herrdeh

Joined: 19 Jan 2012
Posts: 8

PostPosted: Thu 19 Jan 2012, 15:34    Post subject:  

Hi everybody,

I'll try to relaunch this old thread…

Tried to install puppy 5.3.1 slacko today on my girl's Toshiba satellite 1805 with (wow!) 1GB of RAM.

As I expected it would fail when probing the xserver. As I have a working ubuntu (but: no hardware acceleration, that was broken sometimes around ubuntu 7), I mounted the hdd and copied the (known good, exept hardware acceleration) xorg.conf to puppy's /etc/X11. startx or xwin failed both.

I do attach ubuntu's the xorg.conf here - maybe somebody will find something:

Code:
# xorg.conf (X.Org X Window System server configuration file)
#
# Custom file by Michael Minn

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "Kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protoxol" "ImPS/2"
EndSection

Section "Device"
    Identifier    "Trident Microsystems cyberbladeAi1d"
    Driver        "trident"
    BusID        "PCI:1:0:0"
    Option "NoDDC"
EndSection

# Section "Device"
#   Identifier  "Card0"
#   Driver      "trident"
#   VendorName  "Trident Microsystems"
#   BoardName   "CyberBladeAi1d"
#   BusID       "PCI:1:0:0"
# EndSection


Section "Monitor"
    Identifier    "ToshLCD"
    Option        "DPMS"
    HorizSync      30-71
    VertRefresh    50-100
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Monitor       "ToshLCD"
    Device        "Trident Microsystems cyberbladeAi1d"
    DefaultDepth    16
    SubSection "Display"
        Depth        16
        Modes        "1024x768"
    EndSubSection
    SubSection "Display"
        Depth        24
        Modes        "1024x768"
    EndSubSection
    SubSection "Display"
        Depth        16
        Modes        "800x600"
    EndSubSection
    SubSection "Display"
        Depth        24
        Modes        "800x600"
    EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Configured Mouse"
EndSection



AFAIK the
Code:
option "nodcc"
is crucial on that machine.

As this thread has become very long: I coudnt really get clear where the most recent advice can be found. Could someone give me a hint? - NB.: Is it still valid for 5.3.1?

And another thing: ubuntu needed kernel parameters

Code:
i915.modeset=0 noapic


not to hang during the boot procedure. Looks as if this were not necessary for puppy.

BTW.: Tried puppy on a 160MB RAM PIII today - awesome!!!!

Greetings,

Wolf
Back to top
View user's profile Send private message 
herrdeh

Joined: 19 Jan 2012
Posts: 8

PostPosted: Tue 28 Feb 2012, 10:05    Post subject:  

Finally I ended up to use puppy "wary" - this works out of the box.
Attn.: Do not "upgrade" to Xorg 7.6, as offered by the system. That one did not work on my machine.

HTH,
Wolf
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 12 of 12 [167 Posts]   Goto page: Previous 1, 2, 3, ..., 10, 11, 12
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0532s ][ Queries: 12 (0.0083s) ][ GZIP on ]