Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 01:35
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
TEENpup 2.14 Update/Bug fix Release Maybe in 2 weeks
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Author Message
john biles


Joined: 17 Sep 2006
Posts: 1408
Location: Australia

PostPosted: Sat 20 Oct 2007, 04:25    Post_subject:  TEENpup 2.14 Update/Bug fix Release Maybe in 2 weeks  

Hello Everyone,
Forum user edoc has request DjVu file format support as well as there's a problem with the petget installer where I've some how deleted a file preventing installing of new Pets from Barry K's site that I want to fix.

Also I want to add some more small plugins for Konqueror to add more usability.

I thinking of adding Wengophone (older smaller version) to TEENpup as well.

I think it would be easier to create an new iso than post all these changes on the forum.

What do you think?

Any suggestions for Apps you'd like to see added to TEENpup please post them now and I will see what I can do.

If it's not too big and I can get it working properly in TEENpup I see if I can include it in this update/bug fix, now's the time to make your requests.

_________________
Legacy OS 2.1 LTS Released! Install me on a new! EXT2 Partition with 500Mb of swap and I'll be happy. Razz
Legacy OS 4 Released! Install to newer legacy hardware / early EeePC's Very Happy
Back to top
View user's profile Send_private_message Visit_website 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Sat 20 Oct 2007, 09:32    Post_subject:  

hi john,

i've just downloaded version 2.12 of wengophone, and i wonder whether you need to include it with teenpup, as it seems to be an app that you can extract pretty much anywhere, click on the wengophone.sh file, and it works. the only thing missing is that it perhaps needs a .desktop file for the menu. what do you think?
Back to top
View user's profile Send_private_message 
john biles


Joined: 17 Sep 2006
Posts: 1408
Location: Australia

PostPosted: Sat 20 Oct 2007, 10:41    Post_subject:  

Hello muggins,
worked 12 hours today, so will install it and have a play tomorrow.
The desktop file is no problem at all to create, do it all the time.

_________________
Legacy OS 2.1 LTS Released! Install me on a new! EXT2 Partition with 500Mb of swap and I'll be happy. Razz
Legacy OS 4 Released! Install to newer legacy hardware / early EeePC's Very Happy
Back to top
View user's profile Send_private_message Visit_website 
john biles


Joined: 17 Sep 2006
Posts: 1408
Location: Australia

PostPosted: Sun 21 Oct 2007, 10:51    Post_subject:  

In the expected update, you can look forward to KDE's Kaffeine MediaPlayer. It's basically KDE's Gxine Player and offers a few more options.
What I like about this install is that all require codec dependencies are met.
Even with Ubuntu, Mepis etc, this is something I've never seen.
Kaffeine Multimedia Player.jpg
Description 
jpg

 Download 
Filename  Kaffeine Multimedia Player.jpg 
Filesize  59.7 KB 
Downloaded  1195 Time(s) 

_________________
Legacy OS 2.1 LTS Released! Install me on a new! EXT2 Partition with 500Mb of swap and I'll be happy. Razz
Legacy OS 4 Released! Install to newer legacy hardware / early EeePC's Very Happy
Back to top
View user's profile Send_private_message Visit_website 
john biles


Joined: 17 Sep 2006
Posts: 1408
Location: Australia

PostPosted: Thu 25 Oct 2007, 23:04    Post_subject:  

Hello eceryone,
This bug fix/update is going well at the moment, just one problem I'm having with Kaffeine is that it crashes upon exiting of the program, while it appears to all work fine during normal use, this problem to me lets TEENpup down, what do you think.

_________________
Legacy OS 2.1 LTS Released! Install me on a new! EXT2 Partition with 500Mb of swap and I'll be happy. Razz
Legacy OS 4 Released! Install to newer legacy hardware / early EeePC's Very Happy
Back to top
View user's profile Send_private_message Visit_website 
john biles


Joined: 17 Sep 2006
Posts: 1408
Location: Australia

PostPosted: Fri 26 Oct 2007, 19:47    Post_subject:  

Hello Everyone,
It's been a journey testing different versions of Kaffeine to find one that doesn't crash in TEENpup 2.14 and I found that version 0.4.3b works perfectly.
I don't know about other user's of Gxine Player, But I've found when playing DVD's in full screen mode that there was the odd flicker and line here and there.
Now with Kaffeine 0.4.3b there's only a perfect clear image.
Another bonus is that this version of Kaffeine is only half the size of the later versions.
Kaffeine 0.4.3b.jpg
Description 
jpg

 Download 
Filename  Kaffeine 0.4.3b.jpg 
Filesize  40.35 KB 
Downloaded  1091 Time(s) 

_________________
Legacy OS 2.1 LTS Released! Install me on a new! EXT2 Partition with 500Mb of swap and I'll be happy. Razz
Legacy OS 4 Released! Install to newer legacy hardware / early EeePC's Very Happy
Back to top
View user's profile Send_private_message Visit_website 
J.S. Garrison

Joined: 25 Feb 2007
Posts: 36

PostPosted: Wed 31 Oct 2007, 07:37    Post_subject: New User Input About Teen
Sub_title: Relates To Other Pups As Well
 

I've been enjoying TeenPUP because of the large amount of applications it has. I've had issues with wireless connectivity, which, thanks to jonyo and others has come to a solution.

When reforming the next release, can you think about a couple of things
that I have encountered?

First, on the second boot of Teen, I'm stuck at the line where it tries to dicover the network using Rausb0. It says I can hit return to go on, but I haven't had any luck with that. I've had to unplug the wireless USB device to get PUP to boot.

The second issue is related.

I tried unsuccessfully for days to get the Network Wizard to work with my network and wireless router. a lot of different things were thrown at it to make it happen.

jonyo suggested I use RutilT. I did, with no connectivity until I changed from auto DHCP to Static with the router's own settings.

The Wizard wouldn't allow connectivity with that alteration, but the utility did.

Assuming these are two different pieces of software, can't the Wizard
be made to works as the RutilT did?

Thanks
Back to top
View user's profile Send_private_message 
Gimlet

Joined: 22 Apr 2006
Posts: 13

PostPosted: Thu 01 Nov 2007, 12:09    Post_subject: Apps for Teen Pup 2.14
Sub_title: Streamtuner
 

Stremtuner would be lovely
_________________
Think you can, think you can't. Either way your right!
Back to top
View user's profile Send_private_message Visit_website MSNM 
setecio

Joined: 01 Nov 2006
Posts: 326
Location: UK

PostPosted: Sun 11 Nov 2007, 16:31    Post_subject:  

Hi John,

Great work on this derivative. I was about to install it on some old laptops but noticed this update thread which sounds great.

Do you think it will be available soon, as I'd prefer to wait a week or two, if it is.

Thanks.
Back to top
View user's profile Send_private_message 
cb88


Joined: 28 Jan 2007
Posts: 1169
Location: USA

PostPosted: Sun 11 Nov 2007, 17:05    Post_subject:  

things that should be in
the new xcompmanager from MU that does not require dri

the gnoclized icewmconfig

update Pfind and the other Papps

dump seamonkey for firefox iceweasel or opera

Pdrive is looking good now

also modplugplay for XMMS is a must for me

other than that i can't think of anything else right now TeenPup is pretty awesome I even remastered puu_214.sfs with devx_214.sfs so now i even have gcc on a livecd Shocked

EDIT add the latest JWM with gradient support and all the themes.... since they are just text files

_________________
Taking Puppy Linux to the limit of perfection. meanwhile try "puppy pfix=duct_tape" kernel parem eater.
X86: Sager NP6110 3630QM 16GB ram, Tyan Thunder 2 2x 300Mhz
Sun: SS2 , LX , SS5 , SS10 , SS20 ,Ultra 1, Ultra 10 , T2000
Mac: Platinum Plus, SE/30
Back to top
View user's profile Send_private_message Visit_website 
john biles


Joined: 17 Sep 2006
Posts: 1408
Location: Australia

PostPosted: Mon 12 Nov 2007, 06:02    Post_subject:  

Hello cb88,
Can you please supply any links to the apps you want in TEENpup and what you got working in your remaster.

_________________
Legacy OS 2.1 LTS Released! Install me on a new! EXT2 Partition with 500Mb of swap and I'll be happy. Razz
Legacy OS 4 Released! Install to newer legacy hardware / early EeePC's Very Happy
Back to top
View user's profile Send_private_message Visit_website 
macadavy

Joined: 12 Jun 2006
Posts: 214
Location: Cascadia's Attic, eh?

PostPosted: Mon 12 Nov 2007, 07:27    Post_subject:  

Thanks John, for inviting community input - its another example of why Puppy's special! TeenPup is so near my ideal Puppy it hurts. Crying or Very sad
(Me & my eyes thank you for fixing those small menu fonts, btw.)
I've tried about a dozen Puppy varient live CDs so far, and each has its own virtues. Yet none I've seen lets me do four important (to me) things in a browser: view sites with Flash/Java, watching & listening to streaming multimedia and reading PDF docs. It seems many have one or two, and TP has three out of four if the Java install covers the browser (or must one still manually copy .so-and-.so files to .such-and-.such directories? Wink ).
For PDF: can the Adobe Acrobat browser plugin be made to work with KPDF and/or Foxit Reader? http://www.foxitsoftware.com/pdf/desklinux/
Or will it only work with Acrobat Reader itself? There used to be a Firefox Foxit extension but it appears to have dis-appeared. A 'PDF Download' FF ext. exists that might do the job instead, (i.e. call KPDF or Foxit). Can these two functions (i.e. multimedia & PDF) be more simply handled by configuring the 'helper applications' in Seamonkey? If so can Seamonkey or Firefox be pre-configured to do this, 'cause I haven't figured out how that works (i.e. associating file types with applications in SM/FF)? As for Ghostview I suspect it just can't handle the latest PDF standards, its never worked right in any Puppy I've tried.
I really appreciate inclusion of some VoIP softphones - its the 'next big thing'. Would you consider updating Gizmo1beta to the latest Gizmo3? (Debian pkg. which could be dot.pup'd here: http://www.gizmoproject.com/download-linux.html).
Also worthy of your consideration IMHO is Jabbin, a Jabber VoIP client that supports Google Talk, the only GNU/Linux client I know of that does. Just about everyone has a Gmail account these days! Unfortunately their only pkgs. don't include a .deb and I didn't see a source code tarball that could be compiled for Debian or dot.pup'd. I posted about this here: http://www.murga-linux.com/puppy/viewtopic.php?t=22591
and muggins had a run at installing it, noting that it needed the speex & QT libraries. You can check it out here: http://www.jabbin.com/int/
I realize there are a couple of good reasons for going with SeaMonkey (mail client & HTML editor included) but I'd sooner see lightweight replacements for these functions and Firefox with its 1500+ extensions! I understand another reason for retaining SeaMonkey might be that stubborn Flash9 bug that keeps crashing Firefox in some Pups. Lighthouse Puppy beta5 seems to have resolved these - perhaps TazOC has some tips & tweaks about how he did this...
Yikes, long-winded as always! By now you've forgotten what I said to start with so let me reiterate: WTG, John - Teenpup's waaay cool! Cool was the ultimate compliment when I was a teen - but a real live today teen told me: "TeenPup rocks, man - it's phat!" Which is a compliment, also - I think... Wink

_________________
Welcome to my weird, wild, wonderful, wired world!
Back to top
View user's profile Send_private_message 
cb88


Joined: 28 Jan 2007
Posts: 1169
Location: USA

PostPosted: Mon 12 Nov 2007, 14:42    Post_subject:  

spiffy icewm config tool a tcl script gnoclized to look like GTK
http://www.murga-linux.com/puppy/viewtopic.php?search_id=1301101857&t=21540

here are some more gnocl-ized scripts also by Gray
http://www.murga-linux.com/puppy/viewtopic.php?t=21364&search_id=1301101857

you can find most of those by searching for gnocl

the milkmod pluging for XMMS is in dougals XMMS dotpet....on dotpups.de/dotpups

pdrive is here
(requires gtkdialog3 ):
http://www.murga-linux.com/puppy/viewtopic.php?search_id=1163077877&t=21200

Pfind same requirements as pdrive:
http://www.murga-linux.com/puppy/viewtopic.php?search_id=1634835551&t=15136

There is ainebot is an apdir of ainebot I compiled in 3.00 with devx_2.16.sfs and should work fine....
http://www.murga-linux.com/puppy/viewtopic.php?t=23158

Pbackup:
http://www.murga-linux.com/puppy/viewtopic.php?search_id=1634835551&t=10975

Pschedule:
http://www.murga-linux.com/puppy/viewtopic.php?t=22166&search_id=1586225413

_________________
Taking Puppy Linux to the limit of perfection. meanwhile try "puppy pfix=duct_tape" kernel parem eater.
X86: Sager NP6110 3630QM 16GB ram, Tyan Thunder 2 2x 300Mhz
Sun: SS2 , LX , SS5 , SS10 , SS20 ,Ultra 1, Ultra 10 , T2000
Mac: Platinum Plus, SE/30
Back to top
View user's profile Send_private_message Visit_website 
john biles


Joined: 17 Sep 2006
Posts: 1408
Location: Australia

PostPosted: Tue 13 Nov 2007, 07:14    Post_subject:  

Hello macadavy,
I had a play around with trying to get Jabbin to run in TEENpup without luck, I believe it's possible but outside my abilities at the moment.
Also Gizmo 3 dependancies might cause it not to work in TEENpup, I'll have to play with that one as well.
As for JAVA just click on the desktop icon install the dotpup (takes a while to install) and wait for Seamonkey to open. It will open JAVA's test page to confirm that JAVA was installed correctly.
If you have problems do this.
In Seamonkey click on "edit" then "preferences" then "Advanced" and enable JAVA. JAVA should now work.

As for Kpdf and Adobe Acrobat plugin, I haven't tried it. Basically if you go to a website that has a PDF file on it, just click on that PDF and Kpdf should open after a few seconds.

If you really need Adobe Acrobat, Then version 7 from Mandrake, Mandriva will work after unrpming it with the undeb/unrpm dotpup.
At one stage I did have it in TEENpup 2.14 but at about 85mb's in size, I felt as I already had Kpdf in TEENpup 2.14, I could have more apps and still allow the iso to be smaller.

_________________
Legacy OS 2.1 LTS Released! Install me on a new! EXT2 Partition with 500Mb of swap and I'll be happy. Razz
Legacy OS 4 Released! Install to newer legacy hardware / early EeePC's Very Happy
Back to top
View user's profile Send_private_message Visit_website 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Tue 13 Nov 2007, 07:54    Post_subject:  

macadavy & john,

i compiled jabbin on pup2.16 & I uploaded a .pet, to rapidshare, here:

http://rapidshare.com/files/69405538/jabbin-2.0beta2a-i486.pet

It's just over 2M dload, and needs QT libraries and speex installed. Both these are available as .pet packages on puppy's ibiblio site. Oddly it also needs libGL.so.1, which is available by installing the openGl .pup from Mu's site, at dotpups.de/dotpups.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0893s ][ Queries: 12 (0.0038s) ][ GZIP on ]