Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 18 Jul 2019, 21:48
All times are UTC - 4
 Forum index » Taking the Puppy out for a walk » Announcements
NOP (Nearly Office Pup) 3.01 final available for download
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 5 of 10 [150 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9, 10 Next
Author Message
Henry

Joined: 29 Jul 2006
Posts: 865
Location: Oregon USA

PostPosted: Thu 13 Dec 2007, 12:56    Post subject:  

This looks like very good news, Gray. I am especially looking forward to replacing grafburn and upgrading pfind.

I neglected to do the pfix-ram thing before upgrading, so had to overwrite the existing 301.sfs and 301.zdrv in /home/ with those from r2. I see I have Pfind 3.2 now, but have to check through the rest yet.

It looks like everything new is there now, at least the files. I see the files for pburn, but it doesn't appear in the menu, and I can't run it from /usr/bin/pburn. So I simply downloaded and installed pburn-0.4.pet. Now it works and appears in the menu.

Thanks for a great job.

Last edited by Henry on Fri 14 Dec 2007, 20:14; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website 
GrantsV

Joined: 16 May 2007
Posts: 58

PostPosted: Thu 13 Dec 2007, 17:16    Post subject:  

I've been trying to build the perfect Pup, but after seeing NOP my efforts were in vain!

One major issue still remains. Bytecode Interpreter for XFCE non-aliased fonts:
http://support.zenwalk.org/index.php?PHPSESSID=353643e6580a29373e6ad0b64cc89425&topic=132.0

In JWM and IceWM someone had the following instructions, but sadly they dont work for XFCE:

Go to http://murga-linux.com/puppy/viewtopic.php?t=4437
and scroll down about 2/3 of the way; download the BCI-hinting enabled version of libfreetype,
libfreetype.so.6.3.10.tar.gz
to your scratch directory; left-click to start XArchiver and this will unpack it. Copy libfreetype.so.6.3.10 to /usr/lib and then open an rxvt terminal window and issue the commands:
Code:
cd /usr/lib
ln -fs libfreetype.so.6.3.10 libfreetype.so.6
ln -fs libfreetype.so.6.3.10 libfreetype.so
Back to top
View user's profile Send private message 
setecio

Joined: 01 Nov 2006
Posts: 326
Location: UK

PostPosted: Sat 15 Dec 2007, 05:47    Post subject: Re: Xfce panel  

Shocked Shocked Shocked Very Happy Very Happy Very Happy Very Happy Very Happy

Streaming BBC video just works. Excellent. It's been a problem with all the other puppies I have tried and I was just about to look at trying to get it to work, but it just works in this version Very Happy Very Happy Very Happy Very Happy
Excellent. Do you know if this is a result of something you have encorporated in NOP3.01r1 ? It plays using the gxine player and I'm wondering if you have added certain codecs or addons, or if it already work in standard Puppy 3.01 ?

Running frugal NOP on a 365Mhz PII 224MB 7 year old laptop and it is surprisingly fast.

gray wrote:
Setecio, it is really easy to add applications to the panels Very Happy .


How do I add items to the left side menu that pops up from the 'start' button?

How do I add icons to the desktop itself ?

Thanks.
Back to top
View user's profile Send private message 
gray


Joined: 23 Feb 2007
Posts: 318
Location: Adelaide - South Australia

PostPosted: Sat 15 Dec 2007, 17:08    Post subject: Fonts & Gxine  

GrantsV : I dont know anything about fonts etc but I played around with the freetype libs based on the info on the links you provided. I am beginning to think that the function may be already enabled in Xfce4. My fonts are very clear and if you look in the Settings Manager, User Interface pop up you will see font configuration options. Switching hinting off makes a huge difference Shocked .

Setecio : The ability to tune in BBC is in standard 301, but I think gxine behaves better running in Xfce rather than JWM. It is still a bit flakey, but I can view DVD's full screen smoothly, with no lines etc. I think that is a result of the nvidia opengl driver though Very Happy

To add icons to the desktop, right click on an existing desktop icon to get a menu. Then select the item at the bottom, ie Desktop then Create Launcher. Fill in the details similar to the panel app launcher.

Adding items to the start menu requires you to add a file in the /usr/share/applications folder (named something.desktop). It can take a few minutes for the new item to appear in the menu though.
Back to top
View user's profile Send private message 
klu9

Joined: 27 Jun 2007
Posts: 345

PostPosted: Sun 16 Dec 2007, 12:03    Post subject: Metalink for NOP r2  

Metalink for NOP r2

Download puppy-301-NOP-r2.iso via metalink

(See http://puppylinux.org/wikka/MetaLink for info on metalink)
Back to top
View user's profile Send private message 
klu9

Joined: 27 Jun 2007
Posts: 345

PostPosted: Tue 18 Dec 2007, 17:18    Post subject:  

i'm sure this has been discussed before but my search technique is proving fruitless.

How can I add an icon for a folder to the desktop? Or make a bookmark in Thunar to a folder?

I clicked on an existing desktop icon and selected creat new launcher, but it won't let me choose a folder.

And in Thunar there doesn't seem to exist an option to bookmark certain locations and the Thunar FAQ & documentation doesn't mention anything about.
Back to top
View user's profile Send private message 
Henry

Joined: 29 Jul 2006
Posts: 865
Location: Oregon USA

PostPosted: Tue 18 Dec 2007, 18:17    Post subject:  

To make adesktop icon for a folder -
Right click on folder in file manager; send to desktop.

To make a bookmark in file manager -
Right click on folder in file manager; send to side panel.

(Be sure to have view, sidepanel, shortcuts checked.)
Back to top
View user's profile Send private message Visit poster's website 
Sage

Joined: 04 Oct 2005
Posts: 5472
Location: GB

PostPosted: Wed 19 Dec 2007, 06:15    Post subject:  

Found a few minutes to (full) install the latest revision and was surprised to see error message 'No CD present'. Had to mount CD and retry. Don't think this occurred previously?
Back to top
View user's profile Send private message 
klu9

Joined: 27 Jun 2007
Posts: 345

PostPosted: Thu 20 Dec 2007, 00:34    Post subject:  

@henry: thanks

@gray: opera keeps crashing on me... it just disappears, no error dialogs or anything. weird.

@everyone: NOP 301 r2 now available via bittorrent!
Download NOP 301 r2 with Bittorrent via LinuxTracker
Back to top
View user's profile Send private message 
setecio

Joined: 01 Nov 2006
Posts: 326
Location: UK

PostPosted: Fri 21 Dec 2007, 08:56    Post subject:  

NOP3.01r1 on a compaq m700. The screen goes black after 2.5 minutes if nothing is done, moving the mouse makes it reappear. This is too short if reading something. I've looked in the BIOS but see nothing refering to this.

Is this adjustable in NOP somewhere ..... is it a screensaver set to 2.5 minutes, if so where can I change it to 10 minutes .... or is it a power management setting. I've looked around but can't find anywhere to change it ..... any ideas ? Thanks.
Back to top
View user's profile Send private message 
Henry

Joined: 29 Jul 2006
Posts: 865
Location: Oregon USA

PostPosted: Fri 21 Dec 2007, 14:50    Post subject: Pburn  

Gray,

I have been having problems with the latest (and earlier) Pburn in Nop 301 r2 and discussing them with Zigbert in
http://www.murga-linux.com/puppy/viewtopic.php?p=162168#162168

That string details my problems. Are there any Nop specific considerations that would cause these problems? Can you suggest a different simple data burner. (Barry's iso burner is fine and of course is already in Nop and used by Pburn. I put it into the menu separately.)

Thanks
Back to top
View user's profile Send private message Visit poster's website 
gray


Joined: 23 Feb 2007
Posts: 318
Location: Adelaide - South Australia

PostPosted: Fri 21 Dec 2007, 20:58    Post subject: NOP issues  

klu9: Opera 9.24 has been working without problems for me, but I notice that opera 9.25 is now available - very shortly after 9.24. Perhaps there are some issues with 9.24 Question

setecio: If you enter the command gxset in the terminal and select the screen saver tab in the gui you should be able to change the settings you want. Odd though, cos the default timeout is 600 seconds Confused

Henry: I guess I was a bit premature including Pburn - but it looked so good and worked well with the small files I tried to burn. Try grafburn instead. I hope Pburn can evolve into a usable burner app as Puppy badly needs one.
Back to top
View user's profile Send private message 
setecio

Joined: 01 Nov 2006
Posts: 326
Location: UK

PostPosted: Sat 22 Dec 2007, 07:13    Post subject: Re: NOP issues  

I've just discovered that it is only a problem while on battery and the battery is a new one. It doesn't happen on mains


gray wrote:
setecio: If you enter the command gxset in the terminal and select the screen saver tab in the gui you should be able to change the settings you want. Odd though, cos the default timeout is 600 seconds Confused


OK, I tried all that and it didn't change anything, I disabled screensaver and applied. However I don't know how to save .xset.sh. I was going to replace the original but searching for it did not find it so it doesn't originally exist Confused So I saved it to the root folder it suggested but the settings in gxset were not reset back to their original values on reboot. But even before reboot, after applying it, it had no effect. The screen just blanksout after 2.5 minutes, doing anything instantly restores it with no delay in it appearing again.

Maybe if I can get gxset to remember my settings on reboot it might work ? Question

If not ...... >
Confused I found an article about debian etch on the same laptop
http://users.utu.fi/sjsepp/linuxcompaqarmadam700.html#bios_settings
which wrote:
Quote:
Blanking the screen in xorg

I ran into various problems when using Xscreensaver to blank the screen. Therefore I decided to set display's blanking timeout values directly in xorg.conf. It is possible to control timeouts via "laptop-mode" also, which might be easier. I suppose that if a user uses Xscreensaver and sets his or hers own timeout values they will override the values in xorg.conf. I've found out that the display driver for this laptop supports only the "Standby" mode. The display does not resume correctly from "Suspend" or "Off" modes, and only cure I've found is restarting the Xserver.

To set display timeouts open your /etc/X11/xorg.conf or /etc/X11/XF86Config-4 and add the timeout values to the "ServerLayout" section. Below is the relevant section from my xorg.conf:
Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Trackpoint"
InputDevice "Serial mouse"
# Timeout in minutes
Option "StandbyTime" "5"
Option "SuspendTime" "0"
Option "OffTime" "0"
EndSection


Would this work in NOP somehow ? I'm not sure where or what to put into xorg.conf since there is very little in it and there is no 'ServerLayout' section

It only does this on battery and the battery is a new one.
Back to top
View user's profile Send private message 
setecio

Joined: 01 Nov 2006
Posts: 326
Location: UK

PostPosted: Sun 23 Dec 2007, 09:00    Post subject:  

I've solved the battery problem ..... it was a compaq bios issue. I couldn't find any settings to access as they are done via compaq addon software to windows. So I update and reset to default values, and that cured the screen blanking. Very Happy

mmm ... However after doing this, my battery monitor just show 50%% all the time (yes two %%) and doesn't change. It was working perfectly before my Bios changes and is clearly related to the bios update/reset but can you think of anything which might have changed that would need an adjustment in NOP to make it work ?

Thanks.
Back to top
View user's profile Send private message 
gray


Joined: 23 Feb 2007
Posts: 318
Location: Adelaide - South Australia

PostPosted: Sun 23 Dec 2007, 19:36    Post subject: NOP 301 r3  

I have updated NOP 301 to revision 3.
This updates pburn to v0.6 and Opera to v9.25.
Have also replaced the troublesome gxine with xine-ui mediaplayer.
Xine-ui is apparently going to be in the puppy 4 release and so I thought I would give it a try and found it to be much better than gxine!
Also added a small script to play all music files in a folder using xine (just right click on a music file and select the "play all" option).

Download from http://www.puppylinux.ca/NOP
kindly hosted by Caneri

Note: The xineplugin for Opera will show realmedia movies such as those on the BBC website. Sometimes they get "stuck" in which case clicking on the preferences option, then OK usually gets it moving. If that fails then clicking on the "Launch in Standalone player" generally works. The plugin seems to have problems with realaudio files such as internet radio, but if you set Opera to launch xine directly for this media then they play OK. Easiest way to do that is select a broadcast on the BBC radio site and in the pop up select launch in standalone player. In the gui select open with other app and enter xine -H.

.

Last edited by gray on Mon 24 Dec 2007, 06:26; edited 2 times in total
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 5 of 10 [150 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9, 10 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Taking the Puppy out for a walk » Announcements
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0821s ][ Queries: 11 (0.0287s) ][ GZIP on ]