Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Dec 2014, 02:40
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
HSF/HCF softmodem dotpup packages
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 4 of 6 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Author Message
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Tue 03 Oct 2006, 04:44    Post_subject:  

just a few things...have you done ./configure,make. & thenmake install? also i thought, (i'm guessing here), that HSF modems linked /dev/modem with something other than ttyS?, like /dev/ttySHSF0?

from memory, with hsf modems, you have to run hsfconfig.

i'm not sure about you're printer...is it a combined printer/scanner? linuxprinting.org recommmends the hpijs driver for the 1510. they also have a ppd file for the 1510:

http://linuxprinting.org/show_printer.cgi?recnum=HP-PSC_1510

have you tried pakt's cups script?

for scanners puppy has the pupgets sane_backends & xsane gui frontend.
Back to top
View user's profile Send_private_message 
md_jamil

Joined: 10 Sep 2006
Posts: 46
Location: Saudi Arabia

PostPosted: Tue 03 Oct 2006, 18:14    Post_subject: hsf modem driver  

Thanks for help, yes hsf modem is SHSF0 thats all fine and working.
modem is working fine it dials connects script end starts pppd it negotiates a ppp session connection icon appears in bottom to tell you that connectivity is there, but when you start browser nothing resolves like no connection. Look at status tab of connection just an idle connection no bites received just 2 sometimes 4 packets sent and thats all no in out addresses . Look at my previous post I coppied log info. Its just an idle connection. I use gnome ppp dialer which is readly on the desk top. It seems that its not fetching anything from ISP's DHCP server. I assume it works like windows XP these days, you dont have to specify domain proxy or anything just leave everything to auto just supply username and password thats what I am doing. Do I have to fill in domain name?. When Gnome didnt work then I tried all the other dialers with no luck. Please note that I am totally new to Linux environment dont assume that I know anything type complete path for commands. I click console on desktop and type ./configure,make it say no file or directory. I have devx as you know its needed for compiling HSF modem driver went through hsfconfig also worked fine. Modem sounds, dials ok why doesnt it negociate a good ppp session?
Back to top
View user's profile Send_private_message YIM 
md_jamil

Joined: 10 Sep 2006
Posts: 46
Location: Saudi Arabia

PostPosted: Tue 03 Oct 2006, 18:16    Post_subject: hsf modem driver  

Thanks for help, yes hsf modem is SHSF0 thats all fine and working.
modem is working fine it dials connects script end starts pppd it negotiates a ppp session connection icon appears in bottom to tell you that connectivity is there, but when you start browser nothing resolves like no connection. Look at status tab of connection just an idle connection no bites received just 2 sometimes 4 packets sent and thats all no in out addresses . Look at my previous post I coppied log info. Its just an idle connection. I use gnome ppp dialer which is readly on the desk top. It seems that its not fetching anything from ISP's DHCP server. I assume it works like windows XP these days, you dont have to specify domain proxy or anything just leave everything to auto just supply username and password thats what I am doing. Do I have to fill in domain name?. When Gnome didnt work then I tried all the other dialers with no luck. Please note that I am totally new to Linux environment dont assume that I know anything type complete path for commands. I click console on desktop and type ./configure,make it say no file or directory. I have devx as you know its needed for compiling HSF modem driver went through hsfconfig also worked fine. Modem sounds, dials ok why doesnt it negociate a good ppp session?
Back to top
View user's profile Send_private_message YIM 
tempestuous

Joined: 10 Jun 2005
Posts: 5293
Location: Australia

PostPosted: Tue 03 Oct 2006, 21:04    Post_subject:  

Sometimes nameservers need to be manually configured. Find out the IP addresses of your Internet Service Provider's nameservers, they're usually listed on their technical support web page, then set up your /etc/resolv.conf file like this -

nameserver 123.456.789.1
nameserver 123.456.789.2
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Wed 04 Oct 2006, 05:13    Post_subject:  

Quote:
it dials connects script end starts pppd it negotiates a ppp session connection icon appears in bottom to tell you that connectivity is there, but when you start browser nothing resolves like no connection. Look at status tab of connection just an idle connection no bites received just 2 sometimes 4 packets sent and thats all no in out addresses .


i had similar problem with my ltmodem & pup2.01. as i had no idea what was problem/solution i went back to pupversion that i knew worked for my setup, 1.08. maybe try tempestuous's suggestion of using your isp's dns addresses & see if that does anything.
Back to top
View user's profile Send_private_message 
md_jamil

Joined: 10 Sep 2006
Posts: 46
Location: Saudi Arabia

PostPosted: Thu 05 Oct 2006, 07:22    Post_subject: hsf modem driver  

Well I did right those lines but it didnt help any other solution I know its just a little thing but cant workout, cant go back to previous version my connection is too slow, cant afford to download all that lenthy stuff. Do you always configure ppp before you could connect to internet or it come preconfigured, help pages say its straight forward but it isnt
Back to top
View user's profile Send_private_message YIM 
md_jamil

Joined: 10 Sep 2006
Posts: 46
Location: Saudi Arabia

PostPosted: Thu 05 Oct 2006, 08:34    Post_subject: hsf modem driver  

Have a look at the folloing log, it says ppp-secrets file has world and/or group access, is it the culprit, do we have to put something in ppp-secrets file to resolve this.

Oct 5 15:01:41 (none) daemon.notice pppd[2353]: pppd 2.4.4b1 started by root, uid 0
Oct 5 15:01:41 (none) daemon.info pppd[2353]: Using interface ppp0
Oct 5 15:01:41 (none) daemon.notice pppd[2353]: Connect: ppp0 <--> /dev/ttySHSF0
Oct 5 15:01:41 (none) daemon.warn pppd[2353]: Warning - secret file /etc/ppp/pap-secrets has world and/or group access
Oct 5 15:01:48 (none) daemon.warn pppd[2353]: Warning - secret file /etc/ppp/pap-secrets has world and/or group access
Oct 5 15:01:48 (none) daemon.warn pppd[2353]: Warning - secret file /etc/ppp/pap-secrets has world and/or group access
Oct 5 15:01:51 (none) daemon.info pppd[2353]: Hangup (SIGHUP)
Oct 5 15:01:51 (none) daemon.notice pppd[2353]: Modem hangup
Oct 5 15:01:51 (none) daemon.notice pppd[2353]: Connection terminated.
Oct 5 15:01:51 (none) daemon.info pppd[2353]: Exit.
Back to top
View user's profile Send_private_message YIM 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Thu 05 Oct 2006, 09:15    Post_subject:  

in a console, type:

chmod 600 /etc/ppp/chap-secrets

or right click the file in Rox to set the properties

this should not affect whether you are connected or not

one version of Puppy (202?), i couldn't connect until after the firewall was configured
Back to top
View user's profile Send_private_message 
md_jamil

Joined: 10 Sep 2006
Posts: 46
Location: Saudi Arabia

PostPosted: Sat 07 Oct 2006, 19:00    Post_subject: hsf modem driver  

I am using puppy 2.02 chmod 600 did help still same situation nothing changed. Just to give you a clue when I connect from XP modem speaker makes noise for longer period as if renegotiating connection speed and connects at 24K instead of 56k because I have a slow telephone line and I know that, thats normal but when I connect from puppy modem make noise for less duration does it tell you guys anything. Is it to do something with modem initialization string ? just guessing
Back to top
View user's profile Send_private_message YIM 
md_jamil

Joined: 10 Sep 2006
Posts: 46
Location: Saudi Arabia

PostPosted: Sat 07 Oct 2006, 19:04    Post_subject: hsf modem driver  

sorry there is a typing mistake in my previous post, chmod did not help it is still same condition modem hangsup line exit code 16.
Back to top
View user's profile Send_private_message YIM 
md_jamil

Joined: 10 Sep 2006
Posts: 46
Location: Saudi Arabia

PostPosted: Tue 10 Oct 2006, 17:30    Post_subject: hsf modem driver  

is this the end no one know what to do /var/log/messages says pap-secrets has world and/or group access when I look at ppp-secrets its just a blank document. What lines to put in it to resolve this any body knows?putting username*password didnt help.
Back to top
View user's profile Send_private_message YIM 
md_jamil

Joined: 10 Sep 2006
Posts: 46
Location: Saudi Arabia

PostPosted: Tue 10 Oct 2006, 17:46    Post_subject: hsf modem driver  

is this the end no one know what to do /var/log/messages says pap-secrets has world and/or group access when I look at ppp-secrets its just a blank document. What lines to put in it to resolve this any body knows?putting username*password didnt help.
Back to top
View user's profile Send_private_message YIM 
jcoder24


Joined: 06 May 2005
Posts: 601
Location: Barbados

PostPosted: Tue 10 Oct 2006, 19:41    Post_subject:  

Sometimes the hex-ed version gives errors similar to what u are experiencing. If you using that one try recompiling it without the hex-edit.
Back to top
View user's profile Send_private_message 
md_jamil

Joined: 10 Sep 2006
Posts: 46
Location: Saudi Arabia

PostPosted: Wed 11 Oct 2006, 14:25    Post_subject: hsf modem driver  

Thanks for help I am new to Linux world, didnt really understand what you said, you mean HSF driver or the pap-secret file. If it is HSF driver where to find the otherwise one I only know this one in fact I did hack the driver with hex edit but it wasnt working in it raw form(14400) anyway.
Back to top
View user's profile Send_private_message YIM 
jcoder24


Joined: 06 May 2005
Posts: 601
Location: Barbados

PostPosted: Wed 11 Oct 2006, 16:16    Post_subject:  

md_jamil wrote:
you mean HSF driver or the pap-secret file

I meant the hsf driver.

However, I just remembered that some dialers don't work for some users/modems. Can you indicate which program are you using to connect? I'd recommend gkdial, that's has been the most reliable. Also try each of the options pap, chap and chat and see if any works.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 4 of 6 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0894s ][ Queries: 12 (0.0075s) ][ GZIP on ]