Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 23 Oct 2014, 16:01
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
How to install driver for ipw3945 wireless card?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message
ntrncx

Joined: 11 Sep 2007
Posts: 7

PostPosted: Tue 11 Sep 2007, 22:00    Post subject:  How to install driver for ipw3945 wireless card?  

i am going to install my newest driver of my wireless card ipw3945 and when i use make i get this

Quote:
ERROR: A compatible subsystem was not found in the following path[s]:

/lib/modules/2.6.21.5 /lib/modules/2.6.21.5/build

You need to install the ieee80211 subsystem from http://ieee80211.sf.net
and point this build to the location where you installed those sources, eg.:

% make IEEE80211_INC=/usr/src/ieee80211/

or use the 'make patch_kernel' within the ieee80211 subsystem to patch your
kernel sources.


i downloaded ieee80211 and after make i recieve this

Quote:
Checking in /lib/modules/2.6.21.5 for ieee80211 components...
find: /lib/modules/2.6.21.5/build/: No such file or directory
grep: /lib/modules/2.6.21.5/build//.config: No such file or directory
grep: /lib/modules/2.6.21.5/build//include/linux/autoconf.h: No such file or directory
find: /lib/modules/2.6.21.5/build/: No such file or directory
make -C /lib/modules/2.6.21.5/build M=/root/my-documents/ieee80211-1.2.18/ieee80211-1.2.18 modules
make: *** /lib/modules/2.6.21.5/build: No such file or directory. Stop.
make: *** [modules] Error 2


i understood that something missing Razz but how i get it and install it?
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5271
Location: Australia

PostPosted: Wed 12 Sep 2007, 04:00    Post subject:  

Puppy already contains the ipw3945 module, plus firmware.
Is there something wrong with this module?
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5271
Location: Australia

PostPosted: Thu 13 Sep 2007, 21:40    Post subject:  

You need the Puppy 2.17 kernel source, from
http://puptrix.org/sources/kernel-2.6.21.5-pup217/
Back to top
View user's profile Send private message 
ntrncx

Joined: 11 Sep 2007
Posts: 7

PostPosted: Fri 14 Sep 2007, 18:35    Post subject:  

thanks i downloaded from that folder the big bz2 file i extracted it and followed the instructions from the read me file but i must made a mistake cause it says in order to boot it you must copy the image to the right location but i cant find the image.

i did "make oldconfig' i answer some answers(dont know if i answered corectly)
and after i typed "make"

2)why when i install aircrack i cant run airdump?
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0472s ][ Queries: 11 (0.0073s) ][ GZIP on ]