Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 31 Aug 2014, 06:33
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
XPP 1.5 Cups Printer GUI App
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
john biles


Joined: 17 Sep 2006
Posts: 1408
Location: Australia

PostPosted: Thu 09 Aug 2007, 07:18    Post_subject:  XPP 1.5 Cups Printer GUI App  

Hello Everyone,
Here's a small GUI to go with the CUPS Printing System.

It requires the FLTK library which can be downloaded as a dotpup from MU's site

Just unzip the tar.gz and copy into the correct folders.


See Link to Home Page http://cups.sourceforge.net/xpp/#download

Note: I get the feeling it would be better to experiment with this while running live, as it may upset your installed Puppy's printing setting.
xpp 1.5.tar.gz
Description 
gz

 Download 
Filename  xpp 1.5.tar.gz 
Filesize  77.22 KB 
Downloaded  263 Time(s) 

_________________
Legacy OS 2.1 LTS Released! Install me on a new! EXT2 Partition with 500Mb of swap and I'll be happy. Razz
Legacy OS 4 Released! Install to newer legacy hardware / early EeePC's Very Happy

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
john biles


Joined: 17 Sep 2006
Posts: 1408
Location: Australia

PostPosted: Thu 09 Aug 2007, 07:19    Post_subject:  

Here's a Screenshot.
xpp 1.5.jpg
 Description   
 Filesize   33.59 KB
 Viewed   756 Time(s)

xpp 1.5.jpg


_________________
Legacy OS 2.1 LTS Released! Install me on a new! EXT2 Partition with 500Mb of swap and I'll be happy. Razz
Legacy OS 4 Released! Install to newer legacy hardware / early EeePC's Very Happy
Back to top
View user's profile Send_private_message Visit_website 
vanchutr

Joined: 05 Aug 2006
Posts: 427

PostPosted: Thu 09 Aug 2007, 23:24    Post_subject:  

1. Install the fltk-1.1.11.pup (download from www.dotpups.de)
2. Extract xpp.1.5.tar.gz and copy in /usr
3. In console, I used
Code:

xpp

4. xpp won't run and I get this message:
Code:

xpp: error while loading libaries: libfltk_images.so.1.1: cannot open shared object file: No such file or directory.

5. My system is missed the libfltk_images.so.1.1. where I can find it. In /usr/lib I'd found libfltk.so.1 (only one libfltk*)
Thank you
Back to top
View user's profile Send_private_message 
disciple

Joined: 20 May 2006
Posts: 6429
Location: Auckland, New Zealand

PostPosted: Tue 14 Aug 2007, 04:16    Post_subject:  

Sorry - I can't help you with that - you may like to post the question in a new thread. You could try my package of GTKLP though:
http://www.murga-linux.com/puppy/viewtopic.php?search_id=1344278110&t=17768
Back to top
View user's profile Send_private_message 
john biles


Joined: 17 Sep 2006
Posts: 1408
Location: Australia

PostPosted: Wed 15 Aug 2007, 00:10    Post_subject:  

Hello vanchutr,
Go to /usr/lib and find the lib called libfltk_images.so.2 or simular.
Now open ROX in say "my documents" and drag the lib accross to it and link it there.
Now rename the link to libfltk_images.so.1.1 and drag it back into /usr/lib

Hopefully XPP 1.5 will now open.

_________________
Legacy OS 2.1 LTS Released! Install me on a new! EXT2 Partition with 500Mb of swap and I'll be happy. Razz
Legacy OS 4 Released! Install to newer legacy hardware / early EeePC's Very Happy
Back to top
View user's profile Send_private_message Visit_website 
vanchutr

Joined: 05 Aug 2006
Posts: 427

PostPosted: Wed 15 Aug 2007, 00:51    Post_subject:  

Thank you John Biles
I'll try with your instructions
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0529s ][ Queries: 12 (0.0081s) ][ GZIP on ]