Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 22 Oct 2014, 10:09
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Funny GParted bug with Windows XP
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
clarf


Joined: 13 Jun 2007
Posts: 612
Location: The old Lone Wolf

PostPosted: Tue 19 Jun 2007, 12:43    Post subject:  Funny GParted bug with Windows XP  

Hi, i recently found a bug. With it you have a Windows XP instalation, that runs but doesn´t have any icons, task bar, tools bar, nothing... You can Enter to Task Manager and see the Windows applications running. You have the same results with Safe Mode, Debug Mode, etc. This Windows only shows the wallpaper but doesn´t work fine. (Like any Microsoft OS).

Well, i found this bug using Puppy 2.16 and GParted, you have to install a new NTFS Partition in your hard disk with GParted. Now reboot and insert Windows XP instalation disk, choose the NTFS partition created with GParted and use it without changing. (If you use a FAT32 partition, when Windows finish to copy the installation files it could not continue booting from the disk).

Windows install XP over the new Partition without errors, moreover it´ll start with the logo screen and it´ll run all the process.

Windows XP will not be able to detect any disk error but you´ll have a stupid XP instalation that doen´t work even with a Safe Mode or any recuperation disk....
Back to top
View user's profile Send private message 
HairyWill


Joined: 26 May 2006
Posts: 2949
Location: Southampton, UK

PostPosted: Wed 20 Jun 2007, 05:11    Post subject:  

As I understand it.
You have used a Gparted on puppy live CD to create a single NTFS partition on a disk.
You have then shutdown puppy without saving anything onto the disk and tried on more than one occasion to install XP.
Your XP installation process has failed in some way.
You are confident that this problem lies with the partition or formatting not the XP installation (I don't quite understand how)

As I see it the problem either lies with GParted or with XP I think it is highly unlikely to be caused by puppy.
I recommend you try the same process again but instead of using puppy just use a Gparted live CD. If you still get the same problem you need to talk to the Gparted guys or microsoft.

_________________
Will
contribute: community website, screenshots, puplets, wiki, rss
Back to top
View user's profile Send private message 
raffy

Joined: 25 May 2005
Posts: 4776
Location: Manila

PostPosted: Wed 20 Jun 2007, 19:26    Post subject: start with XP  

If you want to install XP then why start with Puppy? You can let XP wipe and format the entire drive, then when XP is already working, boot Puppy and add it to the system in one of two ways: (1) frugal without partitioning, or (2) frugal or normal with Puppy in its own partition.

Gparted will come into play only with option 2.

It is quite confusing to speculate about a bug (in Puppy) for problems in installing another OS. Smile

Here is another possibility: XP likes to be in the first partition.

_________________
Puppy user since Oct 2004. Want FreeOffice? Get the sfs (English only).
Back to top
View user's profile Send private message 
alienjeff


Joined: 08 Jul 2006
Posts: 2291
Location: Winsted, CT - USA

PostPosted: Wed 20 Jun 2007, 20:14    Post subject:  

Call Microsoft customer (non)service. And good luck ...

-aj

_________________
hangout: ##b0rked on irc.freenode.net
diversion: http://alienjeff.net - visit The Fringe
quote: "The foundation of authority is based upon the consent of the people." - Thomas Hooker

Back to top
View user's profile Send private message 
clarf


Joined: 13 Jun 2007
Posts: 612
Location: The old Lone Wolf

PostPosted: Thu 21 Jun 2007, 10:06    Post subject:  

Hi, thanks for the answers.

I boot from Puppy CD, because in a new non partitioned HD, Windows XP always try to make a NFTS partition, then i tried to create a FAT32 partition and install XP in it. With the FAT partition XP coulnd't finish the installation, with NFTS (made by GParted) it finished without errors. But the OS is just useless. Surprised

In fact i think that is a XP fault, it doesn't detect a FAT partition and it install fully in NTFS without a single error. What stupid OS. Razz

Another thing after i used GParted, i deleted the NTFS partition made by GParted with XP and created a new NTFS, but I got the same error. I Finally i had to make a Win98 boot disk and use Fdisk to create a new FAT32 partition an make a full format.... "XP after delete the NTFS partition made by GParted was unabled to create a new FUNCTIONAL NFTS partition for Windows installation"

All the time i created a single Partition for the entire HDD.

It is a Microsoft fault (full install in a incompatible Partition) Twisted Evil , or a Gparted bug....
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0541s ][ Queries: 11 (0.0043s) ][ GZIP on ]