Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 19 Apr 2014, 05:41
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Usuarios de habla Hispana
cable modem sb5100 ono
Moderators: rarsa
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
dromedario

Joined: 19 Jun 2007
Posts: 5

PostPosted: Tue 19 Jun 2007, 04:12    Post subject:  cable modem sb5100 ono  

mi pregrunta es si es posible conectarse a internet con este modem con puppy tengo las versiones 2.13 y 2.14 y ninguna me reconoce el modem, es extraño porque otras versiones de linux si me reconoce el modem

un salu2 y gracias
Back to top
View user's profile Send private message 
DiabloRojo


Joined: 11 Mar 2007
Posts: 27
Location: Madrid, Spain, Europe, Earth, Solar System

PostPosted: Tue 19 Jun 2007, 13:33    Post subject:  

Si es por USB entonces tendras que instalar el driver.

Si tienes puerto Ethrnet o de red local no es necesario, sino configurar tu tarjeta de red.

_________________
Foro de usuarios de (Forum of users of) OpenSUSE

LO SIENTO NO CONTESTO A PRIVADOS SOBRE GNU/LINUX.
Back to top
View user's profile Send private message 
dromedario

Joined: 19 Jun 2007
Posts: 5

PostPosted: Wed 20 Jun 2007, 03:13    Post subject:  

lo tengo conectado por usb ya que el puerto ethernet lo uso para una red local

me comentas el tema de drivers donde lo encuentro de hecho tengo un particion de linux con debian y no me ha hecho falta nuingun driver para que reconozca el modem con puerto eth1

he comprobado que puppy por lo menos cuando se utiliza como cd-live no tiene el directorio /etc/init para parar o reiniciar procesos por lo que no puedo jugar con la red para pararla o volverla a enceder

un salu2
Back to top
View user's profile Send private message 
DiabloRojo


Joined: 11 Mar 2007
Posts: 27
Location: Madrid, Spain, Europe, Earth, Solar System

PostPosted: Wed 20 Jun 2007, 13:17    Post subject:  

Veo que en Debian lo tienes por eth0, pues igual puedes hacerlo por Puppy.

En Wizard Net, puedes configurarlo es muy sencillo, claro siempre que detecte el driver sino lo cargas tu manualmente y lo configuras.
.

_________________
Foro de usuarios de (Forum of users of) OpenSUSE

LO SIENTO NO CONTESTO A PRIVADOS SOBRE GNU/LINUX.
Back to top
View user's profile Send private message 
dromedario

Joined: 19 Jun 2007
Posts: 5

PostPosted: Fri 22 Jun 2007, 10:13    Post subject:  

No mi conexion del cable moden no es a treves del puerto eth0 sino de eth1

he estado leyendo por ahi y lei que habia que levantar el modulo usbnet

modprobre usbnet

bien pues esta opcion funciona en distribuciones tan minimalista como DSL-N
cargo este modulo y ya me aparece el puerto eth1 luego solo tengo que activarlo con dchp

esta opcion no funciona en puppy, algo tiene que faltar y no son los drivers del modem porque no le hace falta

un salu2
Back to top
View user's profile Send private message 
DiabloRojo


Joined: 11 Mar 2007
Posts: 27
Location: Madrid, Spain, Europe, Earth, Solar System

PostPosted: Sat 23 Jun 2007, 13:30    Post subject:  

¿Sale algun mensaje de error?, mira si esta cargado con lsmod.

En Setup->Network wizard no aparece ese driver.

_________________
Foro de usuarios de (Forum of users of) OpenSUSE

LO SIENTO NO CONTESTO A PRIVADOS SOBRE GNU/LINUX.
Back to top
View user's profile Send private message 
dromedario

Joined: 19 Jun 2007
Posts: 5

PostPosted: Sat 23 Jun 2007, 14:35    Post subject:  

bueno por fin he encontrado el fallo (suele pasar en distribuciones tan minimalistas que suelen faltar modulos)

para poder cargar un cable modem a traves de usb hacen falta dos modulos
usbnet y cdc_ether

en puppy por los menos en sus versiones 2.13 y 2.14 no llevan incluido el fichero /lib/modules/2.6.18.1/kernel/drivers/usb/net/cdc_ether.ko

por lo cual para poder tenerlo he tenido que compilar el kernel

si alguno le hiciera falta ya tengo este modulo compilado por si tiene este modem u otro cable modem

para que active el modem en el inicio he tenido que modificar el fichero /etc/rc.d/rc.local
incluyendo las siguiente lineas la final del fichero

modprobe usbnet
modprobe cdc_ether
dhcpcd -d eth1

en mi caso eth1 porque es el puerto de conexion para otros puede ser eth0 0 eth2

un salu2
Back to top
View user's profile Send private message 
ZeNiTRaM

Joined: 04 Jun 2006
Posts: 29

PostPosted: Sun 24 Jun 2007, 17:52    Post subject:  

Creo que llego algo tarde, pero probaste con el archivo zdrv_2XX.sfs? Este trae los modulos del kernel que, por su tamaño, no "caben" en la Puppy a secas.. quizas traiga ya compilados los que te hacen falta Rolling Eyes
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Usuarios de habla Hispana
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0447s ][ Queries: 11 (0.0044s) ][ GZIP on ]