Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Sep 2014, 08:06
All times are UTC - 4
 Forum index » Taking the Puppy out for a walk » Suggestions
Compiling problems in 1.0.5a(Solved)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
Ian
Official Dog Handler


Joined: 04 May 2005
Posts: 1237
Location: Queensland

PostPosted: Mon 15 Aug 2005, 02:31    Post subject:  Compiling problems in 1.0.5a(Solved)  

I couldn't think of anywhere else to put this as we don't have a section relating to the use of 1.0.5alpha. I will move it if we accquire such a section or if John or Flash can think of where it should be posted. ( no rude suggestions please)

In trying to compile a program I got an error regarding ltclstub8.4 and from what I have been able to find out this is a file that is created when tcl is compiled.

Has anyone else had the same experience.

Last edited by Ian on Fri 19 Aug 2005, 03:59; edited 1 time in total
Back to top
View user's profile Send private message 
Guest
Guest


PostPosted: Mon 15 Aug 2005, 04:08    Post subject:  

Ian,Ian,Ian (shakes head in shame)




What are we trying to compile petal ?

hehehehe
Back to top
Ian-not-logged-in
Guest


PostPosted: Tue 16 Aug 2005, 00:53    Post subject:  

Its a database called Sqlite. Its here if you are interested in having a look.

http://www.sqlite.org/

Thanks mate.
Back to top
Ian
Official Dog Handler


Joined: 04 May 2005
Posts: 1237
Location: Queensland

PostPosted: Thu 18 Aug 2005, 02:52    Post subject:  

Ok, I finally found this:

http://www.tcl.tk/doc/howto/stubs.html

and here is a snippet from it:

'When you build or install Tcl, you will notice a new library, libtclstub8.1a.'

I can't find this library in Puppy, the only one I could find is /usr/lib/libtcl8.4.so.

I wonder what affect commenting it out of the makefile in sqlite would have.
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Thu 18 Aug 2005, 11:14    Post subject:  

The Tcl/Tk libraries currently used in Puppy are taken out of Mandrake 9.2.
I haven't yet migrated that library to Vector.

So, if you have access to Mandrake, fire it up, and you should find the req'd lib.

Note, the stub library that is missing can often be chosen to not be required by
a configure option prior to compiling -- some kind of "disable stubs" option.

Try
# ./configure --help
to see the options.
Back to top
View user's profile Send private message Visit poster's website 
Ian
Official Dog Handler


Joined: 04 May 2005
Posts: 1237
Location: Queensland

PostPosted: Thu 18 Aug 2005, 18:10    Post subject:  

Thanks for that Barry.

This is a followup.

I copied the two stub files tcl & tk from Mandrake 10.1 and it compiled, thanks again Barry.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Taking the Puppy out for a walk » Suggestions
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0451s ][ Queries: 11 (0.0056s) ][ GZIP on ]