Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 18 Sep 2014, 01:57
All times are UTC - 4
 Forum index » Taking the Puppy out for a walk » Suggestions
Please include hotplug and touchkitusb (Solved)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 3 [39 Posts]   Goto page: 1, 2, 3 Next
Author Message
DavidBell

Joined: 24 Nov 2006
Posts: 132

PostPosted: Sun 18 Mar 2007, 19:42    Post subject:  Please include hotplug and touchkitusb (Solved)  

I would like to see hotplug and touchkitusb included. I think they are part of 2.6.18 but I can't find them in Puppy. I tried compiling touchkitusb in Puppy2.14 but I had to modify it slightly, compiled and loads OK but still doesn't seem to work. DB
Last edited by DavidBell on Fri 03 Aug 2007, 20:08; edited 1 time in total
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5257
Location: Australia

PostPosted: Tue 20 Mar 2007, 20:59    Post subject:  

The "touchkitusb" module has apparently been replaced in newer kernels with the "usbtouchscreen" module.

UPDATE April 16 2009
Touchscreen HOWTO now consolidated in new thread here -
http://www.murga-linux.com/puppy/viewtopic.php?t=41286

Last edited by tempestuous on Thu 16 Apr 2009, 04:57; edited 2 times in total
Back to top
View user's profile Send private message 
DavidBell

Joined: 24 Nov 2006
Posts: 132

PostPosted: Thu 22 Mar 2007, 21:14    Post subject:  

Thankyou I'll try it this weekend. DB
Back to top
View user's profile Send private message 
DavidBell

Joined: 24 Nov 2006
Posts: 132

PostPosted: Fri 23 Mar 2007, 20:51    Post subject:  

I have usbtouchkit loading ... hotplug didn't seem to work but I fixed it by adding
Code:
In rc.local ...

insmod /lib/modules/2.6.18.1/kernel/drivers/usb/input/usbtouchscreen.ko


This gives me raw touchscreen but it's not calibrated properly. evtouch is meant to do this, but I haven't got it to load yet.

Code:
In /var/log/Xorg.0.log I get

(II) LoadModule: "input/evtouch" (evtouch)
(WW) LoadModule: given non-canonical module name "input/evtouch"
(II) Loading /usr/X11R7/lib/xorg/modules/input/evtouch_drv.so
dlopen: /lib/libc.so.6: version `GLIBC_2.4' not found (required by /usr/X11R7/lib/xorg/modules/input/evtouch_drv.so)
(EE) Failed to load /usr/X11R7/lib/xorg/modules/input/evtouch_drv.so
(II) UnloadModule: "evtouch"
(EE) Failed to load module "input/evtouch" (loader failed, 7)


Do I need the GLIBC_2.4 or a more up to date evtouch?

Thanks David
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5257
Location: Australia

PostPosted: Sat 24 Mar 2007, 06:32    Post subject:  

deleted
Last edited by tempestuous on Thu 16 Apr 2009, 05:00; edited 9 times in total
Back to top
View user's profile Send private message 
DavidBell

Joined: 24 Nov 2006
Posts: 132

PostPosted: Thu 05 Apr 2007, 03:41    Post subject:  

This still isn't working right, usbtouchklkit and evtouch seem to talk different languages. Can you please post me the usbtouchkit source you used, and the compile commands you used?

TIA. DB
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5257
Location: Australia

PostPosted: Thu 05 Apr 2007, 11:28    Post subject:  

DavidBell wrote:
... usbtouchklkit ...

The module is "usbtouchscreen"

The Evtouch Xorg plugin source is from -
http://stz-softwaretechnik.com/~ke/touchscreen/evtouch.html#download
Back to top
View user's profile Send private message 
joeblack


Joined: 15 May 2007
Posts: 11

PostPosted: Tue 15 May 2007, 11:20    Post subject: SAME PROBLEM  

I am trying to use it with lilliput touchscreen display. egalax touch controller. after insmod touch glass begin to move w/o calibation. But when I set xorg.conf as described, it freezes with a blank screen while loaindg X11. Did anyone find a solution? thanks
Back to top
View user's profile Send private message 
DavidBell

Joined: 24 Nov 2006
Posts: 132

PostPosted: Fri 25 May 2007, 18:03    Post subject:  

Quote:
But when I set xorg.conf as described, it freezes with a blank screen while loaindg X11


I had this problem too, in my case it was because some of the how-tos assumed different paths for xorg modules. Re-run the Xorg wizard to get a clean start, and double check each of the paths in your adjusted xorg.conf file really point to files.

I still haven't got my calibration to work though, I know it's doable becasue the thing does react to touches, and xorg is adjusting the input but I haven't got the calibration working. Just haven't had the time to put into it.

DB
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5257
Location: Australia

PostPosted: Fri 20 Jul 2007, 00:33    Post subject:  

deleted
Last edited by tempestuous on Thu 16 Apr 2009, 05:02; edited 6 times in total
Back to top
View user's profile Send private message 
DavidBell

Joined: 24 Nov 2006
Posts: 132

PostPosted: Fri 03 Aug 2007, 20:06    Post subject:  

Thanks tempestuous, didn't see your post until today. It is now working following your last instructions. I don't really know why it's work, but the fact that it is makes me happy Smile

I guess the main thing I was missing was that I wasn't loading evdev. Also I was using insmod instead of modprobe, don't know if that's important. Most of my other settings were the same.

I would still like to try hacking the usbtouchscreen module directly one day, so it works in XVesa. XOrg messes up my sound sometimes.

Thanks again David
Back to top
View user's profile Send private message 
boklanio

Joined: 20 Aug 2007
Posts: 5

PostPosted: Wed 22 Aug 2007, 16:32    Post subject:  

Hello All,

I'm sorry for asking this after all the info posted here, but I still need some assistance in setting up usb touchscreen device. I'm using puppy 2.17 which has kernel 2.6.21.5. I installed the posted package (new version) but when I execute the command modeprobe usbtouchscreen, bash reports:

FATAL: module usbtouchscreen not found

I think this might be because the pet package was compiled for kernel 2.6.18.1 (i think so because of the digits from the package title (file name). If this suggestion is correct, please suggest if there is a package for kernel 2.6.21.5 and please help me to compile one if it's not available.

If the package is not kernel-sensitive, please provide me with any suggestions that can solve this issue,

I began using Linux several days ago, so please accept my apologies if my suggestions seem stupid Embarassed .

Many thanks to all of you in advance.
Back to top
View user's profile Send private message 
tonylu9

Joined: 21 Aug 2007
Posts: 8
Location: Canada

PostPosted: Thu 23 Aug 2007, 11:19    Post subject: the driver seems work
Subject description: but , there are two issues
 

1. after execute
modprobe usbtouchscreen
modprobe evdev

I have to unplug the touchscreen usb cable and plug it in again, then I can see the event2 from the command "cat /proc/bus/input/devices"


2. the calibration
no idea why the touch will work so weird . dont know how to do that.
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
boklanio

Joined: 20 Aug 2007
Posts: 5

PostPosted: Fri 24 Aug 2007, 08:01    Post subject:  

Hello again I installed Puppy 2.15CE (kernel 2.6.18.1), followed the instructions posted by tempestuous (thank you very much, buddy! Wink ) and my touch panel is now working perfectly!

the calibration values should be:

Option "MinX" "900"

Option "MinY" "1090"

Option "MaxX" "16090"

Option "MaxY" "16000"

After that all is working Smile Thanks!
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5257
Location: Australia

PostPosted: Fri 24 Aug 2007, 09:32    Post subject:  

deleted
Last edited by tempestuous on Thu 16 Apr 2009, 05:03; edited 1 time in total
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 3 [39 Posts]   Goto page: 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Taking the Puppy out for a walk » Suggestions
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0761s ][ Queries: 11 (0.0092s) ][ GZIP on ]