Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 17:51
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
How to set up a Wacom Tablet
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 24 of 24 Posts_count   Goto page: Previous 1, 2, 3, ..., 22, 23, 24
Author Message
don570


Joined: 10 Mar 2010
Posts: 3437
Location: Ontario

PostPosted: Sat 19 Apr 2014, 15:27    Post_subject:  

There are actually two drivers

1) kernel
2) Xorg

The kernel driver is built into the puppy distro.
The Xorg driver has to be installed. (Although some distros have
it built-in as well such as Porteus and Ubuntu)


Google 'wacom + driver + linux'
http://sourceforge.net/projects/linuxwacom/files/xf86-input-wacom/



_________________________________________
Back to top
View user's profile Send_private_message 
Argolance


Joined: 06 Jan 2008
Posts: 1851
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sun 20 Apr 2014, 07:38    Post_subject:  

Bonjour don570,
Thanks for info.
Done!
It works perfectly for me, running Puppy Precise 5.7.1. The pet package is too big (304 ko) to be uploaded on the forum. So, for those who are interested in, xf86-input-wacom-k3.9.11-0.24.0.pet is available from the Arrow ToOpPy site repository.

Cordialement.

_________________

Back to top
View user's profile Send_private_message Visit_website 
charlie6


Joined: 30 Jun 2008
Posts: 1033
Location: South of Belgium

PostPosted: Tue 22 Apr 2014, 10:50    Post_subject:  

Hi don570 and all,

here are two xf86-wacom-input drivers download links, both compiled on wheezy-3.5.2.11:
the one is earlier version 0.17;
http://www.datafilehost.com/d/9719651c
this 0.17 runs OK here and ensures smooth cursor motions;

the second is the latest 0.24;
http://www.datafilehost.com/d/3a57b4fc
since version 0.18 (which has been told as "buggy"), i cannot get further versions working as nice as the 0.17 ! Crying or Very sad

Till now... keeping living with 0.17... Cool

I already reported it in earlier posts (around page22): whtever "relative" or "absolute" mode", the cursors arrow runs away to the above left screen corner once the stylus is lifted far away from the pad. I believe the cursor should stay were it has been left then, as it is the case on drivers up to 0.17.
All this using various tablets as Graphire1 , Volito1 and MTE450 (Bamboo) on desktops and laptops.

Do you get such a similar behaviour?

I reported this to wacom projects developper who could not reproduce it.

Thanks for eventual report !

Cheers,
Charlie
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3437
Location: Ontario

PostPosted: Tue 22 Apr 2014, 15:12    Post_subject:  

To Charlie .....

My Bamboo tablet has been working fine except Windows XP Rolling Eyes
where there's a bug that forces me to re-install
the driver from time to time.

There may be something wrong with my precise pet package that
I have listed. Did I leave out my script?? I'll download and check at home.

I recompiled the source in Precise 5.7.1 and here it is

http://www.datafilehost.com/d/87525f21

I'll check Argolance's package to see if it was made correctly.

To post it on this page I will drop an app from the package to
reduce it to 250 kb limit.

_________________________________
Back to top
View user's profile Send_private_message 
charlie6


Joined: 30 Jun 2008
Posts: 1033
Location: South of Belgium

PostPosted: Tue 16 Dec 2014, 16:30    Post_subject: cursors behaviour since xf-86-input wacom 0.17.0 [SOLVED]  

Hi don570 and all !
good news ... at least for me ... Laughing
charlie6 wrote:
...blablibla...
since version 0.18 (which has been told as "buggy"), i cannot get further versions working as nice as the 0.17 ! Crying or Very sad

Till now... keeping living with 0.17... Cool

I already reported it in earlier posts (around page22)...
Do you get such a similar behaviour?

I reported this to wacom projects developper who could not reproduce it.


I've just got this "still warm" post from wacom developper Jason Gerecke:
Quote:
Objet: [linuxwacom:bugs] #229 xf86-input driver versions above 0.17.0 : no right-click + unexpected cursor behaviour
De: "Jason Gerecke"
Date: Sam 13 décembre 2014 01:19
À: "[linuxwacom:bugs]" <229@bugs.linuxwacom.p.re.sf.net>
Priorité : Normale
Options: Afficher l'en-tête complet | Voir la version imprimante

status: open --> closed-works-for-me
Comment:

Both of these issues seem to result from an unexpected interaction between our driver and the generic "mouse" driver. As described in [bugs:#240], if you add Option "GrabDevice" "1" to each wacom InputDevice in /etc/X11/xorg.conf then both problems seem to be prevented.


I then compiled and installed version the latest version 0.27.0;
now ..here is xorg.conf edited accordingly (input devices section):
just added
Option "GrabDevice" "1"
in each input device.

Quote:
Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
#Screen 1 "Screen1" RightOf "Screen0"
#Screen 2 "Screen2" RightOf "Screen1"
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
#from kernel 2.6.35 and later the "SendCoreEvents" after InputDevice is no longer required
InputDevice "stylus"
InputDevice "eraser"
InputDevice "cursor"
InputDevice "pad"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc102"
Option "XkbLayout" "be" #xkeymap0
#Option "XkbVariant" "" #xkbvariant0
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2" #mouse0protocol
Option "Device" "/dev/mouse"
#Option "Emulate3Buttons"
#Option "Emulate3Timeout" "50"
Option "ZAxisMapping" "4 5" #scrollwheel
EndSection


Section "InputDevice"
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "USB" "on"
Option "GrabDevice" "1"
# Option "Mode" "Absolute"
Option "Mode" "Relative"
# Option "AlwaysCore" "on"
Option "Speed" "1.0"
Option "Threshold" "5"
Option "CursorProx" "5"
# Option "Speed" "5"
# # Option "ForceDevice" "ISDV4" # Serial Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "USB" "on"
Option "GrabDevice" "1"
EndSection

Section "InputDevice"
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/input/wacom" # USB ONLY
Option "Type" "cursor"
Option "USB" "on" # USB ONLY
Option "Mode" "Relative"
Option "GrabDevice" "1"
Option "CursorProx" "5"
Option "Speed" "1.0"
EndSection

Section "InputDevice"
Identifier "pad"
Driver "wacom"
Option "Device" "/dev/input/wacom" # USB ONLY
Option "Type" "pad"
Option "USB" "on" # USB ONLY
Option "GrabDevice" "1"
EndSection


restarted X, and the cursors mouse now moves as expected ... Shocked Smile (NB: Option "Mode" "Relative" is my favourite cursors behaviour Rolling Eyes )
just try it !!
hth Smile
charlie
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3437
Location: Ontario

PostPosted: Tue 16 Dec 2014, 21:22    Post_subject:  

I found this comment on wacom site

http://sourceforge.net/p/linuxwacom/bugs/229/?limit=25#9c30

I've downloaded version 0.27 and I'll try it on Precise puppy.
__________________________________________________
Back to top
View user's profile Send_private_message 
charlie6


Joined: 30 Jun 2008
Posts: 1033
Location: South of Belgium

PostPosted: Wed 17 Dec 2014, 01:36    Post_subject: xf86-input-wacom driver compiled for kernel 3.17.4  

hi don570 and all,
compiled on Tahr-6.0CE PAE k.3.17.4
here is xf86-input-wacom driver compiled for kernel 3.17.4 (337K ...might be possible to reduce the size under 250K .. Confused )
download link:
http://www.datafilehost.com/d/e3645c6a

NB: the device option #Option "GrabDevice" "1" is included as commented line in the /etc/X11/xorg.conf file (installed by the pinstall.sh) to the four devices:
Code:
#Option "GrabDevice" "1"

just uncomment it to activate that option.

Cheers, Charlie

ps: @don570: lot of thanks for the pinstall.sh ...works nice Smile !!
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3437
Location: Ontario

PostPosted: Wed 17 Dec 2014, 21:38    Post_subject:  

charlie6 wrote:
here is xf86-input-wacom driver compiled for kernel 3.17.4
(337K ...might be possible to reduce the size under 250K .


To get the size under 250k I leave the applications out.
xsetwacom is an app I don't use . Also /etc folder isn't needed either since rules are set set elsewhere.

______________________________________________________

I posted a new precise package on the previous page. It works well on my
Bamboo 450. I think your Bamboo 450 has a defect, otherwise more people
would have complained to wacom.

I tried putting

Code:
Option "Mode" "Relative"

into the xorg.conf file but it turned my pressure off.
________________________________________________


New Wacom Bamboo Splash models in store don't mention compatibilty with
Windows XP however on support forum they say it is possible to
use Windows XP and certain posted driver packages.
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3437
Location: Ontario

PostPosted: Thu 18 Dec 2014, 20:58    Post_subject: Tahr puppy driver works  

To Charlie:

I tested your pet package in tahr 5.8.3 and it works fine!
Fortunately you commented out the lines for Absolute and Relative position.

I re-packaged the pet

1) I removed everything in /etc i.e the rules since they are in /usr

2) Removed desktop file

3) Removed man files

4) Removed all applications

5) Removed kernel drivers wacom.so

6) Changed the warning message in pinstall.sh so it launches last.
This avoids a confusing jumble of windows.

The size is now well under 250k max so I can post it on the precious page. Laughing


___________________________________________
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 24 of 24 Posts_count   Goto page: Previous 1, 2, 3, ..., 22, 23, 24
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0961s ][ Queries: 12 (0.0145s) ][ GZIP on ]