Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 Apr 2014, 06:57
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Blender-2.45 Released Sept 19 2007
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 3 [33 Posts]   Goto page: 1, 2, 3 Next
Author Message
Previously known as Guest


Joined: 28 Sep 2005
Posts: 240

PostPosted: Tue 20 Feb 2007, 00:40    Post subject:  Blender-2.45 Released Sept 19 2007
Subject description: 3D rendering etc.
 

Blender-2.45 is the free open source 3D content creation suite, available for all major operating systems under the GNU General Public License.

http://www.blender.org/

Needed libraries in Puppy's PETget package manager:

libsdl-1.2.9 (492Kb)
xorg-OPENGL-7.0: opengl libraries (1132Kb)
Some scripts probably won't work unless
Python-2.4.3 python interpreter (36804Kb) is installed.

Additional libs. linked below.
arts-2.2.2-17
freealut-1.1.0-1
openal-0.0.8-1

Tested in Puppy 2.17.1 & 2.13

Removed blenderplayer.

Uninstall previous first.

Blender 2.45
7.8 MB
Blender-2.45.pup

Additional libs.
160 KB
Blender_libs-2.45.pup

BlenderPlayer.
3787 KB
Blender-2.45-blenderplayer.tar.gz

Last edited by Previously known as Guest on Mon 24 Sep 2007, 00:00; edited 5 times in total
Back to top
View user's profile Send private message 
john biles


Joined: 17 Sep 2006
Posts: 1382
Location: Australia

PostPosted: Tue 20 Feb 2007, 23:00    Post subject:  

Hello Previously known as Guest,
Will Blender work in Puppy 2.10 and is there Dotpups for these the required dependencies EG:
libsdl-1.2.9 (492Kb)
xorg-OPENGL-7.0: opengl libraries (1132Kb)

Instead of the PETget versions.

_________________
Legacy OS 2.1 LTS Released! Install me on a new! EXT2 Partition with 500Mb of swap and I'll be happy. Razz
Legacy OS 4 Released! Install to newer legacy hardware / early EeePC's Very Happy
Back to top
View user's profile Send private message Visit poster's website 
Previously known as Guest


Joined: 28 Sep 2005
Posts: 240

PostPosted: Wed 21 Feb 2007, 00:47    Post subject:  

john biles wrote:
Hello Previously known as Guest,
Will Blender work in Puppy 2.10 and is there Dotpups for these the required dependencies EG:
libsdl-1.2.9 (492Kb)
xorg-OPENGL-7.0: opengl libraries (1132Kb)

Instead of the PETget versions.


I've just tested in a fresh Puppy 2.10, it worked OK after installing this:

http://www.murga-linux.com/puppy/viewtopic.php?search_id=1113664903&t=1731

The previously mentioned libs are in PETget/Pupget package manager.
Back to top
View user's profile Send private message 
Fiberflinger


Joined: 12 Feb 2007
Posts: 223

PostPosted: Wed 21 Feb 2007, 10:34    Post subject: Older version of Blender  

I have an older version of Blender on a Mandrake 7.0 and want to enstall it. I'm not having much luck, mostly because I really don't know what the heck I'm doing. I finally got into a folder in /usr/local/share but kept getting a message that it was truncated. Don't even know what that means. I don't have my modem up and running on the Puppy side yet, so I downloaded unrpm on the "windows"side, but that did not seem to work either when I accessed it. I really feel stupid.

How do I get it going?

Fiber Flinger
Back to top
View user's profile Send private message Visit poster's website 
estel2000

Joined: 05 Apr 2007
Posts: 1

PostPosted: Thu 05 Apr 2007, 05:32    Post subject:  

Got Blender working! thx Smile

However, i had to use the .tar.bz2 from the official blender site. the .pup package didn't work for me...
Back to top
View user's profile Send private message 
Previously known as Guest


Joined: 28 Sep 2005
Posts: 240

PostPosted: Thu 05 Apr 2007, 17:07    Post subject:  

estel2000 wrote:
Got Blender working! thx Smile

However, i had to use the .tar.bz2 from the official blender site. the .pup package didn't work for me...


What version of Puppy are you running? In what way didn't the pup work, errors downloading? launching? It's running OK in versions listed in this thread so far & in 215CE.

Glad you finally got it working. Smile
Back to top
View user's profile Send private message 
john biles


Joined: 17 Sep 2006
Posts: 1382
Location: Australia

PostPosted: Fri 06 Apr 2007, 21:11    Post subject:  

Hello everyone,
Blender also needs python 2.4 installed from
http://puppyfiles.org/dotpupsde/dotpups/Programming/
to work.

_________________
Legacy OS 2.1 LTS Released! Install me on a new! EXT2 Partition with 500Mb of swap and I'll be happy. Razz
Legacy OS 4 Released! Install to newer legacy hardware / early EeePC's Very Happy
Back to top
View user's profile Send private message Visit poster's website 
Previously known as Guest


Joined: 28 Sep 2005
Posts: 240

PostPosted: Fri 06 Apr 2007, 21:49    Post subject:  

john biles wrote:
Hello everyone,
Blender also needs python 2.4 installed from
http://puppyfiles.org/dotpupsde/dotpups/Programming/
to work.


True, the version I've posted should have python deps included, just tested again in a fresh 2.14. Other deps are mentioned for the versions tested on so far. If there are other issues I've missed feedback appreciated. Smile
Back to top
View user's profile Send private message 
John Doe

Joined: 01 Aug 2005
Posts: 1689
Location: Michigan, US

PostPosted: Fri 06 Apr 2007, 22:31    Post subject:  

I got DRI running with my ATI card using OpenGL and Xorg7.1

Added libSDL and Python and Blender ran fine over here.
Back to top
View user's profile Send private message 
LeFish

Joined: 08 Apr 2007
Posts: 3

PostPosted: Tue 10 Apr 2007, 03:50    Post subject: Xlib: glx missing  

I installed all the previously mentioned pets and pups on my Puppy 2.15 CE final system. When I now start Blender the Xlib states the following:

Xlib: extension "GLX" missing on display ":0.0"


the xorg.config should be ok.


I'm using a radeon9800xt graphicscard.

I got Blender up and running and even yafray working with it yesterday afternoon after hours of trial and error. But after a mistake I had to reboot the system and did not save my configuration. I tried hours yesterday to get it running again, but I didnt know what I had done to get blender to work!


Thx for any help!

LeFish
Back to top
View user's profile Send private message 
john biles


Joined: 17 Sep 2006
Posts: 1382
Location: Australia

PostPosted: Tue 10 Apr 2007, 05:34    Post subject:  

Hello Previously known as Guest,
I also get the message
Xlib: extension "GLX" missing on display ":0.0" but haven't had time to try and get it working. Any ideas as it appears I'm not the only one with this problem.

_________________
Legacy OS 2.1 LTS Released! Install me on a new! EXT2 Partition with 500Mb of swap and I'll be happy. Razz
Legacy OS 4 Released! Install to newer legacy hardware / early EeePC's Very Happy
Back to top
View user's profile Send private message Visit poster's website 
Previously known as Guest


Joined: 28 Sep 2005
Posts: 240

PostPosted: Tue 10 Apr 2007, 06:58    Post subject:  

IIRC, it must run in Xorg & not Xvesa. I seem to remember that error before. Give feedback.
Back to top
View user's profile Send private message 
LeFish

Joined: 08 Apr 2007
Posts: 3

PostPosted: Tue 10 Apr 2007, 07:36    Post subject:  

I remember me being able to run it in Xorg, though... As I said: I donno how I did it, but it was possible. Twice even, if I recall it right. I just remebered me installing random packages until I got it to work. Now I would like to approach it in a more "scientific" way.

I found a pretty cool site on how xgl works. I believe this is what we need, right?!

http://principe.homelinux.net/
Back to top
View user's profile Send private message 
john biles


Joined: 17 Sep 2006
Posts: 1382
Location: Australia

PostPosted: Tue 10 Apr 2007, 09:09    Post subject:  

Hello Previously known as Guest,
I only run xorg on my PC so are getting this message while running xorg.
I have an old Riva TNT 32MB graphic card that really belongs in a 1998-2001 PC and I'm using a PC that originally had XP on it.
I found by using the old Graphic card that it didn't improve the preformance graphically, but freed up 32MB's of my RAM
Maybe this old graphics card is upsetting Blender some how?

_________________
Legacy OS 2.1 LTS Released! Install me on a new! EXT2 Partition with 500Mb of swap and I'll be happy. Razz
Legacy OS 4 Released! Install to newer legacy hardware / early EeePC's Very Happy
Back to top
View user's profile Send private message Visit poster's website 
Previously known as Guest


Joined: 28 Sep 2005
Posts: 240

PostPosted: Tue 10 Apr 2007, 09:58    Post subject:  

I've gotten the error & rebooted & that took care of it, restarting wm or X didn't. (after installing all deps).

Python & all the other deps installed, it works OK for me in Xorg. The previous release for puppy worked fine in xvesa, but this version wouldn't Question
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 3 [33 Posts]   Goto page: 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0628s ][ Queries: 11 (0.0032s) ][ GZIP on ]