Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 02:17
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Enlightenment will not load after upgrade to 2.13 from 2.12
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
Reni

Joined: 12 Sep 2006
Posts: 9

PostPosted: Tue 16 Jan 2007, 08:06    Post subject:  Enlightenment will not load after upgrade to 2.13 from 2.12  

Hi,
I've just upgraded to 2.13 from 2.12 and now e16 wm will not load (not at regular boot nor from the command prompt). I upgraded to 2.13 with full drivers. The enlightenment I'm using was compiled locally. I've recompiled under the new version, but to no avail. Perhaps I need the latest devx version also? Does anybody have any suggestions?

Thanks,
Reni
Back to top
View user's profile Send private message 
Dougal


Joined: 19 Oct 2005
Posts: 2505
Location: Hell more grotesque than any medieval woodcut

PostPosted: Tue 16 Jan 2007, 14:37    Post subject:  

You say you've recompiled under the new version, but have not got the new devx module? The filesystem is pretty similar in 2.12 and 2.13, but it's always good to use the right devx rather than renaming the old one…

How do you mean E16 doesn't work? Have you tried to "ldd" the binary to see if there's a problem with libraries?

If you try starting X with E16 (i.e. running "xwin e16" or "xwin enlightenment" or whatever) and end up back in the command-line, you should try saving the xerrs.log file (or looking at it with mp or something).
Just type
Code:
cp /tmp/xerrs.log ~/xerrs.e16
and then start X into JWM (or whatever) and look at the xerrs.e16 file -- you should find a message saying why if failed.
_________________
What's the ugliest part of your body?
Some say your nose
Some say your toes
But I think it's your mind
Back to top
View user's profile Send private message 
Reni

Joined: 12 Sep 2006
Posts: 9

PostPosted: Wed 17 Jan 2007, 21:08    Post subject: e16
Subject description: e16 loading fixed
 

Thanks Dougal.
Looking into the xerrs.log file was the key. I needed to recompile Imlib2 v1.2.0 and FreeType2 2.1.6 before it would load. I didn't need the latest devx file, but I've recently downloaded and installed it.

Thanks again for the help.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0520s ][ Queries: 11 (0.0147s) ][ GZIP on ]