Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 31 Oct 2014, 00:18
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Puppy 2.12: 3D-Control-Center V2.00
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 6 Posts_count   Goto page: 1, 2, 3, 4, 5, 6 Next
Author Message
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sat 25 Nov 2006, 20:59    Post_subject:  Puppy 2.12: 3D-Control-Center V2.00  

This is a slightly modified version for Puppy 2.12

Details about the program (and older versions):
http://www.murga-linux.com/puppy/viewtopic.php?t=10834

Download:
http://dotpups.de/dotpups/3D-Control-Center/getdir.pup (20 kb)
http://dotpups.de/dotpups/3D-Control-Center/Gtklist04MU.pup (18 kb)
http://dotpups.de/dotpups/3D-Control-Center/3DCC-Puppy-2.12-and-2.13.pup (74 kb)
It requires an active internet-connection, to be able to download additional files required for your graficscard.


I did not test it intesively, so please report all bugs you find.
But t should work, as I just had to change some version-numbers.

Nvidia-users
there is an own installer for you:
http://www.murga-linux.com/puppy/viewtopic.php?t=14438

Mark

Edited_times_total
Back to top
View user's profile Send_private_message Visit_website 
Pizzasgood


Joined: 04 May 2005
Posts: 6270
Location: Knoxville, TN, USA

PostPosted: Tue 28 Nov 2006, 04:04    Post_subject:  

Quote:
This version does not support the propriatary ATI-driver, I will compile the required kernel-module tomorrow.

Did you do that yet, or am I just being glitchy? It's to late/early for me to go digging around for error messages, so lets just say I'm getting higher framerates with the vesa driver than with the fglrx driver without DRI. 25 vs 14, to be exact Neutral

_________________
Between depriving a man of one hour from his life and depriving him of his life there exists only a difference of degree. --Muad'Dib

Back to top
View user's profile Send_private_message Visit_website 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Tue 28 Nov 2006, 04:48    Post_subject: Re: Puppy 2.12: 3D-Control-Center V2.00  

MU wrote:

I did not test it intesively, so please report all bugs you find.
But t should work, as I just had to change some version-numbers.

Mark

Hey Mark, thanks for that! Much appreciated.

I have installed too, but like Pizzasgood I'm getting some strange activity.

Even though I loaded the i810 DRI - correct for my hardware - when I try your Demo it says that
Quote:
DRI-Status: DRI is NOT active, the demo should run slow (< 10 fps)

Only trouble is I still get frame rates >20fps, according to the Demo screen!

I absolutely LOVE the window shadows, though. What do I have to change to get that to load at startup?

Vista, eat your heart out! Razz

Cheers
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Tue 28 Nov 2006, 09:00    Post_subject:  

Sorry, I had uploaded the old dotpup by accident Embarassed
I updated it with a new one now.

I did not yet compile the ATI propriatary driver, hope I can do it today.

-------------

Quote:
I absolutely LOVE the window shadows, though. What do I have to change to get that to load at startup?


You can add such 2 lines to /root/.xinitrc, before
exec $CURRENTWM

Code:
  killall xcompmgr
  xcompmgr -c -l -14 -t -14 -r 15 -o .7 2>/dev/null&


Look with an editor at
/usr/local/3DCC/resource/run-shaows
for other parameters to display shadows different, try
xcompmgr --help
for details.

Mark
Back to top
View user's profile Send_private_message Visit_website 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Tue 28 Nov 2006, 17:25    Post_subject: Re: Puppy 2.12: 3D-Control-Center V2.00  

WhoDo wrote:

Even though I loaded the i810 DRI - correct for my hardware - when I try your Demo it says that
Quote:
DRI-Status: DRI is NOT active, the demo should run slow (< 10 fps)

Only trouble is I still get frame rates >20fps, according to the Demo screen!

Hi Mark. Sorry, but no change even though I downloaded all the dotpups again, reinstalled and rebooted. Same error as above.

Cheers
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Tue 28 Nov 2006, 23:24    Post_subject:  

whodoo, please send me your /var/log/Xorg.0.log as attachment.

----------------
I uploaded the ATI-propriatary driver dotpup, you can install it from within the 3DCC (DRI-Graficscard-drivers -> ATI-fglrx).

This was nasty Evil or Very Mad
First the Kernelmodule failed to compile, but this helped me:
http://www.gentooforum.de/thread.php?threadid=11378
Quote:
/usr/src/linux/include/linux/mm.h

insert after the "include" lines:

#define VM_SHM 0x00000000


Then I got strange errors from libGL that are reported in many forums, but a re-installation with the Ati-installer fixed it.
I hope, the dotpup works, at least it did then in a new Test-Muppy.

I also could compile the newer driver, but made no dotpup, as I cannot test it.
The new driver no longer supports cards older than Radeon 9500.

Mark
Back to top
View user's profile Send_private_message Visit_website 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Wed 29 Nov 2006, 01:02    Post_subject:  

MU wrote:
whodoo, please send me your /var/log/Xorg.0.log as attachment.

Here it is, Mark. After reading the file I also tried the i915 driver as well, but the same result.

Cheers

Update: Hmmm. Board won't let me add an attachment with .log, .sav or .txt extension ... something is amiss. I have changed extension to .gz but file is still raw text.
Xorg.0.log.gz
Description 
gz

 Download 
Filename  Xorg.0.log.gz 
Filesize  61.02 KB 
Downloaded  691 Time(s) 
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Wed 29 Nov 2006, 11:30    Post_subject:  

2146: (II) I810(0): direct rendering: Disabled

But no hint, why.
I miss entries concerning DRM , loading a Kernel-Module.
Do you have these files?:
/lib/modules/2.6.18.1/kernel/drivers/char/drm/drm.ko
and
/lib/modules/2.6.18.1/kernel/drivers/char/drm/i810.ko
/lib/modules/2.6.18.1/kernel/drivers/char/drm/i915.ko

In the logs I was sent in the past I find none for intel-chips.
If someone with working accelleration (even on other Pupyversions) might post his log, we might get a hint by comparing them...

For example my Ati-fglrx-driver has such lines in the log, that show that it tries to use the Kernelmodule:

Quote:
(II) fglrx(0): [drm] DRM interface version 1.0
(II) fglrx(0): [drm] created "fglrx" driver at busid "PCI:1:0:0"
(II) fglrx(0): [drm] added 8192 byte SAREA at 0x2000
(II) fglrx(0): [drm] mapped SAREA 0x2000 to 0xb6f4d000
(II) fglrx(0): [drm] framebuffer handle = 0x3000
(II) fglrx(0): [drm] added 1 reserved context for kernel
(II) fglrx(0): DRIScreenInit done
(II) fglrx(0): Kernel Module Version Information:
(II) fglrx(0): Name: fglrx
(II) fglrx(0): Version: 8.28.8
(II) fglrx(0): Date: Aug 17 2006
(II) fglrx(0): Desc: ATI FireGL DRM kernel module
(II) fglrx(0): Kernel Module version matches driver.
(II) fglrx(0): Kernel Module Build Time Information:


I think, also with Intel something concerning DRM should be reported, but as it is not, the drm.ko might not have been found.
Mark
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Wed 29 Nov 2006, 11:44    Post_subject:  

Ah, found it.

Please delete:
/root/dotpups-downloads/DRM-Kernelmodules-Puppy.pup

Then again in 3DCC, install the Kernelmodules.
I had packaged them in a wrong folder Embarassed Embarassed

They went to /modules/
instead of
/lib/modules/

You can delete /modules/

Mark
Back to top
View user's profile Send_private_message Visit_website 
dvw86


Joined: 04 May 2005
Posts: 636
Location: Washington State

PostPosted: Wed 29 Nov 2006, 19:45    Post_subject:  

Mark,
Would this affect the VIA unichrome drivers as well? They install in Puppy 2.12 but do not enable DRI.
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Wed 29 Nov 2006, 19:57    Post_subject:  

Yes, there is a unichrome-driver for xorg:
http://dotpups.de/3DCC/2.12/
The Kernel-dotpup contains a via.ko-module.
You can choose unichrome in the 3DCC.

I could not test it myself though, so no guarantee.

Please look first in xorg.conf, what Puppys xorgwizard entered as

Driver "xxx"

If xxx is vesa, you might have to replace it with
Driver "via"

/usr/X11R7/lib/xorg/modules/drivers/
has no unichrome, so I assume it is via.
The via-module then automatically should load
/usr/X11R7/lib/xorg/modules/dri/unichrome_dri.so
This file is installed by 3DCC from the dotpup DRI-unichrome_dri.so.pup.

Try and please report if it works or not.

Mark
Back to top
View user's profile Send_private_message Visit_website 
dvw86


Joined: 04 May 2005
Posts: 636
Location: Washington State

PostPosted: Wed 29 Nov 2006, 20:14    Post_subject:  

Quote:

Ah, found it.

Please delete:
/root/dotpups-downloads/DRM-Kernelmodules-Puppy.pup
Then again in 3DCC, install the Kernelmodules.
I had packaged them in a wrong folder Embarassed Embarassed

They went to /modules/
instead of
/lib/modules/

You can delete /modules/

Mark


That fixed it for the VIA unichrome drivers as well. Thanks Mark.
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Wed 29 Nov 2006, 20:31    Post_subject:  

yes, it affects all drivers.
Mark
Back to top
View user's profile Send_private_message Visit_website 
Roger

Joined: 01 Mar 2006
Posts: 15
Location: Germany

PostPosted: Thu 30 Nov 2006, 08:07    Post_subject: mach64  

Hi,

just tried it on my notebook with mach64 - no success.
The 3d demo runs but tells me dri is not anbaled, i get about 7 fps.

From the xorg log:
(==) ATI(0): Write-combining range (0x40000000,0x800000)
(II) ATI(0): [drm] SAREA 2200+1208: 3408
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
[drm] failed to load kernel module "mach64"
(II) ATI(0): [drm] drmOpen failed
(EE) ATI(0): [dri] DRIScreenInit Failed

I managed to get drm/dri running (with lots of help from you) on puppy 1.08 - but that was xorg 6

Any ideas?
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Thu 30 Nov 2006, 08:25    Post_subject:  

there was no mach64 kernel-module in zdrv_212.sfs.
I will try to compile one this evening.

Mark
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 6 Posts_count   Goto page: 1, 2, 3, 4, 5, 6 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1844s ][ Queries: 12 (0.0947s) ][ GZIP on ]