Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 20 Nov 2019, 19:34
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
DpupBuster CE 64 and 32 bit
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 6 of 9 [128 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9 Next
Author Message
rameshiyer

Joined: 17 Sep 2009
Posts: 281
Location: Calicut, Kerala, India

PostPosted: Mon 09 Sep 2019, 00:52    Post subject: DpupBuster
Subject description: Internal hard disk Installation
 

I have created a menu entry in refind in EasyOs (fat 32 separate Partition) 640 mb and loading DpupBuster. See I a just layman user only. Only my passion doing something through train and error method. I don't know how to load frugal method. Anyway I will frugal also.
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger 
01101001b


Joined: 08 Mar 2017
Posts: 90
Location: Buenos Aires, Argentina

PostPosted: Sat 28 Sep 2019, 19:40    Post subject: Re: virtualbox 6
Subject description: virtualbox 6
 

josejp2424 wrote:
testing virtualbox without kernel source or devx.

TiredPup wrote:
I decided to try out Virtual Box which I do use from time to time. I installed the Devx and Kernel Source packages provided. This is the result.

Could it be the hardware? . I really don't know.
but in my case virtualbox is working.
it would be necessary to see if some user the same thing happens to him.

Same problem here. It seems to be a Virtualbox recurring bug. I had the same problem with VBox 6.0.12 yesterday while trying LxPupSc64 but back then, being in a hurry, I thought (wrongly) LxPupSc64 was the culprit so I ditched it with no second thoughts Sad

Luckily I found later this superb pup and also a Virtualbox .pet so I thought "Great! Problem solved!" but no, it wasn't Sad

Searching for a solution, it seems VBox 6.0.4 worked for some people with this issue. I'll give it a try in a few moments and we'll see :crossfingers: Wink

EDIT: I guess I was asleep or something the first time I installed the Virtualbox pet because after make sure devx and headers.sfs were loaded, I reinstalled and it worked... sort of, since I could now start my virtual machine only after change my virtual netcard first (from bridged adapter to NAT).

Nonetheless, I did try version 6.0.12 again to no avail. Same problem. Finally I tried 6.0.4 and after some complaining about a problem regarding group "vboxusers", it worked perfectly (with the bridged adapter selected again) after creating that group and run /sbin/vboxconfig once more. Hope this helps.
Back to top
View user's profile Send private message 
josejp2424


Joined: 01 Aug 2010
Posts: 513

PostPosted: Sun 29 Sep 2019, 22:39    Post subject: Re: virtualbox 6
Subject description: virtualbox 6
 

01101001b wrote:
josejp2424 wrote:
testing virtualbox without kernel source or devx.

TiredPup wrote:
I decided to try out Virtual Box which I do use from time to time. I installed the Devx and Kernel Source packages provided. This is the result.

Could it be the hardware? . I really don't know.
but in my case virtualbox is working.
it would be necessary to see if some user the same thing happens to him.

Same problem here. It seems to be a Virtualbox recurring bug. I had the same problem with VBox 6.0.12 yesterday while trying LxPupSc64 but back then, being in a hurry, I thought (wrongly) LxPupSc64 was the culprit so I ditched it with no second thoughts Sad

Luckily I found later this superb pup and also a Virtualbox .pet so I thought "Great! Problem solved!" but no, it wasn't Sad

Searching for a solution, it seems VBox 6.0.4 worked for some people with this issue. I'll give it a try in a few moments and we'll see :crossfingers: Wink

EDIT: I guess I was asleep or something the first time I installed the Virtualbox pet because after make sure devx and headers.sfs were loaded, I reinstalled and it worked... sort of, since I could now start my virtual machine only after change my virtual netcard first (from bridged adapter to NAT).

Nonetheless, I did try version 6.0.12 again to no avail. Same problem. Finally I tried 6.0.4 and after some complaining about a problem regarding group "vboxusers", it worked perfectly (with the bridged adapter selected again) after creating that group and run /sbin/vboxconfig once more. Hope this helps.


I really thank you for the tests.. 01101001b

_________________
Shiba Inu | Pupjibaro jessie | My Blog
Back to top
View user's profile Send private message Visit poster's website 
josejp2424


Joined: 01 Aug 2010
Posts: 513

PostPosted: Mon 30 Sep 2019, 13:27    Post subject: DpupBuster 32 bits
Subject description: Dpupbuste32
 

it's an update of DPupBuster-7.9.0.2..

thanks nilsonmorales for the wallapers he did

For those who use the previous version, it is no longer compatible with this one because the location of the libraries has changed. so the devx will not work either.


.

Use PULSEAUDIO.
RETROVOL was replaced by PASYTRAY.
Pulseaudio is more compatible, many programs use it (skype, firefox, Simplescreen recorder).
Note that pulseaudio is only working as root. It is not working as SPOT..



Pkg - CLI package manager ( Thank you sc0ttman).
I love this program, and it works great. You can use apt-get or apt to install programs.
Also Pkg as the PPM, they use only Debian Buster repo.



this dpupbuster 32 is the same as dpupbuster 64.
It has all the same programs, except that it doesn't bring mpaint.

Gimp 2.4 compiled by ,ttuuxxx.



For test Dpupbuster 32.


Download dpupbuster-32bits-PAE-8.0.0-uefi-beta3_29092019.iso

Download dpupbuster-32bits-No-PAE-8.0.0-uefi-beta3_29092019.iso

_________________
Shiba Inu | Pupjibaro jessie | My Blog
Back to top
View user's profile Send private message Visit poster's website 
01101001b


Joined: 08 Mar 2017
Posts: 90
Location: Buenos Aires, Argentina

PostPosted: Tue 01 Oct 2019, 17:27    Post subject: Re: virtualbox 6
Subject description: virtualbox 6
 

josejp2424 wrote:
I really thank you for the tests.. 01101001b

Hi josejp2424! You're welcome! Cool

By the way, I've seen (in sourceforge) you have compiled Nvidia drivers for 340 and 410 for dpupbuster 64 (4.19.23) Any chance you can do the same for 304? Because I'm out of luck in that matter Crying or Very sad

Regardless you can or not, thanks in advance! Very Happy
Back to top
View user's profile Send private message 
TiredPup


Joined: 16 Jun 2019
Posts: 30
Location: United States

PostPosted: Wed 02 Oct 2019, 08:19    Post subject:  

I have installed dpupbuster64 8.0 RC1 to an USB flash drive and am using it to boot my recently acquired windows 10 HP laptop. This unit has the RTL8821CE wifi card. I installed the driver for it with a *.pet package made by peebee for use with his bionicpup64 8.0. It works quite well. Thank you for your for this.

Quote:
$ inxi -F
System:
Host: dpupbuster64 Kernel: 4.19.23 x86_64 bits: 64 Desktop: JWM 2.3.7
Distro: Puppy 8.0.0
Machine:
Type: Laptop System: HP product: HP Laptop 15-db0xxx
v: Type1ProductConfigId serial: CND8366W7P
Mobo: HP model: 84AE v: 86.20 serial: PHJMPE4NMBAG0P UEFI: Insyde v: F.10
date: 05/31/2018
Battery:
ID-1: BAT1 charge: 40.7 Wh condition: 40.7/41.0 Wh (99%)
CPU:
Topology: Quad Core model: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx
bits: 64 type: MT MCP L2 cache: 2048 KiB
Speed: 1371 MHz min/max: 1600/2000 MHz Core speeds (MHz): 1: 1372 2: 1372
3: 1368 4: 1372 5: 1372 6: 1375 7: 1595 8: 1499
Graphics:
Device-1: AMD driver: amdgpu v: kernel
Display: server: X.Org 1.20.4 driver: amdgpu,ati
unloaded: fbdev,modesetting,vesa resolution: 1366x768~60Hz
OpenGL: renderer: AMD RAVEN (DRM 3.27.0 4.19.23 LLVM 7.0.1)
v: 4.5 Mesa 18.3.6
Audio:
Device-1: AMD driver: snd_hda_intel
Device-2: AMD driver: N/A
Device-3: AMD driver: snd_hda_intel
Sound Server: ALSA v: k4.19.23
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8169
IF: eth0 state: down mac: f4:39:09:c9:da:ab
Device-2: Realtek driver: rtl8821ce
IF: wlan0 state: up mac: d8:9c:67:a5:c2:c9
Drives:
Local Storage: total: 960.76 GiB used: 5.12 GiB (0.5%)
ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS541010B7 size: 931.51 GiB
ID-2: /dev/sdb vendor: SanDisk model: Cruzer Glide size: 29.25 GiB
Sensors:
Missing: Required tool sensors not installed. Check --recommends
Info:
Processes: 181 Uptime: 9m Memory: 7.52 GiB used: 597.3 MiB (7.8%)
Shell: bash inxi: 3.0.32
Screenshot.png
 Description   
 Filesize   72.34 KB
 Viewed   817 Time(s)

Screenshot.png

Back to top
View user's profile Send private message 
darry19662018

Joined: 31 Mar 2018
Posts: 645
Location: Rakaia

PostPosted: Sat 05 Oct 2019, 03:58    Post subject:
Subject description: 7.9.0.1 32bit versin
 

Very nice so far Joesph - thank you running flawlessly on HP dv6000.Smile
_________________
Puppy Linux Wiki: http://wikka.puppylinux.com/HomePage

https://freemedia.neocities.org/
Back to top
View user's profile Send private message Visit poster's website 
josejp2424


Joined: 01 Aug 2010
Posts: 513

PostPosted: Sun 06 Oct 2019, 21:35    Post subject: Re: virtualbox 6
Subject description: virtualbox 6
 

01101001b wrote:
josejp2424 wrote:
I really thank you for the tests.. 01101001b

Hi josejp2424! You're welcome! Cool

By the way, I've seen (in sourceforge) you have compiled Nvidia drivers for 340 and 410 for dpupbuster 64 (4.19.23) Any chance you can do the same for 304? Because I'm out of luck in that matter Crying or Very sad

Regardless you can or not, thanks in advance! Very Happy


yes 01101001b, I will upload the nvidia drivers. Very Happy

TiredPup wrote:
I have installed dpupbuster64 8.0 RC1 to an USB flash drive and am using it to boot my recently acquired windows 10 HP laptop. This unit has the RTL8821CE wifi card. I installed the driver for it with a *.pet package made by peebee for use with his bionicpup64 8.0. It works quite well. Thank you for your for this.

Quote:
$ inxi -F
System:
Host: dpupbuster64 Kernel: 4.19.23 x86_64 bits: 64 Desktop: JWM 2.3.7
Distro: Puppy 8.0.0
Machine:
Type: Laptop System: HP product: HP Laptop 15-db0xxx
v: Type1ProductConfigId serial: CND8366W7P
Mobo: HP model: 84AE v: 86.20 serial: PHJMPE4NMBAG0P UEFI: Insyde v: F.10
date: 05/31/2018
Battery:
ID-1: BAT1 charge: 40.7 Wh condition: 40.7/41.0 Wh (99%)
CPU:
Topology: Quad Core model: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx
bits: 64 type: MT MCP L2 cache: 2048 KiB
Speed: 1371 MHz min/max: 1600/2000 MHz Core speeds (MHz): 1: 1372 2: 1372
3: 1368 4: 1372 5: 1372 6: 1375 7: 1595 8: 1499
Graphics:
Device-1: AMD driver: amdgpu v: kernel
Display: server: X.Org 1.20.4 driver: amdgpu,ati
unloaded: fbdev,modesetting,vesa resolution: 1366x768~60Hz
OpenGL: renderer: AMD RAVEN (DRM 3.27.0 4.19.23 LLVM 7.0.1)
v: 4.5 Mesa 18.3.6
Audio:
Device-1: AMD driver: snd_hda_intel
Device-2: AMD driver: N/A
Device-3: AMD driver: snd_hda_intel
Sound Server: ALSA v: k4.19.23
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8169
IF: eth0 state: down mac: f4:39:09:c9:da:ab
Device-2: Realtek driver: rtl8821ce
IF: wlan0 state: up mac: d8:9c:67:a5:c2:c9
Drives:
Local Storage: total: 960.76 GiB used: 5.12 GiB (0.5%)
ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS541010B7 size: 931.51 GiB
ID-2: /dev/sdb vendor: SanDisk model: Cruzer Glide size: 29.25 GiB
Sensors:
Missing: Required tool sensors not installed. Check --recommends
Info:
Processes: 181 Uptime: 9m Memory: 7.52 GiB used: 597.3 MiB (7.8%)
Shell: bash inxi: 3.0.32
.

Thanks TiredPup, for the tests. Very Happy

darry19662018 wrote:
Very nice so far Joesph - thank you running flawlessly on HP dv6000.Smile


thanks darry19662018 Very Happy

_________________
Shiba Inu | Pupjibaro jessie | My Blog
Back to top
View user's profile Send private message Visit poster's website 
ETP


Joined: 19 Oct 2010
Posts: 1170
Location: UK

PostPosted: Mon 07 Oct 2019, 15:38    Post subject: Testing: - dpupbuster64-8.0.0-uefi-RC-1 issued 7th Sept 201  

Testing: - dpupbuster64-8.0.0-uefi-RC-1 issued 7th Sept 2019

Hi josejp2424,

Thanks for RC-1.

PulseAudio with SSR was tested successfully and a 4th video has been added
to the album of test videos. (Bottom right with the white dog)

https://photos.app.goo.gl/spuoAuu5bXgEZzXp9

.

_________________
Regards ETP

Kennels
Back to top
View user's profile Send private message 
01101001b


Joined: 08 Mar 2017
Posts: 90
Location: Buenos Aires, Argentina

PostPosted: Thu 10 Oct 2019, 19:34    Post subject: Re: virtualbox 6
Subject description: virtualbox 6
 

josejp2424 wrote:
01101001b wrote:
you have compiled Nvidia drivers for 340 and 410 for dpupbuster 64 (4.19.23) Any chance you can do the same for 304?

yes 01101001b, I will upload the nvidia drivers. Very Happy

Thank you, thank you, thank you! You are my hero Very Happy Wink
Back to top
View user's profile Send private message 
linux28

Joined: 05 Apr 2009
Posts: 236

PostPosted: Thu 10 Oct 2019, 22:11    Post subject:  

no make

from .gdumpparser import IntrospectionBinary
File "/usr/lib/x86_64-linux-gnu/gobject-introspection/giscanner/gdumpparser.py", line 35, in <module>
from .transformer import TransformerException
File "/usr/lib/x86_64-linux-gnu/gobject-introspection/giscanner/transformer.py", line 35, in <module>
from .sourcescanner import (
File "/usr/lib/x86_64-linux-gnu/gobject-introspection/giscanner/sourcescanner.py", line 32, in <module>
from .ccompiler import CCompiler
File "/usr/lib/x86_64-linux-gnu/gobject-introspection/giscanner/ccompiler.py", line 29, in <module>
from distutils.msvccompiler import MSVCCompiler
ModuleNotFoundError: No module named 'distutils.msvccompiler'
Back to top
View user's profile Send private message 
linux28

Joined: 05 Apr 2009
Posts: 236

PostPosted: Thu 10 Oct 2019, 22:17    Post subject:  

No module named 'distutils.msvccompiler


no make


DpupBuster CE 64

edited thunar/thunar-window.c to remove running-as-root message.
make thunar
Back to top
View user's profile Send private message 
linux28

Joined: 05 Apr 2009
Posts: 236

PostPosted: Sat 12 Oct 2019, 22:39    Post subject: gvfs  

/usr/lib/gio/modules/libgioremote-volume-monitor.so: wrong ELF class: ELFCLASS32
Failed to load module: /usr/lib/gio/modules/libgioremote-volume-monitor.so
/usr/lib/gio/modules/libgvfsdbus.so: wrong ELF class: ELFCLASS32
Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 14484
Location: Gatineau (Qc), Canada

PostPosted: Sat 12 Oct 2019, 22:48    Post subject:  

Hello Linux28.

I don't know about the other things you mention, but make IS in the devx for this Puppy.
Not in the main Pup sfs, in the devx sfs. I compiled a couple of things with it; it works fine.

Have a look in José's repo for this DPupBuster, the devx should be there.

IHTH.

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
linux28

Joined: 05 Apr 2009
Posts: 236

PostPosted: Sun 13 Oct 2019, 07:29    Post subject:  

musher0 wrote:
Hello Linux28.

I don't know about the other things you mention, but make IS in the devx for this Puppy.
Not in the main Pup sfs, in the devx sfs. I compiled a couple of things with it; it works fine.

Have a look in José's repo for this DPupBuster, the devx should be there.

IHTH.


Thank you! I downloaded and installed devx, I want to use thunar, it can't be gvfs, I want to edited thunar/thunar-window.c to remove running-as-root message.
Make thunar, but the compilation is wrong, the tips are those above.
I am a newbie, don't understand everyone. Don't be surprised.
thank you very much!
I want to use thunar, remove running-as-root message
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 6 of 9 [128 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1076s ][ Queries: 12 (0.0194s) ][ GZIP on ]