Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

READ-ONLY-MODE: PLEASE DO NOT POST NEW STUFF!
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile       

The time now is Tue 11 Aug 2020, 03:02
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
GPU not recognized by current Slimjet and Iron browsers?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [15 Posts]  
Author Message
gjuhasz


Joined: 29 Sep 2008
Posts: 422

PostPosted: Thu 20 Jun 2019, 03:24    Post subject:  GPU not recognized by current Slimjet and Iron browsers?  

Dear Slimjet/Iron/Chrome users,

Do you see any difference between the current Slimjet and Iron browsers in your own puplet?

It seems that in Slimjet (and Chrome) the gpu is not recognized and cannot be corrected in the browser settings.

See the attached screenshots and http://madebyevan.com/webgl-water/

Thanks in advance.

Have fun!

Regards,

gjuhasz
slimjet.png
 Description   Problems in Slimjet
 Filesize   97.15 KB
 Viewed   549 Time(s)

slimjet.png

iron.png
 Description   Correct webgl handling in Iron
 Filesize   63.46 KB
 Viewed   567 Time(s)

iron.png

Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3635
Location: wales ... by the sea

PostPosted: Thu 20 Jun 2019, 04:58    Post subject:  

hi gjuhasz,

yes i've noticed the newest chromium based browsers no longer have hardware acceleration enabled . also you don't seem to be able to enable it in its settings Sad . Version 73 has hardware acceleration working

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 6397
Location: King's Lynn, UK.

PostPosted: Thu 20 Jun 2019, 07:12    Post subject:  

@ gjuhasz/philb666:-

Have a look at this thread of mine from a while back:-

http://www.murga-linux.com/puppy/viewtopic.php?t=114441

The flags might say they're 'switchable' (and act as if they are!).....but for Linux, at least, they've been disabled internally to the browser process. For us, they don't actually DO anything..... Rolling Eyes

The Chromium Project is promoted as a separate entity from Google.....but everybody knows it's simply Google's browser R & D department.



We're kinda stuck with that one, I'm afraid.....


Mike. Wink

_________________
MY 'PUPPY' PACKAGES

Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3635
Location: wales ... by the sea

PostPosted: Sat 24 Aug 2019, 05:54    Post subject:  

all chrome based browser now seem broken in bionicpup64.
opera
chrome
chromium
vivaldi
all of them now have absolutely zero hardware acceleration., and suffer from really bad screen tearing, even on high end systems.

version 73 of chromium, chrome and all the others based on that version did have hardware acceleration to some degree, and could stream 4k youtube at 60fps smoothly. Now they can't even stream 480p without tearing, even with an nvidia 1050ti. it seems all processing is now done with the cpu Sad

if any of you have links for older versions of vivaldi, opera, chrome, (i have chromium) from about the time bionicpup was released. please post them here.

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3635
Location: wales ... by the sea

PostPosted: Sat 24 Aug 2019, 06:53    Post subject:  

ok i now have ...

chromium 73.0.3683.86
opera 58.0.3135.90
vivaldi 2.3.1440.60
chrome 70.0.3538.77

all stream youtube perfectly. i'll package them and upload to bionics repo.

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 2202
Location: London, England

PostPosted: Sat 24 Aug 2019, 07:06    Post subject:  

I have vivaldi-2.3.1440.61 which you can try.
Also the older vivaldi-1.9.818.50 which was tail end of GTK2 for older pups for anyone interested.
https://yadi.sk/d/euoIiDRDqcFnK?force_show=1

_________________
Oscar in England

Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3635
Location: wales ... by the sea

PostPosted: Sat 24 Aug 2019, 08:33    Post subject:  

thanks OscarTalks
_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
puppy_apprentice


Joined: 07 Feb 2012
Posts: 300

PostPosted: Sat 24 Aug 2019, 11:23    Post subject:  

Google turned off GPU acceleration in their browser due to bad linux GPU drivers (in their opinion). I've read somewhere that there are versions for Ubuntu compiled with GPU accelerations:

For Ubuntu based Puppies try this:
Code:
sudo add-apt-repository ppa:saiarcot895/chromium-beta
sudo apt-get update
sudo apt-get install chromium-browser
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3635
Location: wales ... by the sea

PostPosted: Sat 24 Aug 2019, 12:38    Post subject:  

puppy_apprentice wrote:
Google turned off GPU acceleration in their browser due to bad linux GPU drivers (in their opinion). I've read somewhere that there are versions for Ubuntu compiled with GPU accelerations:

For Ubuntu based Puppies try this:
Code:
sudo add-apt-repository ppa:saiarcot895/chromium-beta
sudo apt-get update
sudo apt-get install chromium-browser

hi puppy_apprentice,

that is already available in quickpet although it has the problem of not being able to sign into your google account properly.

but all chrome based browsers from the time of bionicpups release had hardware acceleration anyway, the above chromium just added extra stuff and took even more load off the cpu.

anyway i've now uploaded opera, chromium, google-chrome & vivaldi to bionicpups repo. once they've been mirrored on nluug i'll update quickpet to point to only those versions .... and also make a post in the browser section with links and instructions

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3635
Location: wales ... by the sea

PostPosted: Sat 24 Aug 2019, 12:41    Post subject:  

for anyone that wants to test .. try the latest google chrome, opera, vivaldi or chromium full screen streaming on youtube.

then try the versions here http://distro.ibiblio.org/puppylinux/pet_packages-bionic64/

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 6397
Location: King's Lynn, UK.

PostPosted: Sat 24 Aug 2019, 21:54    Post subject:  

Hiya, Phil.

Now I see what you want Chrome 73 for. So, here you go; Google-Chrome 73.0.3683.75 as an SFS:-

https://drive.google.com/file/d/1h6h3QIyKFv3MtSdbXX3swYEpT2_nuXS5/view?usp=sharing


Mike. Wink

_________________
MY 'PUPPY' PACKAGES

Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3635
Location: wales ... by the sea

PostPosted: Wed 28 Aug 2019, 12:56    Post subject:  

Mike Walsh wrote:
Hiya, Phil.

Now I see what you want Chrome 73 for. So, here you go; Google-Chrome 73.0.3683.75 as an SFS:-

https://drive.google.com/file/d/1h6h3QIyKFv3MtSdbXX3swYEpT2_nuXS5/view?usp=sharing


Mike. Wink


thanks mike

i'll upload it to bionicpup64s repo

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 6397
Location: King's Lynn, UK.

PostPosted: Wed 28 Aug 2019, 18:31    Post subject:  

@ Phil:-

I also have the Opera 63 release I've just packaged up. It's running fine in Xenialpup64, YouTube and all.

You might want to try it out on your own set-up first, though.....see if you think it's worth uploading to the Bionic64 repo.

https://drive.google.com/file/d/1R_f9dx_ulEbZZem54dEOka_SFCszw4Rg/view?usp=sharing


Mike. Wink

_________________
MY 'PUPPY' PACKAGES

Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3635
Location: wales ... by the sea

PostPosted: Wed 28 Aug 2019, 19:06    Post subject:  

hi mike

thanks but opera 63 has no acceleration for me Sad . i think opera uses different version numbers to chrome.

i've sent you a PM.

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3635
Location: wales ... by the sea

PostPosted: Thu 29 Aug 2019, 04:48    Post subject:  

here's a short video comparing chrome 73 & 76. this is the same for all browsers based on chrome
https://youtu.be/dT9MJZGAkRM

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [15 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0523s ][ Queries: 12 (0.0078s) ][ GZIP on ]