Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 20 Aug 2019, 12:20
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff)
Broken PPM on Bionicpup64
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [1 Post]  
Author Message
Shaolin12

Joined: 06 Jun 2019
Posts: 3

PostPosted: Thu 06 Jun 2019, 11:33    Post subject:  Broken PPM on Bionicpup64
Subject description: Puppy Package Manager only works in classic mode, plus additional weirdness.
 

Greatings! I am a new Puppy Linux user, but not new to Linux in general.

I am using Bionicpup64 on a 64GB memory stick, on a friend's Acer Aspire 5733Z laptop with 8GB's of ram & dual cores whilst on holiday in Austria.

The problem I'm having is that Puppy Package Manager is no longer functioning properly in that it will only work in classic mode (occasionally in the new mode), and when I uninstall programs, it still lists them as being installed.

The problems arose when first trying to follow advice to get Bluetooth sound working (failed), which required getting apulse1.6 from the xenial ubuntu repo, which led to me installing a whole bunch of other stuff (Pulseaudio components, dnscrypt-proxy, Peer Guardian Linux, and other dependencies), which led me to find out that various bits I'd installed were not required in the first place, and then something I did in removing those packages (sadly I don't remember which ones) led to the current situation.

Currently if I configure PPM to run in its new mode, it hangs at the splash screen. If I do it from the terminal I get a gtkdialog warning about PPM_GUI with an error code. If I go to /usr/local/petget and activate the configure script I can re-select use 'classic mode', and PPM then works.

I think that in my haste to get things done, I have uninstalled a gnome .desktop handler, but I think I accidentally installed some gnome components and am unsure whether those gnome desktop components should be in bionicpup64 in the first place, plus installing stuff from the ubuntu repos listed in PPM may well have caused the issue.

Is there a solid way other than doing a complete re-install to get PPM working as it should?

Last night I thought I had fixed it by removing PPM (I had previously downloaded quickpet64 to reinstall after a reboot), but on reboot, before I even got to try to reinstall it, PPM came up with the new interface and worked very well....until this morning when it defaulted back to not wanting to work in that mode again.

Anyone able/willing to help with this?
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [1 Post]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0420s ][ Queries: 11 (0.0220s) ][ GZIP on ]