Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 22 May 2019, 05:58
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
[vice-2.4] in ppm puppy-tahr-official
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
fabrice_035


Joined: 28 Apr 2014
Posts: 634
Location: Bretagne / France

PostPosted: Tue 09 Apr 2019, 12:45    Post subject:  [vice-2.4] in ppm puppy-tahr-official
Subject description: link libpango destroyed my puppy
 

Hi,

After installed vice-2.4, the .pet replace link from libpango-1.0.so.0 to libpango-1.0.so.3800.1 (working situation ok) by link to libpango-1.0.so.3600.1

No more windows open, impossible to use Puppy after. Reboot to fresh usb and corrected that. I was scared but everything went back to normal.

Can we confirm that too?

Regard

_________________
xenialpup 7.5 / Linux Kernel: 4.4.95 / Window Manager: JWM v2.3.7
Back to top
View user's profile Send private message 
mostly_lurking

Joined: 25 Jun 2014
Posts: 321

PostPosted: Tue 09 Apr 2019, 16:47    Post subject:  

You installed this program on Xenialpup? I just tried in with Xenialpup 7.5 in a virtual machine. Similar result - the vice 2.4 .pet for Tahrpup re-links libpango from a 3800 version to a 3600 one, and some - but not all - programs fail to create a window (urxvt terminal and ROX Filer are still working, for example). The question is why this library is even included in the package... Tahrpup has the exact same version already.

So while a package for an older Puppy will often be compatible with a newer one, it isn't in this case.
Back to top
View user's profile Send private message 
fabrice_035


Joined: 28 Apr 2014
Posts: 634
Location: Bretagne / France

PostPosted: Wed 10 Apr 2019, 01:28    Post subject:  

Yes on XenialPup. After install it is impossible to remove the package because ppm crash too.
Someone knows a command line to remove a packet from the ppm ?

_________________
xenialpup 7.5 / Linux Kernel: 4.4.95 / Window Manager: JWM v2.3.7
Back to top
View user's profile Send private message 
mostly_lurking

Joined: 25 Jun 2014
Posts: 321

PostPosted: Wed 10 Apr 2019, 10:02    Post subject:  

You could try fixing the symlink: delete the link to the 3600 version of libpango and re-link to the 3800 one. Either through ROX Filer, if it still works, or via the terminal (if your graphical terminal is broken, too, press Ctrl + Alt + Backspace to exit to the command prompt). Enter the following commands:
Code:
cd /usr/lib
rm ./libpango-1.0.so.0
ln -s ./libpango-1.0.so.0.3800.1 ./libpango-1.0.so.0
(This goes to /usr/lib, deletes the link, and creates a new one to the correct libpango version.)

After I did that, the applications that previously failed were working again. Vice seemed to be working, as well - at least it started up; I had no Commodore programs to test it. (It ended up in the "Utility" menu, btw.) I have no idea if you might find any other problems lurking somewhere that haven't become apparent yet; time will tell, I guess.

The solution I described in the following thread for uninstalling a problematic package from the command prompt worked, too, but I had to rename "vice-2.4.files" in /root/.packages to "vice-2.files" (command: mv /root/.packages/vice-2.4.files /root/.packages/vice-2.files) because petget didn't seem to process the name correctly for some reason:
How do I reverse fatal changes to my frugal pupsave [SOLVED]
Back to top
View user's profile Send private message 
fabrice_035


Joined: 28 Apr 2014
Posts: 634
Location: Bretagne / France

PostPosted: Wed 10 Apr 2019, 10:38    Post subject:  

Hello,

Ok, petget -package_name for remove, understand.

Vice work fine.

Regard.

_________________
xenialpup 7.5 / Linux Kernel: 4.4.95 / Window Manager: JWM v2.3.7
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0242s ][ Queries: 11 (0.0029s) ][ GZIP on ]