Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 10 Dec 2019, 18:58
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
[RESOLU] "No internet interface" avec une prise Ethernet
Moderators: Béèm, darkerror05, linuxcbon
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [18 Posts]   Goto page: 1, 2 Next
Author Message
Freco


Joined: 20 Feb 2011
Posts: 168

PostPosted: Thu 28 Mar 2019, 05:16    Post subject:  [RESOLU] "No internet interface" avec une prise Ethernet
Subject description: Problème rencontré sur pls PC et avec pls puplets
 

Bonjour,

Ca m'était arrivé déjà il y a quelques temps, alors que l'ordi fonctionne bien en Ethernet avec Slacko 632 par exemple, le fait de tester une autre version (XenialPup/ BionicPup/ Dpup Stretch/ Toopy...) impossible de me connecter au réseau via Ethernet.
Le message "no internet interface detected" indiqué en tête de chaque utilitaires proposant la connection... alors que c'est instantané avec Slacko par exemple...

Et là j'ai refait le test avec Dpup Stretch et Bionic Pup, sur deux PC différents un bon vieux Pentium 4 et un HP récent, et même topo...

Je suis sec, avez vous des idées là-dessus?

Merci.

Freco.

P.S: je viens de créer un post sur la section anglaise :
http://www.murga-linux.com/puppy/viewtopic.php?p=1023471#1023471

Last edited by Freco on Fri 05 Apr 2019, 13:11; edited 1 time in total
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3720
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Thu 28 Mar 2019, 13:00    Post subject:  

Arrow Bionic64 Pup Killed XP's Ethernet? Rolling Eyes
_________________

A second life for your PCs...
Back to top
View user's profile Send private message Visit poster's website 
don570


Joined: 10 Mar 2010
Posts: 5393
Location: Ontario

PostPosted: Thu 28 Mar 2019, 13:47    Post subject:  

Quote:
impossible de me connecter au réseau via Ethernet.

Avez-vous essayé le logiciel 'SNS' --> Simple Network Setup par Barry Kauler.

Il donne une liste des périphériques .
____________________________________________
Back to top
View user's profile Send private message 
Freco


Joined: 20 Feb 2011
Posts: 168

PostPosted: Thu 28 Mar 2019, 16:58    Post subject:  

don570 wrote:

Avez-vous essayé le logiciel 'SNS' --> Simple Network Setup par Barry Kauler.

Il donne une liste des périphériques .
____________________________________________


Oui, j'ai essayé chacun des utilitaires réseau, mais toujours rien.

La commande "ifconfig" ne renvoit que "lo".

J'ai essayé Bionic32 avec le noyau de Slacko632, pareil...
Back to top
View user's profile Send private message 
fabrice_035


Joined: 28 Apr 2014
Posts: 655
Location: Bretagne / France

PostPosted: Thu 28 Mar 2019, 17:14    Post subject:  

salut,

Dans l'ordre il faut commencer par un
Code:
lspci

Ce qui va lister les périphériques détectés.

Exemple chez moi
Code:
...
04:00.0 Network controller: Intel Corporation WiFi Link 5100
08:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5784M Gigabit Ethernet PCIe (rev 10)
...

Si il n'y a aucune carte Ethernet dans ta liste, ça devient très bizarre. La suite (i)logique voudrait que si ta réseau est devenu invisible quel que soit le système d'exploitation elle est hs. Je tenterai d'enlever la pile du bios et/ou de faire un clear cmos
https://www.google.com/search?client=firefox-b-d&q=effacer+bios+carte+mere ... sait-on jamais ...

_________________
xenialpup 7.5 / Linux Kernel: 4.4.95 / Window Manager: JWM v2.3.7
Back to top
View user's profile Send private message 
Freco


Joined: 20 Feb 2011
Posts: 168

PostPosted: Thu 28 Mar 2019, 17:25    Post subject:  

Voilà ce que me donne lspci depuis Bionic et Lubuntu

Code:
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller (rev 07)


Tout à l'air normal...
Back to top
View user's profile Send private message 
fabrice_035


Joined: 28 Apr 2014
Posts: 655
Location: Bretagne / France

PostPosted: Thu 28 Mar 2019, 17:39    Post subject:  

Freco wrote:
Voilà ce que me donne lspci depuis Bionic et Lubuntu

Code:
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller (rev 07)


Tout à l'air normal...


Ah c'est plutôt une bonne nouvelle.
Je ne connais pas bionic et lubuntu mais pas mal de pistes ici :

https://www.google.com/search?&q=linux+ifconfig+no+eth0+connection+up

Code:
ifconfig seul n'affiche que les interfaces activées, il faut exécuter ifconfig -a pour lister toutes les interfaces, même inactives. ifconfig eth0 up n'aura aucun effet si eth0 n'existe pas, il y a bien longtemps qu'on n'utilise plus ces saletés d'alias entre les noms d'interfaces et les noms des modules.
lspci -nnk devrait afficher le nom du module censé gérer cette carte, et s'il est chargé. S'il ne l'est pas, essayer de le charger à la main avec modprobe <nomdumodule>. S'il l'est, examiner les logs du noyau affichés par dmesg et rechercher ce qui ce rapporte à ce périphérique et ce module.

_________________
xenialpup 7.5 / Linux Kernel: 4.4.95 / Window Manager: JWM v2.3.7
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 14533
Location: Gatineau (Qc), Canada

PostPosted: Thu 28 Mar 2019, 17:56    Post subject:  

Salut Freco.

J'ai vécu ça il y a un mois environ sur le DPupBuster7.9.0.1 -- qui ne sera
jamais publié d'ailleurs.

DPB7901 a fini par trouver le module noyau pour l'ethernet, mais pas
celui pour le son, ce qui demeure un mystère des grands dieux... .

Pour revenir un peu en arrière --
ton slacko te fait des misères quand tu reviens dessus après avoir fait
des sessions avec xenial et ses cousins? (C'est ce que je comprends.)
Sur le même ordi. C'est bien ça ?

Il faudrait nous préciser exactement quel Toutou | Puppy te fait des
misères, s.v.p. Ça nous aiderait à t'aider.

À ma connaissance, il y a deux procédures pour réveiller un module
endormi, ethernet ou autre,

-- l'une, avec la commande < modprobe module > , (depuis la session)

-- l'autre en insérant le nom exact du module pour ta carte à la ligne 30
(ou par là) du fichier /etc/rc.d/MODULESCONFIG, la ligne qui commence
par < ADDLIST='' > (sans les chevrons). Cette dernière façon permet au
Puppy de réveiller le module endormi pendant le lancement (alias boot).

Voilà. C'est ce que je sais, et en ce domaine des modules du noyau je ne
suis pas trop fort, malheureusement.

J'espère quand même que ces quelques informations te mettront sur la
bonne piste.

À+

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
Mdor


Joined: 24 Jul 2010
Posts: 1809
Location: France

PostPosted: Thu 28 Mar 2019, 18:34    Post subject:  

Bonsoir,

La première chose à vérifier est la présence du module du noyau concernant la carte Ethernet :
Code:
lspci -nnk | grep -i net -A2

S'assurer de la présence du module "kernel driver module in use : xxxx"

Par exemple sur mon notebook actuel :
Code:
#lspci -nnk | grep -i net -A2
02:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
   Subsystem: Hewlett-Packard Company Device [103c:1508]
   Kernel driver in use: b43-pci-bridge
08:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)
   Subsystem: Hewlett-Packard Company Device [103c:3054]
   Kernel driver in use: r8169
#


Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
Freco


Joined: 20 Feb 2011
Posts: 168

PostPosted: Fri 29 Mar 2019, 04:03    Post subject:  

Merci pour vos réponses!

J'aurais de quoi tester à mon retour la semaine prochaine...
Wink

musher0 wrote:

Pour revenir un peu en arrière --
ton slacko te fait des misères quand tu reviens dessus après avoir fait
des sessions avec xenial et ses cousins? (C'est ce que je comprends.)
Sur le même ordi. C'est bien ça ?

Il faudrait nous préciser exactement quel Toutou | Puppy te fait des
misères, s.v.p. Ça nous aiderait à t'aider.


Salut musher0,

Alors pour refaire l'historique :
_PC 1 : Pentium 4 fixe
.distro habituelle : Slacko 6.3.2
.test Ethernet non reconnu : XenialPup32 + d'autres puplets (de souvenir Pipoca marchait mais pas Tooppy).
Testé aussi en bootant sur clé USB. Testé aussi sur d'autres PCs voisins, toujours pas d'Ethernet.

_PC 2 : Pentium 4 fixe
.distro habituelle : Slacko 6.3.2
.test Ethernet non reconnu : Bionic32, DpupStretch

_PC 3 : i3 laptop récent
.distro habituelle : Lubuntu
.test Ethernet non reconnu : Bionic32, Bionic64

A chaque fois, j'installe Puppy directement en copiant à la mano les vmlinux/initr/puppy.sfs dans un dossier en mettant à jour le Grub2 via le 40_custom.

Merci et a+
Back to top
View user's profile Send private message 
Mdor


Joined: 24 Jul 2010
Posts: 1809
Location: France

PostPosted: Fri 29 Mar 2019, 04:14    Post subject:  

Bonjour Freco,

Que la donne la commande : lspci -nnk | grep -i net -A2

Tu devrais au moins avoir le nom du module de la carte Ethernet sur la Slacko qui fonctionne, puis de vérifier sur les autres puplettes....


Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
Freco


Joined: 20 Feb 2011
Posts: 168

PostPosted: Wed 03 Apr 2019, 17:17    Post subject:  

Désolé de répondre que maintenant.

Je viens de retester sur un 4ème PC et j'ai le même problème...
et ce avec Bionic 32 et 64 et Dpup Stretch.

M�dor wrote:

Que la donne la commande : lspci -nnk | grep -i net -A2


sur Ubuntu:
Code:

ubuntu@OptiPlex:~$ lspci -nnk | grep -i net -A2
00:19.0 Ethernet controller [0200]: Intel Corporation 82567LM-3 Gigabit Network Connection [8086:10de] (rev 02)
   Subsystem: Dell 82567LM-3 Gigabit Network Connection [1028:027f]
   Kernel driver in use: e1000e
   Kernel modules: e1000e


sur puppy:
Code:

# lspci -nnk | grep -i net -A2
lspci: Unable to load libkmod resources: error -12
00:19.0 Ethernet controller [0200]: Intel Corporation 82567LM-3 Gigabit Network Connection [8086:10de] (rev 02)
   Subsystem: Dell Device [1028:027f]
00:1a.0 USB controller [0c03]: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #4 [8086:3a67] (rev 02)


M�dor wrote:

Tu devrais au moins avoir le nom du module de la carte Ethernet sur la Slacko qui fonctionne, puis de vérifier sur les autres puplettes....


tentative de réveil du module:
Code:
 # modprobe e1000e
modprobe: ERROR: ../libkmod/libkmod.c:586 kmod_search_moddep() could not open moddep file '/lib/modules/4.9.163-lxpup-32-pae/modules.dep.bin'
modprobe: FATAL: Module e1000e not found in directory /lib/modules/4.9.163-lxpup-32-pae


Ai-je loupé une manip?

musher0 wrote:

-- l'autre en insérant le nom exact du module pour ta carte à la ligne 30
(ou par là) du fichier /etc/rc.d/MODULESCONFIG, la ligne qui commence
par < ADDLIST='' > (sans les chevrons). Cette dernière façon permet au
Puppy de réveiller le module endormi pendant le lancement (alias boot).


J'ai bien rajouté au fichier /etc/rc.d/MODULESCONFIG
Code:
ADDLIST=e1000e

qui s'est bien chargé au redémarrage (apparaît bien log durant le démarrage), mais rien de nouveau...

fabrice_035 wrote:

https://www.google.com/search?&q=linux+ifconfig+no+eth0+connection+up


Il y a t'il un équivalent de /etc/network/interfaces sur puppy?

Sinon j'ai essayé lundi plusieurs liens, mais sans trouver qq chose qui veuille bien marcher...

J'ai du mal à comprendre pourquoi j'ai un tel problème, sur toutes les nouvelles versions et tous les PC que j'ai sous la main...
Il doit bien y avoir un truc! J'ai jamais connu rien de tel depuis 2011 que j'utilise Puppy...
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3720
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Thu 04 Apr 2019, 04:42    Post subject:  

Bonjour,
Une piste: Arrow unable to load libkmod resources?

Cordialement.

_________________

A second life for your PCs...
Back to top
View user's profile Send private message Visit poster's website 
Mdor


Joined: 24 Jul 2010
Posts: 1809
Location: France

PostPosted: Fri 05 Apr 2019, 03:45    Post subject:  

Bonjour Freco,

Quote:
modprobe: FATAL: Module e1000e not found in directory /lib/modules/4.9.163-lxpup-32-pae

Donc le module n'est pas présent ce qui est assez curieux !

Là je suis passé sous LxUpupbb-18.5 / k4.9.96 et le module e1000e est bien présent !

Code:
# uname -a
Linux puppypc8170 4.9.96-lxpup-32-pae #1 SMP Thu Apr 26 11:45:00 +08 2018 i686 i686 i686 GNU/Linux

# modinfo e1000e
filename:       /lib/modules/4.9.96-lxpup-32-pae/kernel/drivers/net/ethernet/intel/e1000e/e1000e.ko
version:        3.2.6-k
license:        GPL
description:    Intel(R) PRO/1000 Network Driver
author:         Intel Corporation, <linux.nics@intel.com>
srcversion:     17F7A315AD56539B514FD71
alias:          pci:v00008086d000015D6sv*sd*bc*sc*i*
alias:          pci:v00008086d000015E3sv*sd*bc*sc*i*
alias:          pci:v00008086d000015D8sv*sd*bc*sc*i*
alias:          pci:v00008086d000015D7sv*sd*bc*sc*i*
alias:          pci:v00008086d000015B9sv*sd*bc*sc*i*
alias:          pci:v00008086d000015B8sv*sd*bc*sc*i*
alias:          pci:v00008086d000015B7sv*sd*bc*sc*i*
alias:          pci:v00008086d00001570sv*sd*bc*sc*i*
alias:          pci:v00008086d0000156Fsv*sd*bc*sc*i*
alias:          pci:v00008086d000015A3sv*sd*bc*sc*i*
alias:          pci:v00008086d000015A2sv*sd*bc*sc*i*
alias:          pci:v00008086d000015A1sv*sd*bc*sc*i*
alias:          pci:v00008086d000015A0sv*sd*bc*sc*i*
alias:          pci:v00008086d00001559sv*sd*bc*sc*i*
alias:          pci:v00008086d0000155Asv*sd*bc*sc*i*
alias:          pci:v00008086d0000153Bsv*sd*bc*sc*i*
alias:          pci:v00008086d0000153Asv*sd*bc*sc*i*
alias:          pci:v00008086d00001503sv*sd*bc*sc*i*
alias:          pci:v00008086d00001502sv*sd*bc*sc*i*
alias:          pci:v00008086d000010F0sv*sd*bc*sc*i*
alias:          pci:v00008086d000010EFsv*sd*bc*sc*i*
alias:          pci:v00008086d000010EBsv*sd*bc*sc*i*
alias:          pci:v00008086d000010EAsv*sd*bc*sc*i*
alias:          pci:v00008086d00001525sv*sd*bc*sc*i*
alias:          pci:v00008086d000010DFsv*sd*bc*sc*i*
alias:          pci:v00008086d000010DEsv*sd*bc*sc*i*
alias:          pci:v00008086d000010CEsv*sd*bc*sc*i*
alias:          pci:v00008086d000010CDsv*sd*bc*sc*i*
alias:          pci:v00008086d000010CCsv*sd*bc*sc*i*
alias:          pci:v00008086d000010CBsv*sd*bc*sc*i*
alias:          pci:v00008086d000010F5sv*sd*bc*sc*i*
alias:          pci:v00008086d000010BFsv*sd*bc*sc*i*
alias:          pci:v00008086d000010E5sv*sd*bc*sc*i*
alias:          pci:v00008086d0000294Csv*sd*bc*sc*i*
alias:          pci:v00008086d000010BDsv*sd*bc*sc*i*
alias:          pci:v00008086d000010C3sv*sd*bc*sc*i*
alias:          pci:v00008086d000010C2sv*sd*bc*sc*i*
alias:          pci:v00008086d000010C0sv*sd*bc*sc*i*
alias:          pci:v00008086d00001501sv*sd*bc*sc*i*
alias:          pci:v00008086d00001049sv*sd*bc*sc*i*
alias:          pci:v00008086d0000104Dsv*sd*bc*sc*i*
alias:          pci:v00008086d0000104Bsv*sd*bc*sc*i*
alias:          pci:v00008086d0000104Asv*sd*bc*sc*i*
alias:          pci:v00008086d000010C4sv*sd*bc*sc*i*
alias:          pci:v00008086d000010C5sv*sd*bc*sc*i*
alias:          pci:v00008086d0000104Csv*sd*bc*sc*i*
alias:          pci:v00008086d000010BBsv*sd*bc*sc*i*
alias:          pci:v00008086d00001098sv*sd*bc*sc*i*
alias:          pci:v00008086d000010BAsv*sd*bc*sc*i*
alias:          pci:v00008086d00001096sv*sd*bc*sc*i*
alias:          pci:v00008086d0000150Csv*sd*bc*sc*i*
alias:          pci:v00008086d000010F6sv*sd*bc*sc*i*
alias:          pci:v00008086d000010D3sv*sd*bc*sc*i*
alias:          pci:v00008086d0000109Asv*sd*bc*sc*i*
alias:          pci:v00008086d0000108Csv*sd*bc*sc*i*
alias:          pci:v00008086d0000108Bsv*sd*bc*sc*i*
alias:          pci:v00008086d0000107Fsv*sd*bc*sc*i*
alias:          pci:v00008086d0000107Esv*sd*bc*sc*i*
alias:          pci:v00008086d0000107Dsv*sd*bc*sc*i*
alias:          pci:v00008086d000010B9sv*sd*bc*sc*i*
alias:          pci:v00008086d000010D5sv*sd*bc*sc*i*
alias:          pci:v00008086d000010DAsv*sd*bc*sc*i*
alias:          pci:v00008086d000010D9sv*sd*bc*sc*i*
alias:          pci:v00008086d00001060sv*sd*bc*sc*i*
alias:          pci:v00008086d000010A5sv*sd*bc*sc*i*
alias:          pci:v00008086d000010BCsv*sd*bc*sc*i*
alias:          pci:v00008086d000010A4sv*sd*bc*sc*i*
alias:          pci:v00008086d0000105Fsv*sd*bc*sc*i*
alias:          pci:v00008086d0000105Esv*sd*bc*sc*i*
depends:        ptp
retpoline:      Y
intree:         Y
vermagic:       4.9.96-lxpup-32-pae SMP mod_unload modversions 686
signat:         PKCS#7
signer:         
sig_key:       
sig_hashalgo:   md4
parm:           debug:Debug level (0=none,...,16=all) (int)
parm:           copybreak:Maximum size of packet that is copied to a new buffer on receive (uint)
parm:           TxIntDelay:Transmit Interrupt Delay (array of int)
parm:           TxAbsIntDelay:Transmit Absolute Interrupt Delay (array of int)
parm:           RxIntDelay:Receive Interrupt Delay (array of int)
parm:           RxAbsIntDelay:Receive Absolute Interrupt Delay (array of int)
parm:           InterruptThrottleRate:Interrupt Throttling Rate (array of int)
parm:           IntMode:Interrupt Mode (array of int)
parm:           SmartPowerDownEnable:Enable PHY smart power down (array of int)
parm:           KumeranLockLoss:Enable Kumeran lock loss workaround (array of int)
parm:           WriteProtectNVM:Write-protect NVM [WARNING: disabling this can lead to corrupted NVM] (array of int)
parm:           CrcStripping:Enable CRC Stripping, disable if your BMC needs the CRC (array of int)
#


Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
Freco


Joined: 20 Feb 2011
Posts: 168

PostPosted: Fri 05 Apr 2019, 05:34    Post subject:  

M�dor wrote:

Quote:
modprobe: FATAL: Module e1000e not found in directory /lib/modules/4.9.163-lxpup-32-pae

Donc le module n'est pas présent ce qui est assez curieux !

Là je suis passé sous LxUpupbb-18.5 / k4.9.96 et le module e1000e est bien présent !


Merci.
Je vais faire la même vérification chez moi et je réessayerais ça.
Oui, je confirme que c'est bizarre, surtout que ça arrive sur 4 PCs différents, 3 box différentes, et sur plusieurs versions de puppy
a+
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [18 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0916s ][ Queries: 11 (0.0055s) ][ GZIP on ]