Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 09 Dec 2019, 00:04
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
Epson WF 3720 prints blank pages from Precise 571
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [17 Posts]   Goto page: 1, 2 Next
Author Message
Walt52

Joined: 03 Apr 2014
Posts: 122

PostPosted: Thu 03 Jan 2019, 00:05    Post subject:  Epson WF 3720 prints blank pages from Precise 571  

I just got an Epson WF 3720 for my desktop running precise 5.7.1. Precise recognized the printer right away, and knows it should print when I tell it to, but just cranks out blank pages and won;t stop. It does fine printing tests of itself, so it's not the ink or printhead. I tried to use CUPS to configure it. . .could that be the problem?
When it asks for the driver, the only options are other Epson model numbers, and none seems to work.
Then, to top it off, my iPad can get it to print correctly!
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 12974
Location: S.C. USA

PostPosted: Thu 03 Jan 2019, 00:41    Post subject:  

This should help you.
Read carefully the info about Epson printers.

How to Install Your Printer/Scanner in Puppy
http://www.murga-linux.com/puppy/viewtopic.php?t=59015

_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer)
Back to top
View user's profile Send private message 
FeodorF


Joined: 07 Jul 2010
Posts: 258
Location: Heidelberg, Germany

PostPosted: Thu 03 Jan 2019, 06:34    Post subject: Epson WF 3720
Subject description: .ppd file
 

You'll need the:

Epson-WF-3720_Series-epson-escpr2-en.ppd

You can read right there:

https://www.linuxquestions.org/questions/slackware-14/cups-prints-nothing-4175641094/
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12801
Location: Stratford, Ontario

PostPosted: Thu 03 Jan 2019, 07:52    Post subject: Re: Epson WF 3720
Subject description: .ppd file
 

FeodorF wrote:
You'll need the:Epson-WF-3720_Series-epson-escpr2-en.ppd

Quote:
3. Despite what you may have read, a PPD file by itself is rarely sufficient to install a printer in Puppy. In most cases, you need an additional driver package.

For the umpteenth time, a PPD file is just a text configuration file.

---------------------
Back to top
View user's profile Send private message 
Walt52

Joined: 03 Apr 2014
Posts: 122

PostPosted: Thu 03 Jan 2019, 19:37    Post subject:  

OK, I get the difference between a PPD and Drivers, and clearly I need the driver. They list four at the Epson site, and three seem to be for scanners. The fourth is "not available." I gather I need eppi, too, and I've inferred that eppi is the epson version of candi, and that somehow they are like each other. I can't find eppi to download anywhere, and while I see Peasy lots of other things, I can't find PeasyPort. I don't suppose updating CUPS would cover this? Also, the description of how to install the elusive driver from the command line has left me in the dust.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12801
Location: Stratford, Ontario

PostPosted: Thu 03 Jan 2019, 20:25    Post subject:  

Walt52 wrote:
They list four at the Epson site, and three seem to be for scanners. The fourth is "not available."

I don't know what Epson is doing with their drivers. You need the "not available" one - ESC/P-R Driver 2 (generic driver). It looks like they have withdrawn this driver for a number of models that it is supposed to support.

Instead, try the driver for the WF-3620. It may be compatible.

Quote:
I gather I need eppi, too, and I've inferred that eppi is the epson version of candi, and that somehow they are like each other. I can't find eppi to download anywhere.

It's a PET package attached to the post where you read that. Download and click-install it.
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1931
Location: Italy

PostPosted: Thu 03 Jan 2019, 20:59    Post subject:  

Eppi is attached to the following post:

http://www.murga-linux.com/puppy/viewtopic.php?p=466449#466449
Back to top
View user's profile Send private message 
Walt52

Joined: 03 Apr 2014
Posts: 122

PostPosted: Sun 06 Jan 2019, 01:48    Post subject:  

I came up with a solution for the Epson. . .I returned it. Now I have an HP Officejet pro 6878, which was supposed to be able to work with a linux machine. . .and it DOES print all the information. . . on the left half of the page. So far I've tried using the wife's iPad, and that works fine. Tried downloading a new hplip. . .it started to transfer, then aborted. Tried to download a driver (they didn't have any for linux that I could make work, and none cover the Windows XP versions I have on my dell 1501. I've tried resetting the parameters on the early CUPS version I have (would a later one be more likely to have a 6978?), but it still crams everything on the left side of the page. Suggestions?
Back to top
View user's profile Send private message 
Walt52

Joined: 03 Apr 2014
Posts: 122

PostPosted: Mon 07 Jan 2019, 00:43    Post subject: Epson WF 3720 prints blank pages from Precise 571 (Solved)
Subject description: Took it back!
 

Took it back!
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 12974
Location: S.C. USA

PostPosted: Mon 07 Jan 2019, 01:00    Post subject:  

Can you use a newer version of Puppy?
A lot has changed in Puppy since Precise 5.7.1.

_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer)
Back to top
View user's profile Send private message 
Walt52

Joined: 03 Apr 2014
Posts: 122

PostPosted: Mon 07 Jan 2019, 21:26    Post subject:  

Tried Tahr 64 6.0.3 and it "saw" the printer, but didn't have the right driver, so it also printed a half page. Tried Slacko and it couldn't detect the printer at all.
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1931
Location: Italy

PostPosted: Tue 08 Jan 2019, 01:46    Post subject:  

I think you need hplip installed for the right driver of your hp printer. Hplip support has been discontinued in puppy. I have hplip-3.16.11 but it's not updated. You can try to install hplip from hp support in a live puppy to try if it works:

https://developers.hp.com/hp-linux-imaging-and-printing
Back to top
View user's profile Send private message 
Walt52

Joined: 03 Apr 2014
Posts: 122

PostPosted: Tue 08 Jan 2019, 10:49    Post subject:  

After opening Spot and running sh, it starts loading then says "extraction failed. Terminated." It's done this several times, so I can't install hplip 3.18.12.
Back to top
View user's profile Send private message 
Walt52

Joined: 03 Apr 2014
Posts: 122

PostPosted: Tue 08 Jan 2019, 11:17    Post subject:  

More explanation about not installing hplip:

tried to run sh in root, started to run, then said I shouldn't run extract in root, so I ran it in spot, got "creating diectory hplip-3.18.12 verifying archive integrity-All good. Uncompressing hplip3.18.12 self extracting archive hplip3.18.12.run Line 369 cd:hplip3.18.12 permission denied. . .but then it started to run,. .then said "extraction failed. terminated."
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1931
Location: Italy

PostPosted: Tue 08 Jan 2019, 12:01    Post subject:  

Check Private Message.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [17 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0479s ][ Queries: 11 (0.0046s) ][ GZIP on ]