Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 18 Jun 2019, 23:03
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
ScPup & ScPup64 - Slackware Current based Woof-CE pups
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 7 of 10 [140 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9, 10 Next
Author Message
Wiz57


Joined: 03 Feb 2019
Posts: 39
Location: Chickasha, OK

PostPosted: Tue 02 Apr 2019, 18:49    Post subject:  

I downloaded Palemoon.sfs from the "Internet>Get Web Browser" menu.
Will try the patches for gpicview later.
Thanks!
Wiz Wink
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1984
Location: London, England

PostPosted: Tue 02 Apr 2019, 21:30    Post subject:  

ScPup 32bit 19.01+6
The gpicview image viewer doesn't display .gifs for me either.
The Debian one was the same and the Arch one didn't run, missing libjpeg.so.8

I tried compiling gpicview from source but again it was the same.

I compiled Viewnior 1.6 in ScPup32
That displays the test .gifs I tried here and the animation looks OK
After installation you can change the default image viewer in the Default Applications Chooser or Right Click > Open With > viewnior

EDIT:- see below for Viewnior 1.7 which is better than 1.6 in ScPup

_________________
Oscar in England


Last edited by OscarTalks on Fri 05 Apr 2019, 08:07; edited 1 time in total
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3887
Location: Worcestershire, UK

PostPosted: Wed 03 Apr 2019, 02:13    Post subject:  

6502coder wrote:
(DPupStretch 7.5 CE has the same version of GPicView but patched to render AnimGIFs.)

Where did Radky get this patched version????

Perhaps it isn't gpicview but libgif???? But if viewnior works then ???

http://ftp.br.debian.org/debian/pool/main/g/giflib/libgif7_5.1.4-0.4_i386.deb

Palemoon sfs is rebuilt without the old updater that is now obsolete and re-uploaded.

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPup, ScPup & ScPup64, LxPup, LxPupSc and LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
OscarTalks


Joined: 05 Feb 2012
Posts: 1984
Location: London, England

PostPosted: Wed 03 Apr 2019, 09:05    Post subject:  

ScPup32 19.01+6
Slight devx mismatch.
Symlink libfreetype.so in devx should be a link to libfreetype.so.6.17.0
NOT 6.16.1 which does not exist in the .iso
This issue causes error out when compiling anything which requires libfreetype (because it is not found).

_________________
Oscar in England

Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1984
Location: London, England

PostPosted: Wed 03 Apr 2019, 09:31    Post subject:  

Searching around a bit for information about gpicview and .gif image files I found one suggestion that "gdk-pixbuf2 update (2.31.1-1 -> 2.31.2-1) breaks gpicview due to reusing buffers"

Suggested quick fix is to remove "if( pixbuf != iv->pix )" from image_view_set_pixbuf in the source file image-view.c:346 and recompile gpicview.

So I did that and the result was that the couple of animated .gif files I tested did "play" normally. Folks may wish to test if all the other needed functions still work.
gpicview-0.2.5-i686-scpup-gif-fix.pet
Description  The .gif issue appears to be fixed but is everything else still OK with it?
pet

 Download 
Filename  gpicview-0.2.5-i686-scpup-gif-fix.pet 
Filesize  53.85 KB 
Downloaded  47 Time(s) 

_________________
Oscar in England

Back to top
View user's profile Send private message 
corvus


Joined: 12 Jun 2015
Posts: 138
Location: In the peninsula shaped like a boot.

PostPosted: Wed 03 Apr 2019, 15:37    Post subject: Printer no longer working  

Hi peebee,
since I upgraded to the +6 64bit version my printer no longer works.
Have you modified cups or some other package referred to the printer?

To be sure I went back to the +5 version and my printer works perfectly.
With the +6 version it prints only the following error message:

INTERNAL ERROR - uw_color == 4
POSITION : 0X0 (0)
SYSTEM : h6fw_5.49/xl_image
LINE : 341
VERSION : SPL 5.49 10-20-2010

Nothing relevant in CUPS error_log, anyway attached.

The only error/warning in dmesg is not printer related:
Code:
Warning! fotg210_hcd should always be loaded before uhci_hcd and ohci_hcd, not after


Printer model: Samsung ML-1675 Laser printer.

Regards
error_log.gz
Description  CUPS error log, fake gz.
gz

 Download 
Filename  error_log.gz 
Filesize  5.46 KB 
Downloaded  50 Time(s) 

_________________
Hoc unum scio, me nihil scire. Socrate
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1824
Location: Italy

PostPosted: Thu 04 Apr 2019, 13:34    Post subject: Audacity-2.3.1  

I have experimental SFSs of ponce audacity 2.3.1.
Audacity-2.3.1-i586-s_19.01.sfs:

https://drive.google.com/file/d/1dFaF8zL_AKhM72O175oHRLu_DK-pn6hh/view?usp=sharing

Audacity-2.3.1-x86_64-s_19.01.sfs:

https://drive.google.com/file/d/1wCPHhwuJvBfW1Su0kHwFak_vo50aGPtz/view?usp=sharing

But they require wxGTK3-3.0.4-i586-2ponce.txz and wxGTK3-3.0.4-x86_64-2ponce.txz respectively. This is experimental. Caution!
Back to top
View user's profile Send private message 
6502coder


Joined: 23 Mar 2009
Posts: 623
Location: Western United States

PostPosted: Thu 04 Apr 2019, 16:50    Post subject:  

peebee wrote:
6502coder wrote:
(DPupStretch 7.5 CE has the same version of GPicView but patched to render AnimGIFs.)

Where did Radky get this patched version????

I don't know. I'm relying on what radky said in his notes for the "Alpha-2 changelog: 4/Nov/2017" in the second post of the DPupStretch 7.5 thread:

Quote:
Update gpicview 0.2.5, patched to support animated GIFs
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1984
Location: London, England

PostPosted: Thu 04 Apr 2019, 17:40    Post subject:  

I probably shouldn't presume to guess what Radky did with gpicview in his DpupStretch, but I find it interesting that his gpicview and the Arch gpicview both require libjpeg.so.8

Radky appears to have also added this library from somewhere, even though it is not listed as a Debian Stretch library at all, so one theory is that he has used the Arch gpicview which their developers have patched.

Standard build of the libjpeg-turbo package produces libjpeg.so.62 BUT you can compile with the configure option --with-jpeg8 in which case it produces libjpeg.so.8 instead, but this is non-standard in some distros it seems (?).

Anyway, the gpicview I compiled above in ScPup32 does not depend on libjpeg.so.8 so there is no need to add the extra runtime library. I was hoping a few more people might test and report though.

I also recompiled with that patch in my own personal DpupStretch, because the official Debian version of gpicview still has this bug (and I don't need to add libjpeg.so.8 as it depends on the native libjpeg.so.62 instead)

_________________
Oscar in England

Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1984
Location: London, England

PostPosted: Thu 04 Apr 2019, 18:32    Post subject:  

Here is the 64bit version of patched gpicview compiled from source in ScPup64
These packages only overwrite the executable binary plus /usr/share/gpicview
gpicview-0.2.5-x86_64-scpup-gif-fix.pet
Description  Please test animated .gif files plus other functions
pet

 Download 
Filename  gpicview-0.2.5-x86_64-scpup-gif-fix.pet 
Filesize  51.16 KB 
Downloaded  50 Time(s) 

_________________
Oscar in England

Back to top
View user's profile Send private message 
6502coder


Joined: 23 Mar 2009
Posts: 623
Location: Western United States

PostPosted: Fri 05 Apr 2019, 01:27    Post subject:  

I tested Oscar's gpicview-0.2.5-i686-scpup-gif-fix.pet in a second LiveCD test of the 32-bit "+6". I just unpacked the PET and grabbed the executable, then tried it on the same suite of pix I used on my previous LiveCD test. Looks OK to me. I tried all the buttons: rotating images, different zooms, save as, etc. No problems to report.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3887
Location: Worcestershire, UK

PostPosted: Fri 05 Apr 2019, 04:45    Post subject:  

This is a long standing bug from 2016 that hasn't been fixed:
https://sourceforge.net/p/lxde/bugs/814/

@Radky in a pm says:
Quote:
Early in the development of Dpup Stretch, to support viewing of animated GIFs, I compiled gpicview from source using the following patch:

https://bbs.archlinux.org/viewtopic.php?pid=1520553#p1520553


and has sent a pet but it does indeed need libjpeg.so.8 ....

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPup, ScPup & ScPup64, LxPup, LxPupSc and LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 3887
Location: Worcestershire, UK

PostPosted: Fri 05 Apr 2019, 06:56    Post subject:  

OscarTalks wrote:
I compiled Viewnior 1.6 in ScPup32

Viewnior 1.7 is available and works from ArchLinux and ArchLinux32:

https://mirror.archlinux32.org/i686/community/viewnior-1.7-1.0-i686.pkg.tar.xz

The gif I'm using to test:
giphy.gif
 Description   
 Filesize   127.16 KB
 Viewed   287 Time(s)

giphy.gif


_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPup, ScPup & ScPup64, LxPup, LxPupSc and LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
OscarTalks


Joined: 05 Feb 2012
Posts: 1984
Location: London, England

PostPosted: Fri 05 Apr 2019, 08:03    Post subject:  

Yes, Viewnior 1.7 is better than 1.6 but you can't build it with autotools.

Building requires the meson build system:-
Install python 3 (3.5 or later, I used 3.7.3)
Install ninja
Install meson
Compile Viewnior 1.7

I have done this in ScPup32 and it works. Those build dependencies are not required to run it once built.
viewnior-1.7-i686-scpup.pet
Description  Compiled from source in ScPup32
pet

 Download 
Filename  viewnior-1.7-i686-scpup.pet 
Filesize  74.97 KB 
Downloaded  55 Time(s) 

_________________
Oscar in England

Back to top
View user's profile Send private message 
Wiz57


Joined: 03 Feb 2019
Posts: 39
Location: Chickasha, OK

PostPosted: Fri 05 Apr 2019, 19:15    Post subject:  

OscarTalks--I grabbed the 32 bit gpicview pet you uploaded, will test later tonight. Also may grab peebee's updated palemoon sfs, just to have on hand. Been busy this week manufacturing parts for oilfield, and some little tiny sleeves for an audio company. I'm running a couple of Brown and Sharpe screw machines at a local machine shop, been cutting steel quite a bit of late, both 303 stainless and "tool steel". That's been keeping me a tad busy, which is good! I kind of like paychecks! Laughing

ps...bandied about with OscarTalks gpicview 32bit, no issues, and animations working as expected on the few ani-GIFs I have. Looks good to go!


pps...peebee, I tried to download the updated palemoon sfs, and wget quit with error the checksums did not match! This was using the "Internet/Get web browser" button in the menu!

Wiz
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 7 of 10 [140 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9, 10 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0737s ][ Queries: 12 (0.0327s) ][ GZIP on ]