Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 18 Nov 2018, 08:24
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
comment ouvrir une application
Moderators: Béèm, darkerror05, linuxcbon
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [16 Posts]   Goto page: 1, 2 Next
Author Message
7x7albert

Joined: 16 Dec 2009
Posts: 34

PostPosted: Tue 06 Nov 2018, 07:12    Post subject:  comment ouvrir une application  

Bonjour à vous toutoulinuxiens j'ai besoin de vos lumières en effet j'ai téléchargé deux applications vlc et anki ils sont visibles dans le menu mais lorsque je clique sur l'icone rien ne se passe, auriez vous la gentillesse de me guider pour rendre celles ci opérationnelles. En vous remerciant par avance. Very Happy
Back to top
View user's profile Send private message 
oui

Joined: 20 May 2005
Posts: 3127
Location: near Woof (Germany) :-) Acer Laptop emachines 2 GB RAM AMD64. franco-/germanophone, +/- anglophone

PostPosted: Tue 06 Nov 2018, 07:24    Post subject:  

alors ouvre le "monitor" / "terminal" (est parmis les icônes offertes sur le bureau) et tape par ex. vlc dedans et confirme

dans le monitor, tu liras probablement après un message d'erreur.

il est possible par ex. qu'il te manque des "dépendances" (la peste sous linux!!!)
Back to top
View user's profile Send private message 
Dorothée


Joined: 27 Nov 2012
Posts: 240

PostPosted: Tue 06 Nov 2018, 22:25    Post subject:  

Bonjour,

il se peut que tu aies téléchargé des applications qui ne conviennent pas à ta puplette (Tahr pour Precise, Precise pour Slacko etc.).

Le mieux serait que tu sois sûr que ces applications sont bien destinées à ta distribution. Si elles ne le sont pas, désinstalle-les et installe les bonnes.

Si elles sont correctes pour ta puplette, alors effectivement, peut-être manque-t-il des dépendances ou librairies, comme l'écrit Oui, et cela peut être un peu galère pour les rajouter.

C'est la raison pour laquelle il est toujours mieux de tester des applications en montant un sfs (que l'on peut démonter après si ça ne marche pas) plutôt qu'en installant directement un pet.

Bon courage,

PS: pour trouver les librairies qui manquent, il faut taper dans la console:

Code:
ldd le chemin du binaire


par exemple:

Code:
ldd /usr/bin/vlc
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3457
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Wed 07 Nov 2018, 13:35    Post subject:  

Bonsoir,
Dorothée wrote:
PS: pour trouver les librairies qui manquent, il faut taper dans la console:

Il peut être aussi intéressant d'ouvrir une console et de taper:
Code:
# vlc

et voir ce qui s'affiche...
Exemple, chez moi:
Code:
# vlc
VLC media player 2.1.6 Rincewind (revision 2.1.6-0-gea01d28)
[0x8c4b150] main libvlc: Lancement de vlc avec l'interface par défaut. Utilisez « cvlc » pour démarrer VLC sans interface.

Mais on aimerait savoir quelle version de vlc tu as installée, et sur quel Puppy! Rolling Eyes

Cordialement.

_________________

Back to top
View user's profile Send private message Visit poster's website 
7x7albert

Joined: 16 Dec 2009
Posts: 34

PostPosted: Fri 09 Nov 2018, 09:19    Post subject:  

mon systéme Linux 3.4.94 (i686)
distribution Toutou Slaxen -6.0
la version de VLC 2.1.2
Back to top
View user's profile Send private message 
7x7albert

Joined: 16 Dec 2009
Posts: 34

PostPosted: Fri 09 Nov 2018, 09:23    Post subject:  

voici le message écrit en console suite à la commande vlc

VLC is not supposed to be run as root. Sorry.
Il you need to use real-time priorities and/or privileged TCP ports
you can use vlc-wrapper (make sure it is Set-UID root and cannot be run by non-trusted users first).
Back to top
View user's profile Send private message 
7x7albert

Joined: 16 Dec 2009
Posts: 34

PostPosted: Fri 09 Nov 2018, 09:28    Post subject:  

voici la traduction google

VLC n'est pas censé être exécuté en tant que root. Pardon.
Si vous devez utiliser des priorités en temps réel et / ou des ports TCP privilégiés
vous pouvez utiliser vlc-wrapper (assurez-vous qu'il s'agit de la racine Set-UID et qu'il ne peut pas être exécuté par des utilisateurs non approuvés au préalable).

J'essaie de comprendre !!!!!!
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 12980
Location: Gatineau (Qc), Canada

PostPosted: Fri 09 Nov 2018, 10:31    Post subject:  

Salut 7x7Albert.

Pour ma part, j'ai la version
Quote:
VLC media player 2.2.2 Weatherwax (revision 2.2.2-0-g6259d80)
de vlc, et elle ne se fait pas prier pour s'ouvrir sur mon xenialPup-706.

Où es-tu allé pêcher ta version de vlc ? C'est celle livrée « sortie usine »
par la Slaxen ?

~~~~~~~~~

Un « wrapper » est un script de lancement d'une application, spécialement
conçu pour une distro ou une situation donnée. Parfois fourni avec le logiciel.

Y a-t-il un fichier « vlc-wrapper » dans le répertoire où se trouve vlc ?
Si oui, clique dessus ? S'il ne se passe rien, reviens nous voir ?

À+

~~~~~~~~~~~~~~
Ajout 5 min. après.

Il y a une description exactement de ton problème ici, ainsi que de sa solution :

-- ouvre le fichier « vlc-wrapper » dans ton éditeur de textes (geany, leafpad
ou autre)

-- parcours les lignes et trouve la mention « geteuid ». Remplace cette
mention « geteuid » par la mention « getppid » (sans les guillemets).
Vérifie qu'il n'y a pas de coquille dans ce que tu as tapé. Ensuite...

-- enregistre le script corrigé

-- ferme ton éditeur

-- va dans le répertoire où se trouve vlc et clique sur le script
« vlc-wrapper » corrigé.

Ça donne quoi ? vlc se lance ? Tu nous tiens au courant, s.t.p. ?

À+.

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
oui

Joined: 20 May 2005
Posts: 3127
Location: near Woof (Germany) :-) Acer Laptop emachines 2 GB RAM AMD64. franco-/germanophone, +/- anglophone

PostPosted: Fri 09 Nov 2018, 16:25    Post subject:  

7x7 a raison, je n'y avais pas pensé car je déteste VLC, un peu à cause de ça d'ailleurs et d'autres choses:

le "vrai" VLC, pas bidouillé pour tourner dans Puppy refuse de tourner en root!

c'est purement et simplement n o r m a l !

mais, si je me rappelle bien, dans Slaxen il y a un usager non-root.

peut-on lui conférer la tâche d'appeler VLC?

médor, Slaxen, c'est ton bébé, c'est à toi de répondre!

pour 7 x 7:

sous linux standard, se loger en non-root est facile en console:

admettons que cet usager soit "puppy" et son mot de passe "linux" (sur plusieurs distribution puppy-linux, ce fut ça, mais il y en a eu aussi d'autres!)

tu tapes en console

# su puppy
le système demandera alors ton mot de passe et tu répondras "linux"!

et dans la ligne suivante, tu taperas

# vlc en confirmant.

pour quitter la session ainsi ouverte, après l'usage

# exit

mais est-ce que cela marchera dans slaxen?

actuellement, dans mon puppy (bionicpup 64 7.9.4), j'ai "mpv" au lieu de VLC. c'est parfait et sans aucun problème! quel soulagement!
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3457
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sat 10 Nov 2018, 12:23    Post subject:  

Obsolète!!!
_________________


Last edited by Argolance on Sat 10 Nov 2018, 15:10; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website 
musher0

Joined: 04 Jan 2009
Posts: 12980
Location: Gatineau (Qc), Canada

PostPosted: Sat 10 Nov 2018, 13:04    Post subject:  

Argolance wrote:
Bonsoir,
Arrow Essaie cette version (2.8.2), soit en SFS, soit en paquet pet.

Cordialement.
Salut, Argolance !

Chanté :
Tra-la-la-la. Elle est pas là ! Laughing

Parlé :
Dans ta section « multimédias » (pas la section « graphiques »), c'est
la version 2.1.2 que tu offres, pas la version 2.8.2.

Prié :
Seigneur Dieu, Rolling Eyes pourquoi faut-il encore que je joue les réviseurs ?

À+

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3457
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sat 10 Nov 2018, 13:17    Post subject:  

Obsolète...
_________________


Last edited by Argolance on Sat 10 Nov 2018, 15:18; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website 
musher0

Joined: 04 Jan 2009
Posts: 12980
Location: Gatineau (Qc), Canada

PostPosted: Sat 10 Nov 2018, 14:49    Post subject:  

Cou' donc, j'suis-ti aveugle?...

J'suis retourné voir ta page, et vlc-2.1.2 n'est pas dans la liste !
Tu offres, de haut en bas :
Quote:
Ton utilitaire d'installation
The Gimp
LazPaint
XnConvert
XnRetro
XnView
Fotoxx
Blender
Cinelerra
LIVES
SweetHome3D
Un vrai de vrai lien direct à l'application ne nuirait pas non plus.

Tierce personne confirmer s.v.p. avant qu'Argolance et moi ne nous
prenions aux ch'veux !?

Merci d'avance !
ToOpPy_LINUX-Téléchargement_PROGRAMMES-Graphisme.html.zip
Description 
zip

 Download 
Filename  ToOpPy_LINUX-Téléchargement_PROGRAMMES-Graphisme.html.zip 
Filesize  6.12 KB 
Downloaded  1 Time(s) 

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)

Last edited by musher0 on Sat 10 Nov 2018, 15:12; edited 1 time in total
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3457
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sat 10 Nov 2018, 15:09    Post subject:  

Bon, c'est promis, je ne touche plus à la moquette! Je ne sais pas pourquoi j'ai focalisé sur Gimp au lieu de vlc! Shocked
Tu as raison. Mais dans tous les cas, il n'y a là aucune raison de se prendre par les cheveux...

_________________

Back to top
View user's profile Send private message Visit poster's website 
musher0

Joined: 04 Jan 2009
Posts: 12980
Location: Gatineau (Qc), Canada

PostPosted: Sat 10 Nov 2018, 15:13    Post subject:  

Ouf. Wink
_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [16 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0604s ][ Queries: 12 (0.0130s) ][ GZIP on ]