Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 15 Nov 2018, 17:11
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Video
Mouse and keyboard hung after starting with Nvidia drv
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
takenp


Joined: 05 Aug 2015
Posts: 66

PostPosted: Mon 15 Oct 2018, 19:02    Post subject:  Mouse and keyboard hung after starting with Nvidia drv  

Bionicpup64 7.9.5 of xxxphilb

I compiled Nvidia driver 340.107 for the distro and got the subj. (Mouse and keyboard hung) after rebooting.

But after unpluggin and plugging mouse and kb I got them working

So the solution I found on Arch wiki was like this. We have to disable evdev (Xorg input driver) in xorg.conf that causes this problem:

Code:
Section "ServerLayout"
...
    Option      "AllowEmptyInpu" "False"
    Option      "AutoAddDevices" "False"
...
EndSection


I've also added a section "InputDevice" from the older xorg.conf but possibly it isnt needed.

So nvidia driver is loading, mouse and keyboard works but there are some problems with libGL* libraries. glxgears says ELF class is wrong... ((

Last edited by takenp on Tue 16 Oct 2018, 03:18; edited 1 time in total
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 11261
Location: Charleston S.C. USA

PostPosted: Mon 15 Oct 2018, 19:42    Post subject:  

The puppy version is bionicpup64 7.9.5?
That is the latest release and the one to be using.
Have you done Quickpet>Info>Bionicpup updates?

Did you get the 64 bit version of the Nvidia driver?

You are sure that is the correct driver for your hardware?
The one Nvidia web site recommends?

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
p310don

Joined: 19 May 2009
Posts: 1253
Location: Brisbane, Australia

PostPosted: Mon 15 Oct 2018, 23:24    Post subject:  

I have had the same issue repeatedly with various Pups. I have found that at the end of the compile process Nvidia asks to re-write it's own xorg.conf file. Don't do that, and then run Puppy's xorgwizard and select nvidia and the keyboard works.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Video
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0293s ][ Queries: 11 (0.0041s) ][ GZIP on ]