Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 18 Nov 2018, 12:50
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
How to prevent Firefox from auto-updating? - [Solved]
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [13 Posts]  
Author Message
icosahedron


Joined: 28 Nov 2011
Posts: 74
Location: UK

PostPosted: Fri 05 Oct 2018, 04:19    Post subject:  How to prevent Firefox from auto-updating? - [Solved]  

Can anyone help with resolving a Puppy/Firefox issue?

I’m using a Puppy that’s a bit of an Old Dog now (Lucid 5.2.5) and it doesn’t like Firefox’s New Tricks.

My Puppy can cope with Firefox 37, I’ve installed a PET of that and it works very nicely, doing everything I want it to do.

Except...

Firefox won’t leave me in peace. It keeps automatically updating FF37 to FF45.0.2, and the newer version is beyond my poor Puppy’s capability - meaning that the internet keeps crashing out. (possibly because I’m running live in RAM and FF45 may be too bloated to run in 1Gb...) Often, it will remember where it was before it crashed, but it’s still inconvenient.
Not only that, but the newer version of Firefox doesn’t want me to install NoScript, because it’s ‘unsigned’, and automatically disables it.

If I wanted it disabled, Mr Fox, I wouldn’t have installed it in the first place! Or, at the very least, you can ask my permission first! Who owns this computer??

I have tried typing ‘about:config’ into the address bar, and changing ‘app.update.auto from 'true’ to 'false’, but that doesn’t seem to do what it says on the tin; Firefox just ignores this and still updates itself automatically.

Is there any way to keep my Puppy working with Firefox 37 and to stop Firefox from automatically updating (or nagging me to do it manually). I’m happy with version 37 and I just want to use the version I’ve chosen, without any hassle.

Sooner or later, I know, I’m going to have to put my Puppy to sleep and get a new one, because nothing out there will talk to it any more, but I want to put off that sad day for as long as possible. I’ve got used to his little quirks, and I hate Firefox’s bully-boy tactics.

Thanks guys. Smile

_________________
Computers: - I just ride 'em, I dunno what makes 'em work.
For me, the Console is labelled "Here be Dragons."

Last edited by icosahedron on Sat 06 Oct 2018, 23:48; edited 1 time in total
Back to top
View user's profile Send private message 
foxpup


Joined: 29 Jul 2016
Posts: 577
Location: europa near northsea

PostPosted: Fri 05 Oct 2018, 04:40    Post subject:  

Use user.js. You should create it in your profile, next to where your pref.js is.
Hope that helps.
Back to top
View user's profile Send private message 
zagreb999

Joined: 11 Apr 2014
Posts: 406
Location: Yugoslavija

PostPosted: Fri 05 Oct 2018, 04:47    Post subject:  

open ff37 tar.bz2,
delete update files ,
see screenshot
Screenshot_2018-10-05_10-31-22.jpeg
Description 
jpeg

 Download 
Filename  Screenshot_2018-10-05_10-31-22.jpeg 
Filesize  171.25 KB 
Downloaded  47 Time(s) 
Back to top
View user's profile Send private message 
darry19662018

Joined: 31 Mar 2018
Posts: 229

PostPosted: Fri 05 Oct 2018, 05:45    Post subject:  

Absolutelty works for me using this method.
Back to top
View user's profile Send private message 
Galbi


Joined: 21 Sep 2011
Posts: 1054
Location: Bs.As. - Argentina.

PostPosted: Fri 05 Oct 2018, 11:30    Post subject:  

I have these lines
Code:
#######################################################
# No Firefox update
127.0.0.1 www.mozilla.org
127.0.0.1 download.cdn.mozilla.net
127.0.0.1 aus5.mozilla.org
127.0.0.1 download.mozilla.org
#######################################################

in the /etc/hosts archive.

_________________
Remember: "pecunia pecuniam parere non potest"
Back to top
View user's profile Send private message 
souleau


Joined: 23 Oct 2016
Posts: 132

PostPosted: Fri 05 Oct 2018, 12:50    Post subject:  

I'm running Puppy Precise 5.7.1, with FF, so I have had exactly the same dilemma you are having.

I'm running Firefox 45.02 right now, with NoScript, version 5.1.8.4, which works fine.

You can find older versions of Noscript here.

https://noscript.net/feed?c=100

You can download the file, and then manually install it as an add-on.

If you don't want FF to update automatically, you go to -Edit-Preferences-Advanced-Update, and check the - never check for updates box-.
Back to top
View user's profile Send private message 
icosahedron


Joined: 28 Nov 2011
Posts: 74
Location: UK

PostPosted: Fri 05 Oct 2018, 14:49    Post subject:  

Thanks guys.

Foxpup, I’m not sure where my profile is, much less where pref.js is.

Zagreb, I’ll try deleting those files when I switch on tomorrow.

Galbi, I’m not sure what those lines of code are for. What is their significance?

Soleau, I found the earlier version of Noscript, and the never check for updates is already checked.

_________________
Computers: - I just ride 'em, I dunno what makes 'em work.
For me, the Console is labelled "Here be Dragons."
Back to top
View user's profile Send private message 
Galbi


Joined: 21 Sep 2011
Posts: 1054
Location: Bs.As. - Argentina.

PostPosted: Fri 05 Oct 2018, 15:29    Post subject:  

icosahedron wrote:
Galbi, I’m not sure what those lines of code are for. What is their significance?

Look here: http://winhelp2002.mvps.org/hosts.htm
I usually add the lines mentioned above, to the hosts file downloaded from that site.
Whenever Ffox tries to update through one of that webs, it will fail because they point to the IP 127.0.0.1 which is your own machine.

It's a good security practice to change the hosts file provided by Puppy, for one of those modified (and regularly updated) hosts files, to avoid your machine connecting to undesirable sites.

Saludos.

_________________
Remember: "pecunia pecuniam parere non potest"
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 12980
Location: Gatineau (Qc), Canada

PostPosted: Fri 05 Oct 2018, 17:08    Post subject:  

Galbi?

Doesn't your trick cancel out any access to Firefox plug-ins if we need one?
TIA.

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
Galbi


Joined: 21 Sep 2011
Posts: 1054
Location: Bs.As. - Argentina.

PostPosted: Fri 05 Oct 2018, 18:57    Post subject:  

musher0 wrote:
Galbi?
Doesn't your trick cancel out any access to Firefox plug-ins if we need one?
TIA.

I almost don't use addons, but, to test, I've just installed Classic Theme Restorer without trouble.

_________________
Remember: "pecunia pecuniam parere non potest"
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 12980
Location: Gatineau (Qc), Canada

PostPosted: Fri 05 Oct 2018, 19:57    Post subject:  

Thanks.
_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
foxpup


Joined: 29 Jul 2016
Posts: 577
Location: europa near northsea

PostPosted: Sat 06 Oct 2018, 14:58    Post subject:  

icosahedron wrote:
Foxpup, I’m not sure where my profile is, much less where pref.js is.
Okay, some more info here.
The profile folder is in /root/.mozilla/firefox/ and probably will have "default" in its name, like 11drg1m.default.
In it is a lot of stuff like places.sqlite which has your bookmarks and history.
There is also prefs.js.
You create user.js as a file there and open it with geany or another texteditor and put these lines in it:
Code:
// turn off application updates:
user_pref("app.update.enabled", false);
user_pref("app.update.auto", false);
user_pref("app.update.silent", false);
The first comment line is needed because the first line is ignored.
prefs.js is used and rewritten by firefox, whereas user.js is an optional file the user can create to override preferences initialized by other preferences files.

I use the trick from zagreb999 as well, renaming the updater files.
Back to top
View user's profile Send private message 
icosahedron


Joined: 28 Nov 2011
Posts: 74
Location: UK

PostPosted: Sat 06 Oct 2018, 23:47    Post subject:  

Hi guys,

Zagreb, deleting those files seems to have done the trick. FF didn't auto-update yesterday. Thanks! Smile

Foxpup, thanks for the extra info. I feel like I might be able to do that now - except that Zagreb's fix has already done the trick and it's quicker. Since I'm running live in RAM, I don't have to worry too much about deleting stuff.

Galbi, that material looks very useful for general security purposes, but it's outta my league at present (as you can see from my signature). I'd love to learn how to do that, though - thanks for showing me that it exists. Maybe with time I'll learn how to do it. Love your avatar, BTW. Smile

_________________
Computers: - I just ride 'em, I dunno what makes 'em work.
For me, the Console is labelled "Here be Dragons."
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [13 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.5507s ][ Queries: 12 (0.0241s) ][ GZIP on ]