Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

READ-ONLY-MODE: PLEASE DO NOT POST NEW STUFF!
  New Forum: http://forum.puppylinux.com
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups    
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 13 Aug 2020, 23:00
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Bionicpup64 8.0 CE
Moderators: Flash, JohnMurga
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 76 of 87 [1305 Posts]   Goto page: Previous 1, 2, 3, ..., 74, 75, 76, 77, 78, ..., 85, 86, 87 Next
Author Message
bigpup


Joined: 11 Oct 2009
Posts: 13981
Location: S.C. USA

PostPosted: Thu 16 Jan 2020, 12:43    Post subject:  

Some bug reports about Bionicpup64 8.0
http://www.murga-linux.com/puppy/viewtopic.php?t=117880
http://www.murga-linux.com/puppy/viewtopic.php?t=117879

_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer)
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 1983
Location: lincoln, uk

PostPosted: Fri 17 Jan 2020, 12:26    Post subject:  

hi guys

I am struggling to get wifi working on my lenovo w520 4284-4dg using bionicpup4 8.0

works ok in xenialpup64

lspci: 03:00.0 Network controller: Intel Corporation Centrino Ultimate-N 6300 (rev 3e)

dmesg | grep wifi (from xenial 64)
iwlwifi 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-6000-6.ucode failed with error -2
iwlwifi 0000:03:00.0: Falling back to user helper
iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-6000-5.ucode failed with error -2
iwlwifi 0000:03:00.0: Falling back to user helper
iwlwifi 0000:03:00.0: loaded firmware version 9.221.4.1 build 25532 op_mode iwldvm
iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG disabled
iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS disabled
iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING disabled
iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Ultimate-N 6300 AGN, REV=0x74
iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1


I was going to copy over the /lib/firmware from xenial to bionic but got a bit lost

help appreciated!!

Smile
Back to top
View user's profile Send private message Visit poster's website 
bigpup


Joined: 11 Oct 2009
Posts: 13981
Location: S.C. USA

PostPosted: Sat 18 Jan 2020, 11:57    Post subject:  

Quote:
I am struggling to get wifi working on my lenovo w520 4284-4dg using bionicpup4 8.0

What exactly is the problem?
Wifi not recognized?

_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer)
Back to top
View user's profile Send private message 
Terry H

Joined: 29 Mar 2009
Posts: 782
Location: The Heart of Muskoka, ON Canada

PostPosted: Sat 18 Jan 2020, 12:19    Post subject:  

ally wrote:
hi guys

I am struggling to get wifi working on my lenovo w520 4284-4dg using bionicpup4 8.0

works ok in xenialpup64

lspci: 03:00.0 Network controller: Intel Corporation Centrino Ultimate-N 6300 (rev 3e)

dmesg | grep wifi (from xenial 64)
iwlwifi 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-6000-6.ucode failed with error -2
iwlwifi 0000:03:00.0: Falling back to user helper
iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-6000-5.ucode failed with error -2
iwlwifi 0000:03:00.0: Falling back to user helper
iwlwifi 0000:03:00.0: loaded firmware version 9.221.4.1 build 25532 op_mode iwldvm
iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG disabled
iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS disabled
iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING disabled
iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Ultimate-N 6300 AGN, REV=0x74
iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1


I was going to copy over the /lib/firmware from xenial to bionic but got a bit lost

help appreciated!!

Smile


ally, you posted the dmesg from xenial which works, but not the dmesg form bionic. What does dmesg show in bionic? This will identify what you need.

Copying the firmware from xenial to bionic, if it shows in dmesg as not found is probably OK. If you are using an older kernel in xenial, the version of firmware required for bionic may be later than that included in xenial.
Back to top
View user's profile Send private message 
rockedge


Joined: 11 Apr 2012
Posts: 1874
Location: Connecticut, United States

PostPosted: Sat 18 Jan 2020, 16:02    Post subject:  

try switching the Xenial kernel that works into the Bionic you would like to run
Back to top
View user's profile Send private message Visit poster's website 
ally


Joined: 19 May 2012
Posts: 1983
Location: lincoln, uk

PostPosted: Sun 19 Jan 2020, 17:07    Post subject:  

apologies....

@bigpup, sorry, yes, wifi device not recognised, in hardinfo the iwlwifi module is listed against "03:00.0 Network controller: Intel Corporation Centrino Ultimate-N 6300 (rev 3e)"

dmesg | grep wifi (from bionicpup64 8.0)

iwlwifi 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-6000-6.ucode failed with error -2
iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-6000-5.ucode failed with error -2
iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-6000-4.ucode failed with error -2
iwlwifi 0000:03:00.0: no suitable firmware found!
iwlwifi 0000:03:00.0: minimum version required: iwlwifi-6000-4
iwlwifi 0000:03:00.0: maximum version supported: iwlwifi-6000-6
iwlwifi 0000:03:00.0: check git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git


Smile
Back to top
View user's profile Send private message Visit poster's website 
Terry H

Joined: 29 Mar 2009
Posts: 782
Location: The Heart of Muskoka, ON Canada

PostPosted: Sun 19 Jan 2020, 19:02    Post subject:  

ally,
Any of the 3 firmware files listed in the dmesg will work, iwlwifi-6000-6.ucode | iwlwifi-6000-5.ucode | iwlwifi-6000-4.ucode.

Your Xenial install has iwlwifi-6000-4.ucode included, so copy that to /lib/firmware in your bionic install.
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 1983
Location: lincoln, uk

PostPosted: Sun 19 Jan 2020, 19:28    Post subject:  

thanks terry

how do I copy the file(s) over, I'm trying to move from zdrv/lib/firmware but it fails with read-only?

Smile
Back to top
View user's profile Send private message Visit poster's website 
Terry H

Joined: 29 Mar 2009
Posts: 782
Location: The Heart of Muskoka, ON Canada

PostPosted: Sun 19 Jan 2020, 19:48    Post subject:  

If you click on the zdrv using ROX. you will be asked whether you want to install SFS or view content. Select to view content, this will mount the zdrv. It will be mounted as Read only, that does not stop files from being copied, So you can then copy the firmware by using drag and drop and selecting copy when the dialog window is displayed when you drag the file to the required location.
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 1983
Location: lincoln, uk

PostPosted: Sun 19 Jan 2020, 20:53    Post subject:  

terry

I must be missing something, opening xenial64 zdrv in rox and bionicpup64 zdrv in adjacent panes after clicking view contents, tried dragging and copy/paste the iwlwifi-6000-4.ucode file

I'm still getting the read only error and no file copied to bionicpup zdrv

Smile
firmware.png
Description 
png

 Download 
Filename  firmware.png 
Filesize  150.99 KB 
Downloaded  47 Time(s) 
Back to top
View user's profile Send private message Visit poster's website 
ally


Joined: 19 May 2012
Posts: 1983
Location: lincoln, uk

PostPosted: Sun 19 Jan 2020, 21:11    Post subject:  

terry

all sorted - thanks

so I put on my big boy pants, extracted the zdrv sfs, copied on the iwlwifi 6000.4 file then re-squashed the sfs

I'm very proud of myself....

Very Happy
Back to top
View user's profile Send private message Visit poster's website 
Terry H

Joined: 29 Mar 2009
Posts: 782
Location: The Heart of Muskoka, ON Canada

PostPosted: Sun 19 Jan 2020, 21:12    Post subject:  

Just copy it to the /lib/firmware in you file system, so it will be in your save file/folder.

If you want it in the zdrv, you would have to unsquashfs then copy the file to the directory created by when you unsquash for zdrv. Then you would have to use mksquashfs to reproduce the zdrv.

It's much easier to just add it to your save.

Edit: Our posts crossed. Well done.
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 1983
Location: lincoln, uk

PostPosted: Sun 19 Jan 2020, 21:25    Post subject:  

gotcha

I was trying to copy from zdrv to zdrv and not zdrive to file/lib/firmware

the latter is much easier!!

filed away for the next time

appreciate the help

Smile
Back to top
View user's profile Send private message Visit poster's website 
Mike Walsh


Joined: 28 Jun 2014
Posts: 6397
Location: King's Lynn, UK.

PostPosted: Mon 20 Jan 2020, 07:22    Post subject:  

Morning, all.

Is it my imagination, or do I recall there being an issue with the CPU Frequency Scaling Tool in Bionicpup64? (It may have been one of the other modern Pups; I'm not certain.)

Bionicpup64 is the first Puppy I've got set-up and running the way I like it on this new machine of mine.....but I don't seem to be able to set the 'governor' to 'balanced' (which is what I normally use.) Consequently, this Pentium Gold G5400 is running flat-out @ 3.7 GHz all the time..!! Power's not an issue, since it's a desktop, but I would like to be able to make use of the SpeedStep stuff.

After selecting the 'on-demand' governor, there is nothing showing in the frequency selection boxes. I'm sure I remember there being a 'fix' issued for this (it may have been ozsouth who came up with it?)

In all honesty, I just haven't got time to read all the way through this thread ATM, so any pointers or advice would be very much appreciated, as always.

TIA.


Mike. Wink

_________________
MY 'PUPPY' PACKAGES

Back to top
View user's profile Send private message 
LateAdopter

Joined: 27 May 2011
Posts: 362
Location: Reading UK

PostPosted: Mon 20 Jan 2020, 14:15    Post subject:  

Hello Mike

By default your G5400 will be using the intel_pstate driver. It has performance and powersave modes. The default may be sset by the BIOS settings or by the kernel configuration. It is not managed by the Puppy frequency scaling tool.
You can override the default via sysfs.

My intel N3150 defaults to powersave.

Alternatively you can put intel_pstate=disable or intel_pstate=passive as a kernel boot parameter. If you disable then the ondemand governor can take over and work normally but the processor HWP may not be fully configured. passive allows the intel_pstate to configure the processor, but I don't know what happens afterwards because I haven't tried it.

I bought an Athlon 3000G rather than a Pentium Gold G5420 because the AMD processor avoids most of the vulnerabilities
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 76 of 87 [1305 Posts]   Goto page: Previous 1, 2, 3, ..., 74, 75, 76, 77, 78, ..., 85, 86, 87 Next
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.2965s ][ Queries: 12 (0.1550s) ][ GZIP on ]