Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 14 Nov 2018, 20:09
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
How to use a USB wifi adapter on wary puppy 5.5?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
tjosurplus

Joined: 27 Aug 2018
Posts: 6

PostPosted: Mon 27 Aug 2018, 10:40    Post subject:  How to use a USB wifi adapter on wary puppy 5.5?  

Hi everyone!
I am a noob for linux. Forgive me.
I am retro computing, I have a very cool old industrial computer I brought back to life using linux wary puppy 5.5. I tried about every other linux based os, and every windows os from 95 up, and the only one that will boot is wary puppy 5.5

Now, I need help! I can get internet using the lan cable, but I want to use wifi.

I plugged in several different wifi usb dongles, and the system does not recognize that I plugged anything in.

My current adapter is a Panda Pau05 wireless N usb adapter

I tried using the network dialog box, and used auto locate and load module for every usb wifi adapter in the list, with no success.

It only shows one choice, the lan connection eth0

I downloaded the linux drivers from the panda website, but don't know how to get them in the wizard.

Today I am going to try the wrap around using the windows .inf file.

I have looked for other posts from wary puppy users, and it seems like wifi may not work in wary puppy. I just need confirmation that it does or does not work.

If it does work, I need step by step instructions on how install the wifi adapter, and if I need to use the terminal to enter commands, I need to have very specific instructions. I am good with computers, but this is a very new OS to me.

Also, it looks like there are programs called "pets", that can be written to install items. I would even be happy to pay for a pet that installs the wifi adapter.

By the way, I also tried plugging in a USB 3g AT&T broadband modem. Puppy automatically recognized this device, and started installing software in a yellow dialog box, but it closes and nothing further happens.

Please help and let me know!

Dave
Back to top
View user's profile Send private message 
darry19662018

Joined: 31 Mar 2018
Posts: 229

PostPosted: Mon 27 Aug 2018, 15:16    Post subject:  

Welcome to the forums Dave,

Here is info I could find on this device.
http://www.pandawireless.com/panda300mbps.htm

Could you please give us more details of your machine as you may require a later Puppy to run on this machine as Wary is very old and has an older kernel which won't support this device. I am sure someone more knowlegeable than me to help you.

Anyway details of your machine are needed to go further with this - this guide gives you an idea of the info required.

http://murga-linux.com/puppy/viewtopic.php?t=90471
Back to top
View user's profile Send private message 
mikeslr


Joined: 16 Jun 2008
Posts: 2773
Location: 500 seconds from Sol

PostPosted: Mon 27 Aug 2018, 15:43    Post subject:  

Hi Dave,

Here's the problem. Manufacturers of wifi adapters expect them to be run under Windows. Consequently, they create the drivers and firmware necessary for the Window operating system to communicate with their wifi adapters. Some, but not all, create drivers and firmware for SOME version of Linux, by which I mean the Linux Kernel. A Linux Kernel is analogous to a car's engine. Each engine is different, so the parts which connect it to many essential components are also different and not interchangeable. Think brakes as compared to car radios. There are many, many Linux Kernels, maybe a dozen or more produced every year.

As a result, the Linux Devs have to create their own drivers for each hardware component, such as the chips used in Wifi adapters. [Firmware, on the other hand, is interchangeable -- not dependent on which kernel is used]. Different Wifi adapters manufacturers may purchase their chips from the same chip manufactures.

It is possible to "compile" a driver for a particular wifi chip; but not something a newby is likely to undertake unless he/she has no other recourse -- among which are not using that computer or operating system.

So, as a practical matter in order to suggest a course of action for you we would have to know (a) the kernel which wary* 5.5 uses and (b) the chip used by EACH of the wifi adapters you currently have available.

See if Wary 5.5 already has PupSysInfo installed: Menu>System>PupSysInfo. If not, use whatever system you were using to post in order to download to somewhere Wary 5.5 will be able to access it the PupSysInfo-2.8 pet from here: http://murga-linux.com/puppy/viewtopic.php?p=579411#579411. When you're back in Wary 5.5., Left-Click it to install it. [I think it will work in Wary 5.5, but if it doesn't, let us know and we'll provide the commands you'll need to run via a terminal to get the necessary information].

Plug in one of your adapters, restart X [Menu>Shutdown>Restart-X or Restart Graphical Server]. Wary will re-catalog what is then part of your system. Open PupSysInfo [Menu>System>PupSysInfo], then click the System Specs Tab at the Top Right and select Base Report. Scrolling down, you'll see a Line "Linux Kernel:" followed by the kernel identified. Further down, you'll see a line beginning with "Network Controller" followed by the name of the manufacturer and the specific chip set, such as "Ralink corp. RT2561/RT61 802.11g PCI [1814:0301]".

Make a note of both, then unplug that adapter, plug in another, Restart-X, reopen PupSysInfo and make a note of the manufacturer and chip set for that adapter. Do that for each adapter you now have.

Hopefully, with that information, someone may be able to locate an already existing driver for Wary 5.5 for one or more of your adapters. Alternatively, we may be able to suggest a different Puppy. Or lastly, we may be able to suggest an wifi adapter which won't cost too much.

mikesLr

Fortunately, you did refer to your Puppy as Wary 5.5. But the mention of "Puppy" was irrelevant. For future reference, always refer to a Puppy by its Name and version number somewhere at the beginning of your post. "Puppy" will get you to this Forum, where you'll find discussions of maybe 200 versions, each slightly different. We don't abandon anything. But then, we all are a little crazy. Laughing
Back to top
View user's profile Send private message 
tjosurplus

Joined: 27 Aug 2018
Posts: 6

PostPosted: Mon 27 Aug 2018, 18:55    Post subject:  

Thank you! Thank you! and Thank You! Noted on wary vs puppy!

Your information was excellent, I'm off to try it right now, and will post result/questions.

I would have no problem buying a wifi adapter that we know works with wary 5.5 out of the box, if anyone knows of such an adapter.

Thank you again.
Dave
Back to top
View user's profile Send private message 
tjosurplus

Joined: 27 Aug 2018
Posts: 6

PostPosted: Thu 30 Aug 2018, 13:45    Post subject:  

Ok, Here is where I'm at.

I tried using the NDISWRAPPER, it found the adapter (said it was present), but went to next step and was unable to locate new hardware, and unloaded the ndiswrapper

I tried using the sys.info as requested, I had to download and install the pet.

Your request was to look under "network controller" I did not have this option, mine only said "network"

under network it listed 802.11 n wlan
under wireless network : no wireless connection
under usb devices: bus 001 device 012: ID 148f:5372 Ralink tech. corp
and second wifi adapter was: bus 001 device 020: ID 148f: 7601 ralink tech corp

Under modules it shows many choices for usb adapters, with specific chipsets, I crossed a few of them and found a nintendo buffalo adapter with the chip set RT 2500
a Belkin Wireless 802.11g USB Network Adapter which also uses the rt2500 chipset.

I am hoping the use of either of those two wifi adapters will allow me to load the correct module and work.

I was also asked what type of system I am running in case I needed to change my OS.

It is a laptop clone made by DRS technologies

with a phoenix bios 4.0 release 6.0
bmicpci-7611 bios revision 1.02
cpu intel mobile pentium II 333mhz
640K system ram
256K sram
40gb harddrive

Thanks again!
Dave
Back to top
View user's profile Send private message 
tjosurplus

Joined: 27 Aug 2018
Posts: 6

PostPosted: Sun 02 Sep 2018, 11:09    Post subject:  

Success!

I got wifi working on wary 5.5

I needed to find a wifi usb adapter that worked with the modules pre-loaded in wary 5.5.

Turns out the one I found is a nintendo USB wifi adapter, which uses Real Tek RA2570 chipset.

It found the adapter automatically. I just had to configure the wireless settings.

Thanks for everyone's help!

Dave
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1541s ][ Queries: 11 (0.0435s) ][ GZIP on ]