Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 22 Sep 2018, 04:12
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Libgtk-3.0 problem for FF-61 & T-Bird 60 in Racy 5.5.....
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
Mike Walsh


Joined: 28 Jun 2014
Posts: 4144
Location: King's Lynn, UK.

PostPosted: Tue 14 Aug 2018, 09:22    Post subject:  Libgtk-3.0 problem for FF-61 & T-Bird 60 in Racy 5.5.....
Subject description: Anybody got any 'pointers' on this one?
 

Afternoon, all.

I'm currently running watchdog's FF45esr and my own Thunderbird 45.8.0 package in Racy 5.5. Don't know why I'm bothering with this, TBH, because they both run extremely well.....but just for the hell of it, I'm trying to get Fred's Quantum 61 'portable' and my new T-Bird 60 packages to run here.

I've already updated libgtk-3.0 and libgdk-3.0, using a package originally linked to me by perdido; put together, I believe, for Precise. This same package has permitted running the above packages in Precise 571, and Slackos 560 & 570.....along with watchdog's advice to add the Wheezy libdbus to /lib, thereby giving it priority in the /path over the native version.

Normally, this would be a fool's errand, due to the advanced age of Racy's glibc. (I'm a glutton for punishment..! Laughing) However, I'm using battleshooter's 'glibc-2.20 upgrade' for Racy 5.5, from here:-

http://www.murga-linux.com/puppy/viewtopic.php?p=806989

.....which works extremely well indeed, and allows me to run the very last 32-bit Chrome (48.0.2564.116) here in Racy, and thus view NetFlix..!

----------------------------------------------------------------------------------------

With Quantum and the new T-Bird both using the same 'engine under the hood', as it were, I figured that if there should be any problems with either of them, it would probably be the same one. And so it's proved.

Running both of them from /root as a trial, I get this in the terminal in both cases:-

Code:
# /root/thunderbird/thunderbird
/root/thunderbird/thunderbird: symbol lookup error: /usr/lib/libgtk-3.so.0: undefined symbol: g_static_resource_init
#
# /root/firefox32/ff
/root/firefox32/firefox: symbol lookup error: /usr/lib/libgtk-3.so.0: undefined symbol: g_static_resource_init
#


I'm guessing there's possibly other 'stuff' needs transplanting yet, but, er.....well, I'm no 'expert' with this kinda thing, really. And my own very slapdash 'suck it and see' approach has let me down this time; I've essentially reached the limits of my own knowledge, I don't mind admitting!

Anybody got any insights on this one? I'm well aware that Racy was the last of the 'T2' builds, before Woof-CE got off the ground, yet it hasn't stopped me from getting several other items working on here that everybody reckoned was impossible, so.....

Any advice or suggestions will, as always, be very much appreciated. TIA.


Mike. Wink

_________________
MY PUPPY PACKAGES | 'Thanks' are always appreciated!
--------------------------------------

Back to top
View user's profile Send private message Visit poster's website 
perdido


Joined: 09 Dec 2013
Posts: 952
Location: ¿Altair IV , Just north of Eeyore Junction.?

PostPosted: Tue 14 Aug 2018, 22:55    Post subject:  

I would start by verifying minimum requirements

Thunderbird will not run at all without the following libraries or packages:
https://www.thunderbird.net/en-US/thunderbird/60.0/system-requirements/
GTK+ 3.4 or higher (should be at 3.4.2 with pet)
GLib 2.22 or higher (GTK+ depends)
Pango 1.14 or higher (GTK+ depends)
X.Org 1.0 or higher (1.7 or higher is recommended)
libstdc++ 4.6.1 or higher

==========================
So looking at precise 5.7.1 all those packages are new enough with the GTK+ 3.4.2 pet added.
So precise can be a source for newer packages for Racy ~maybe

If you feel like exploring find which versions Racy has installed.
Then if any are too old replace with the package from precise 5.7.1 and see if it runs....but beware
that installing newer libs can break things Smile

Two ways to get later packages from precise, gnewpet will create a pet from a package already installed,
or google ubuntu 12.04 <package name> and download the .deb

Just my thoughts, might be totally unrelated to the actual problem.



.


.
Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 4144
Location: King's Lynn, UK.

PostPosted: Wed 15 Aug 2018, 06:59    Post subject:  

Hi, perdido.

Hm. Well, that's odd.

Quote:
<snip>Glib 2.22 or higher<snip>


So how come it's running in both of the Slackos mentioned (560 & 570), as well as Precise 571.....which all have only Glib 2.15? That's the first thing you would expect it to 'spazz out' on, really. Hmm....

No makee sense, mate......


Mike. Wink

_________________
MY PUPPY PACKAGES | 'Thanks' are always appreciated!
--------------------------------------

Back to top
View user's profile Send private message Visit poster's website 
perdido


Joined: 09 Dec 2013
Posts: 952
Location: ¿Altair IV , Just north of Eeyore Junction.?

PostPosted: Wed 15 Aug 2018, 10:27    Post subject:  

Mike Walsh wrote:
Hi, perdido.

Hm. Well, that's odd.

Quote:
<snip>Glib 2.22 or higher<snip>


So how come it's running in both of the Slackos mentioned (560 & 570), as well as Precise 571.....which all have only Glib 2.15? That's the first thing you would expect it to 'spazz out' on, really. Hmm....

No makee sense, mate......


Mike. Wink


Hi Mike,

Precise 5.7.1 has Glib 2.32,(/lib/libglib-2.0.so.0.3200.3, precise has Glibc 2.15 , different animals
I don't know which Glib the slackos have.
You can look in /lib/ to find out by looking at the version info at the end of the file name,
precise being libglib-2.0.so.0.3200.3 with the 2 designating major version, 3200 designating its minor version.
Example here in the list of files https://packages.ubuntu.com/bionic/libglib2.0-0

Like I mentioned in my first post, precise has new enough packages of the minimum requirements to run Wink

Have fun with your wild goose!

.
Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 4144
Location: King's Lynn, UK.

PostPosted: Wed 15 Aug 2018, 11:21    Post subject:  

Hi again, perdido.

A-hah! I see; I'm getting Glib and Glibc muddled up here, 'twould seem...

I'll have another poke around, and see if I can figure out what needs swapping. Breakages aren't ever a problem for me, anyroad; I back the entire kennels up, once a month, regular as clockwork. And the personal data is all sym-linked in from external drives anyway...

We'll see what happens. Cheers for the clarification. BTW; I take it this is 'libglib' we're talking about, yes? So what does that make 'libglibmm'?

Curiouser & curiouser. Yikes....


Mike. Wink

_________________
MY PUPPY PACKAGES | 'Thanks' are always appreciated!
--------------------------------------

Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0527s ][ Queries: 11 (0.0169s) ][ GZIP on ]