Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 15 Oct 2018, 04:55
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Compiling and installing Imagemagick-6.3.6.9 in Slacko-64
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
beringstraat

Joined: 17 Mar 2013
Posts: 4

PostPosted: Sat 23 Jun 2018, 09:28    Post subject:  Compiling and installing Imagemagick-6.3.6.9 in Slacko-64  

Hello.

I’m an ex DSL user.
It is no longer possible to use it on a contemporary laptop. I had some favorite apps, such as Soundtracker and imagemagick. I’m used to the versions available in DSL.

Meanwhile I’ve managed to propre install Soundtracker in Puppy Lucid and Slacko (after changing the file called ‘config.sub’).
Imagemagick I could only install in Lucid so far. I allready tried IM from the repository in Slacko but, very soon I saw that it had changed to much and, that I had to forget all tricks and commands I had gathered. I was allready able to install it without errors (after having installed zlib and libpng) but, when I wanted to display a png image it did’nt work at all. Than I made the ‘make check’ command and came out at:

...
lt-rwblob: Aplication was compiled with png.h from libpng-1.2.58
lt-rwblob: Aplication is running with png.c from libpng-1.4.12
lt-rwblob: Incompathible libpng version in aplication and library
lt-rwblob: memory alocation failed

So I went searching for that png.c file but, can’t find it, exept from a png.c file in the package directory from libpng12. I also saw that in PSlacko there are 2 libpng versions 12 and 14. I then took away 14 but, then the system is to disturbed.
It didn’t work anyway. I alo tried to put some links to png.h called png.c but nothing. And installing with ‘--LDFLAGS and --CFLAGS or --disable-shared’ gave no resold neither.
What can I still try now?
I saw a simular threat which was solved with ‘setting PATH to a minimum’. Can anyone tell me what it means?
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 5159
Location: Ontario

PostPosted: Sat 23 Jun 2018, 12:58    Post subject:  

Your version of imagemagick is too recent for Lucid

However....
slacko 7 (64 bit) has libpng 1.4.5
https://distro.ibiblio.org/puppylinux/pet_packages-slacko/libpng-1.4.5-s.pet
_________________________________________________________

In situations like this I go launchpad and make a search for old packages
https://launchpad.net/imagemagick/+packages
________________________________________
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0855s ][ Queries: 11 (0.0290s) ][ GZIP on ]