Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 23 Sep 2018, 16:07
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
SLIMJET 19.0.2.0 [SOLVED]
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [24 Posts]   Goto page: 1, 2 Next
Author Message
pp4mnklinux


Joined: 23 Aug 2013
Posts: 215

PostPosted: Fri 08 Jun 2018, 10:41    Post subject:  SLIMJET 19.0.2.0 [SOLVED]
Subject description: Can you , please, make a .pet to install it on my puppy tahr linux 6.0.2 ??
 

Hello everybody:

I'm using puppy tahr linux 6.0.2 updated to 6.0.5.

My default browser is SLIMJET 15.1.2.0

i WANT TO UPDATE IT BUT when I update from the browser (applying update) it doesn't work.

When I download slimjet 18 .pet it does't work, the update doesn't work

So I, PLEASE, ask u to make a pet with the last version of SLIMJET

I LIKE TO BE UPDATED WITH THE LASTEST SOFT, SO I'LL BE REALLY THANKFULL WITH YOU IF YOU HELP ME


THANKS A LOT.-...... I'M WAITING FOR IT.


THANKY




https://photos.app.goo.gl/WUDrJhawzVeMOB6x2

_________________
Kernel : Linux 4.9.58 (x86_64)
Version : #1 SMP PREEMPT Mon Nov 13 15:54:01 GMT 2017
C Library : GNU C Library version 2.23 (stable)

Distribution: xenial pup 7.5 x64


http://www.protopage.com/pp4mnkt3am#puPPy_Linux

Last edited by pp4mnklinux on Sat 04 Aug 2018, 02:51; edited 1 time in total
Back to top
View user's profile Send private message 
mjmikulcik

Joined: 09 Jun 2017
Posts: 32

PostPosted: Fri 08 Jun 2018, 11:37    Post subject:  

what are the errors you get when running the updated pet?
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1807
Location: London, England

PostPosted: Fri 08 Jun 2018, 12:26    Post subject:  

I uploaded .pet and .sfs packages of Slimjet 19.0.2.0 earlier today.
It will NOT run in TahrPup though.
I forget the details, but some libraries would need to be upgraded.
Sorry, but I have no plans to do this.
Slimjet 15.1.6.0 is available and runs OK in TahrPup

This Slimjet is based on Chromium 66.
Only 32bit packages of this from me
Runs as spot
Tested briefly in XenialPup and Dpup Stretch.
For anyone wanting to run recent or latest versions of Chromium derivative browsers I recommend upgrading your Puppy version to something more recent than Tahr
https://yadi.sk/d/fd8rBM0WoF9sB?force_show=1

_________________
Oscar in England

Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 4148
Location: King's Lynn, UK.

PostPosted: Fri 08 Jun 2018, 13:10    Post subject:  

@ pp4mnklinux:-

If you upgrade to Tahr 606 (uefi), you can run Oscar's Iron 63 package. Iron is another Chromium 'clone'; more similar to Chrome itself than SlimJet, but a damn good browser for all that.

You can find Oscar's Iron 63 here:-

https://yadi.sk/d/_S5b4g7tpcyZn?force_show=1

It may even run in Tahr 6.05, but I can't confirm that, since I no longer run it.


Mike. Wink

_________________
MY PUPPY PACKAGES | 'Thanks' are always appreciated!
--------------------------------------

Back to top
View user's profile Send private message Visit poster's website 
pp4mnklinux


Joined: 23 Aug 2013
Posts: 215

PostPosted: Fri 08 Jun 2018, 17:57    Post subject: thanks a lot
Subject description: thanks a lot
 

thanks a lot. - I thought I must update... now I'm sure, but the problem is that I worked a lot to configure my puppy.

thanky

_________________
Kernel : Linux 4.9.58 (x86_64)
Version : #1 SMP PREEMPT Mon Nov 13 15:54:01 GMT 2017
C Library : GNU C Library version 2.23 (stable)

Distribution: xenial pup 7.5 x64


http://www.protopage.com/pp4mnkt3am#puPPy_Linux
Back to top
View user's profile Send private message 
pp4mnklinux


Joined: 23 Aug 2013
Posts: 215

PostPosted: Fri 08 Jun 2018, 18:10    Post subject: errors
Subject description: doesn't start
 

mjmikulcik wrote:
what are the errors you get when running the updated pet?


Although it is installed, it doesn't appears in the menu and when starting it from apps folder it doesn't start.


FAIL

_________________
Kernel : Linux 4.9.58 (x86_64)
Version : #1 SMP PREEMPT Mon Nov 13 15:54:01 GMT 2017
C Library : GNU C Library version 2.23 (stable)

Distribution: xenial pup 7.5 x64


http://www.protopage.com/pp4mnkt3am#puPPy_Linux
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1807
Location: London, England

PostPosted: Fri 08 Jun 2018, 20:44    Post subject:  

In fact I can get Slimjet 19.0.2.0 running in TahrPup 6.0.5 without too much difficulty.
Update PPM and install libgtk-3
Update Palemoon to latest version (to provide latest NSS libraries)
Install Slimjet 19.0.2.0 .pet
Add the line:-
export LD_LIBRARY_PATH=/opt/palemoon:$LD_LIBRARY_PATH
to /usr/bin/flashpeak-slimjet above the "exec" line
(This gives priority to the new NSS libraries)
Menu entry should be there or start from terminal with the command slimjet
Testing only, take precautions as necessary.
slimjet-tahr.jpg
 Description   TESTING ONLY - Slimjet 19.0.2.0 in 32bit TahrPup
 Filesize   37.88 KB
 Viewed   310 Time(s)

slimjet-tahr.jpg


_________________
Oscar in England

Back to top
View user's profile Send private message 
pp4mnklinux


Joined: 23 Aug 2013
Posts: 215

PostPosted: Sat 09 Jun 2018, 02:17    Post subject: thanks oscar  

OscarTalks wrote:
In fact I can get Slimjet 19.0.2.0 running in TahrPup 6.0.5 without too much difficulty.
Update PPM and install libgtk-3
Update Palemoon to latest version (to provide latest NSS libraries)
Install Slimjet 19.0.2.0 .pet
Add the line:-
export LD_LIBRARY_PATH=/opt/palemoon:$LD_LIBRARY_PATH
to /usr/bin/flashpeak-slimjet above the "exec" line
(This gives priority to the new NSS libraries)
Menu entry should be there or start from terminal with the command slimjet
Testing only, take precautions as necessary.


THANKS FOR YOUR ANSWER, I think Iĺl change the distro to an updated one and I'll try.

HAVE A NICE WEEKEND

_________________
Kernel : Linux 4.9.58 (x86_64)
Version : #1 SMP PREEMPT Mon Nov 13 15:54:01 GMT 2017
C Library : GNU C Library version 2.23 (stable)

Distribution: xenial pup 7.5 x64


http://www.protopage.com/pp4mnkt3am#puPPy_Linux
Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 4148
Location: King's Lynn, UK.

PostPosted: Sat 09 Jun 2018, 10:04    Post subject:  

Thanks for that 'workaround', Oscar. Working nicely in Tahr 6.0.6 (uefi).

As you know, I still build the Chrome/Iron packages. I'd kinda given up on the SlimJet variants, however, because from series 17 onwards they were becoming absolute sods to get running at all. For some reason the tricks that worked with Iron simply didn't translate to SlimJet.....so I let it all slide, and concentrated on what would work.

Now that I know it'll run OK in the 32-bitzers, I'll see about getting it up-and-running in Xenial & Bionic. Thanks for renewing my interest.

Cheers.


Mike. Wink

_________________
MY PUPPY PACKAGES | 'Thanks' are always appreciated!
--------------------------------------


Last edited by Mike Walsh on Sat 09 Jun 2018, 10:27; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
Mike Walsh


Joined: 28 Jun 2014
Posts: 4148
Location: King's Lynn, UK.

PostPosted: Sat 09 Jun 2018, 10:26    Post subject:  

@ Oscar:-

Initial problem with NetFlix. Came up with one of its famous 'Error Codes'. According to the NetFlix Help Center, the solution to that one was to re-boot (Windows/Mac-only answer, but it was the only one with that specific code), so..... Just to be on the safe side, I swapped libwidevinecdm.so & libwidevinecdmadapter.so with their counterparts from your Iron 63 package.

No idea which was the actual solution, but it's all working now. Can't be without my Star Trek!

(Curiously, for some reason Slimmie's using the default cursor theme instead of the installed 'Polar Cursors'. I've got a feeling you mentioned the solution to this somewhere else quite a while ago; you wouldn't care to jog my memory, would you?)

Cheers.


Mike. Wink

_________________
MY PUPPY PACKAGES | 'Thanks' are always appreciated!
--------------------------------------

Back to top
View user's profile Send private message Visit poster's website 
Mike Walsh


Joined: 28 Jun 2014
Posts: 4148
Location: King's Lynn, UK.

PostPosted: Sat 09 Jun 2018, 19:26    Post subject:  

@ Oscar:-

Runs fine in Xenialpup using the same 'workaround'.

Bionic's a slightly different story. Peebee doesn't install Palemoon in his builds. I do, however, have Fred's FF-Quantum 'portable', so I modified the LD_LIBRARY_PATH addition to read

Code:
export LD_LIBRARY_PATH=/opt/firefox32:$LD_LIBRARY_PATH


for the NSS stuff. Libgtk-3's already the newest version available, so by rights she should run, yes?

Oh, no. She's got different ideas. Starting with
Code:
flashpeak-slimjet


...in the terminal, what comes up? That bloody stupid error that I've never yet managed to get a handle on:-

Code:
# flashpeak-slimjet
/usr/bin/flashpeak-slimjet: symbol lookup error: /usr/bin/flashpeak-slimjet: undefined symbol: gtk_widget_get_scale_factor


I've had this several times over the last year or so in various Chromium derivatives, and, despite repeated digging on the net, there is nothing to be found out there with respect to this problem. Nothing at all.....except for various suggestions to update libgtk-3!

Which ain't the problem.... Any ideas? You ever come across that one, by any chance?


Mike. Confused

_________________
MY PUPPY PACKAGES | 'Thanks' are always appreciated!
--------------------------------------


Last edited by Mike Walsh on Sun 10 Jun 2018, 04:11; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 3474
Location: Worcestershire, UK

PostPosted: Sun 10 Jun 2018, 04:01    Post subject:  

https://sourceforge.net/projects/lxpup/files/Other/LxPupSc/browsers/slimjet_lxsc_spot_19.0.2.0.sfs/download

works on both LxPupSc and UPupBB.....

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
Mike Walsh


Joined: 28 Jun 2014
Posts: 4148
Location: King's Lynn, UK.

PostPosted: Sun 10 Jun 2018, 04:22    Post subject:  

Morning, Peter.

Well, thanks for the link. I'll have a look at that a little later, when I get the chance; I'm more curious than bothered, as to why that error comes up with certain Chromium 'clones' but not others.....

Cheers.


Mike. Wink

_________________
MY PUPPY PACKAGES | 'Thanks' are always appreciated!
--------------------------------------

Back to top
View user's profile Send private message Visit poster's website 
OscarTalks


Joined: 05 Feb 2012
Posts: 1807
Location: London, England

PostPosted: Sun 10 Jun 2018, 06:38    Post subject:  

Mike Walsh wrote:
Initial problem with NetFlix. I swapped libwidevinecdm.so & libwidevinecdmadapter.so with their counterparts from your Iron 63 package.
Curiously, for some reason Slimmie's using the default cursor theme instead of the installed 'Polar Cursors'.

Hi Mike,
Thanks for the Netflix report
I swapped both libraries and have re-uploaded
By the way, Vivaldi has a script for downloading latest libwidevinecdm.so when updates happen.
The cursor issue I believe is because of running as spot
You need the (hidden) symlink /root/spot/.icons with the target of /root/.icons or something along those lines I believe

_________________
Oscar in England

Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 4148
Location: King's Lynn, UK.

PostPosted: Sun 10 Jun 2018, 07:03    Post subject:  

@ Oscar:-

Ah, that's right. I knew it was something simple.....but off the top of my head, I just couldn't remember it. And I really didn't fancy digging back through tons of old posts; I'm getting lazy in my old age, mate! Laughing

Cheers!

--------------------------------------------------

@ peebee:-

Peter, that runs fine, but.....there's the same old problem of crashing on download/upload.

I've run the

Code:
glib-compile-schemas /usr/share/glib-2.0/schemas


.....command in the terminal, but it doesn't seem to make any difference. Any ideas?


Mike. Wink

_________________
MY PUPPY PACKAGES | 'Thanks' are always appreciated!
--------------------------------------

Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 2 [24 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0634s ][ Queries: 12 (0.0061s) ][ GZIP on ]