Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 22 May 2018, 20:04
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
M.2 PCIe wifi---what works in Xenialpup64-7.5?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [12 Posts]  
Author Message
boof

Joined: 26 Sep 2012
Posts: 432

PostPosted: Tue 01 May 2018, 23:39    Post subject:  M.2 PCIe wifi---what works in Xenialpup64-7.5?  

Since everyone appears to have given up on the wl sta driver, I need something else I can use in my slot. advise pls. I'm using XenialPup64-7.5
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 12871
Location: Arizona USA

PostPosted: Wed 02 May 2018, 00:08    Post subject:  

Could you please elaborate? What is a M.2 PCle wifi or a wl sta? There's enough bandwidth allocated to the forum that you can spell things out.
Back to top
View user's profile Send private message 
ozsouth

Joined: 01 Jan 2010
Posts: 322
Location: S.E Australia

PostPosted: Wed 02 May 2018, 01:51    Post subject:  

@Boof - I've made some new wl drivers for new kernels, but I can't test them anymore. I have to download 500+ mb to make you a driver for Xenialpup64 7.5 k 4.9.58, but as others seem to be using it still, I should have a driver within an hour.

Later . . .

see: http://murga-linux.com/puppy/viewtopic.php?p=990500#990500
Back to top
View user's profile Send private message 
boof

Joined: 26 Sep 2012
Posts: 432

PostPosted: Wed 02 May 2018, 19:44    Post subject:  

Oz South
Thank you v much. I tried to make one but failed. It seems to be a real sod of a device, or is that just the support? I'll re-install it and test ur driver for u. Pls give me a full install instruction as I really don't understand what to do. a pet would be nice?
Back to top
View user's profile Send private message 
boof

Joined: 26 Sep 2012
Posts: 432

PostPosted: Wed 02 May 2018, 21:41    Post subject:  

Oz South:
downloaded file as Spot, adjusted MODULECONFIG file, moved wl.ko to correct location, ran depmod and did a cold boot.

wl does not appear in list of drivers for Network Wizard. I think I need chmod 777 <PATH/filename>????
but no, that didn't work either.
no auto load for Frizbee either.
are u sure it doesn't require the driver to be in a subdirectory of broadcomm in the wireless directory?
is there a backup copy of MODULECONFIG i can restore to, as I might have done something silly last time I was there.....

manually loading wl does not keep it loaded-it drops out when specified msg is wl.ko is not in /lib/modules/4.9.58/kernel ????????
same error message with modprobe

Last edited by boof on Wed 02 May 2018, 22:49; edited 1 time in total
Back to top
View user's profile Send private message 
ozsouth

Joined: 01 Jan 2010
Posts: 322
Location: S.E Australia

PostPosted: Wed 02 May 2018, 22:14    Post subject:  

I added pics to my instructions 3 posts up, but seems you have managed ok. Would you please run lspci in a terminal & post your result.
Meanwhile, I'm going to recompile the driver.

Last edited by ozsouth on Wed 02 May 2018, 22:58; edited 2 times in total
Back to top
View user's profile Send private message 
boof

Joined: 26 Sep 2012
Posts: 432

PostPosted: Wed 02 May 2018, 22:54    Post subject:  

here is lspci see last post last paragraph pls
lspci.png
 Description   
 Filesize   198.72 KB
 Viewed   77 Time(s)

lspci.png

Back to top
View user's profile Send private message 
ozsouth

Joined: 01 Jan 2010
Posts: 322
Location: S.E Australia

PostPosted: Wed 02 May 2018, 22:58    Post subject:  

Later . . .

Alternate driver gave compiler warnings - cfg80211 not configured in kernel - so may be flaky or fail completely - try at own risk.
Get it: http://s000.tinyupload.com/?file_id=31777454822797642091

If this fails, you either need another puplet or a new card - seems this kernel doesn't like your card. I replaced my Broadcom 43142 with an Atheros AR9285 and have an RTL8188ce in another machine. Both good.
Back to top
View user's profile Send private message 
boof

Joined: 26 Sep 2012
Posts: 432

PostPosted: Wed 02 May 2018, 23:02    Post subject:  

re the 2 cards you metion--are the m.2 form factor? and yes, I've had that error. could be shot card. will revert to win 10 to check. give me 5 min

card ok. pls recommend new 64 bit uefi version of puppy which has driver for this card.
Back to top
View user's profile Send private message 
ozsouth

Joined: 01 Jan 2010
Posts: 322
Location: S.E Australia

PostPosted: Thu 03 May 2018, 00:29    Post subject:  

AR9285 is same size /slot as BCM43142 - haven't seen the other. Antenna connector not in same place though, as dual band - your antenna wire may not reach.
Tahr64-6.0.6 & Slacko64-6.9.9.9 have uefi versions and I have made working wl drivers (posted in long wl thread on this forum). Sailor Enceladus made an updated Slacko64 with kernel 4.4.126 that I also made a driver for (but couldn't test), I've now confirmed it works.
See:http://www.mediafire.com/folder/y13kxdldb9i9d/x86_64

And I just discovered the alternate wl driver for Xenial64-7.5 (see above) works - at least while I tested via Frisbee

. Posting from it - wires hanging out usb flaky keyboard loose, lines over screen, but wl (BCM43142 alternate driver) working.
Back to top
View user's profile Send private message 
boof

Joined: 26 Sep 2012
Posts: 432

PostPosted: Fri 04 May 2018, 00:12    Post subject:  

Alternate driver with Frizbee does NOT work. card/network not detected. Niemals. Can force driver loading by "specify" but still no joy. will junk card-it has only one antenna and yes, it'sfairly short in my hp 250 G5, but I think it'll be ok. Will try to get the one you knew was going to fit in.
Back to top
View user's profile Send private message 
boof

Joined: 26 Sep 2012
Posts: 432

PostPosted: Fri 04 May 2018, 00:32    Post subject:  

Resolved. have ordered rtl8723be from ebay @ <$AU5- inc post. It'll be a few weeks, but it'll be ok. driver exists in Puppy.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [12 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0413s ][ Queries: 12 (0.0057s) ][ GZIP on ]