Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Oct 2018, 23:49
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Grub Error 15: File Not Found
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
glenk7901

Joined: 11 Apr 2018
Posts: 3

PostPosted: Wed 11 Apr 2018, 20:55    Post subject:  Grub Error 15: File Not Found
Subject description: Grub configuration Problem
 

I wanted to restore my Dell Inspiron Mini 1018 netbook with a new (standard) SSD and Linux. After trying a few different versions, Puppy was the only one that worked, or at least it was the only one I could get working. In fact, to my delight, XenialPup works very well on this old netbook as long as there aren't too many things running.
Since it is sort of awkward having a flash drive continually sticking out of a netbook, I did a full install onto the SSD, but can't get past configuring grub correctly. I have researched this and tried to solve it with at least 4 different configurations, but still can't crack it. Every time the GRUB boot menu says Error 15: File Not Found. I'm assuming that the file it is referring to is vmlinuz, and that something is wrong with the kernel path.
(The netbook uses legacy boot and the ahci driver with the ssd, if that is worth noting. And it is not a dual-boot- bye-bye windows.)
So this seems simple- the photo shows my partitions, the standard sda1 and sda2.
When Grub is installed, it creates these lines on menu.lst:
title Puppy Linux Full on sda1
root (hd0,0)
kernel /boot/vmlinuz root=/dev/sda1 ro vga=normal

I also tried changing "root=/dev/sda1" to "root=/dev/hda1" - no luck.

Also tried changing menu.lst to:
title Xenialpup 7.5 Full Install
uuid ddc2f9d8-0821-46a0-aaac-4b13c0bb5184
root (hd0,0)
kernel /boot/vmlinuz fullinstall root=UUID=ddc2f9d8-0821-46a0-aaac-4b13c0bb5184 vga=normal
initrd /boot/initrd.gz

Still File Not Found. So hopefully there is an easy solution, please help!
IMG_4180.JPG
 Description   
 Filesize   106.84 KB
 Viewed   571 Time(s)

IMG_4180.JPG

IMG_4177.JPG
 Description   
 Filesize   96.57 KB
 Viewed   586 Time(s)

IMG_4177.JPG

Back to top
View user's profile Send private message 
jafadmin

Joined: 19 Mar 2009
Posts: 854

PostPosted: Thu 12 Apr 2018, 15:14    Post subject:  

First off, vmlinuz and initrd.gz don't appear to exist in /boot. Figure out where those files actually are and correct the menu.lst accordingly.
Back to top
View user's profile Send private message 
mikeslr


Joined: 16 Jun 2008
Posts: 2700
Location: 500 seconds from Sol

PostPosted: Thu 12 Apr 2018, 15:51    Post subject: Start From Scratch  

Hi glenk7901,

“… I did a full install onto the SSD but can't get past configuring grub correctly.,,,,” Emphasis supplied.

I haven't quoted any of the “menu.lst”'s you posted, as none of them make sense.

“Do you actually mean grub? Or did you mean grub4dos?

Whichever it is, how did you install the bootloader?

Did you do the following: Running Xenialpup from the USB-Stick, did you use the “Puppy Installer” and when offered the choice between Frugal and Full install choose Full? Is that what you mean by Full Install?

Your sda1 is formatted Linux Ext4. Was this formatting done using a different Linux Distro? Many new Linux Distros are set to create 64-bit Linux Ext4 file systems. Great if you need to access a file-system of 16 Terabytes or greater. Puppies can't boot from partitions so formatted. The gparted which comes with Xenialpup will create a 32-bit Linux Ext4 if you select that formatting. Frankly, on my desktop which has a Terabyte hard-drive I chose Ext3. But it's a toss-up. Puppy's 32-bit Ext4 has some advantages and some disadvantages.

Better yet. Don't answer those questions. Forget about what you did. Start from scratch. Here's why:

If you did a Full install, before you get yourself locked into it by installing a lot of applications, you should know that “Full” and “Frugal” are “Terms of Art” as used by Puppies. They don't mean what most people familiar with Windows or other Linux distros think they mean. [b]Both Full and Frugal install the same operating system and the same applications.[/b] Both can make use of the same additional applications. Puppies are one of the perhaps 4 of the 100s of Linux distros designed to run as a Frugal Install. What Full means is that it requires the dedicated use of an entire partition, formatted as Linux. What Frugal means is that it can be run from a Folder on any drive/partition, co-existing with one other operating system which requires an entire partition, and as many other Frugally installed operating systems as you can fit on that partition "Frugally using your hard-drive". [Puppies don't need any other operating system, nor have to be in a folder; they can be placed at the root of a partition. But, even if you run only one Puppy, placing it in a folder provides an advantage: you can easily try a different –such as newer-- Puppy by locating it in a different folder].

The technique of running them as Full installs was developed at a time when computers typically had 256 Mbs or less of RAM. At that time, because of how a Frugal install works, it took what was considered a significant amount of time to boot or open applications. The technique of a Full Install was developed to provide a choice of overcoming this. But it came at the expense of many advantages provided by a Frugal Install. Today, even using a computer with your specs, the time savings obtained by using a Full install rather than a Frugal install is measured in micro-seconds. For a comprehensive discussion about this, as well as an example of how to set up Puppy, see http://murga-linux.com/puppy/viewtopic.php?p=979462#979462, http://murga-linux.com/puppy/viewtopic.php?p=980683#980683, http://www.murga-linux.com/puppy/viewtopic.php?p=983674#983674

Grub4dos, as available on every Puppy's Menu [Menu>System>Grub4dos Bootloader Config] was designed to recognize where and how Puppy is located on your computer and create a proper menu.lst enabling you to boot into it [and every other OS on your computer].

Here's what I'd do:
1. Boot into the Xenialpup on your USB-Key.

2. Open gparted, Menu>System>gparted. Reformat sda1. (See note below). Your choice: Linux Ext3 or Linux Ext4. Don't forget to set Flags to make this partition bootable. Then Exit. A “new/restructured” sda1 icon will appear just above your taskbar.
3. While still in Xenialpup from your USB-Key, click the desktop icon for sda1. A window will open. Right-click an empty space. Select New>Directory. Give it a name (so you can distinguish it from Xenialpup on your USB-Stick; maybe just 'xenial'). Left-Click the folder to open it. Leave it open.
4. Left-Click the desktop icon for your USB-Key. On either sdb1 or sdb2 (or in a folder on one of them) you should see the following files: initrd.gz, vmlinuz, puppy_xenial_xxx.sfs and zdrz_xenial_xxx.sfs –xxx depending on which iteration of xenialpup you are using. Left-PRESS, HOLD, then drag each of those from its current folder into the folder on sda1. Select “copy”. If you see a folder with the word “save” in it DO NOT copy it into the folder on sda1. [An SaveFile/Folder can not be accurately copied while in use].
5. Still running Xenialpup from your USB-Key, open Menu>System> grub4dos. Run it, selecting sda as the location for it to install. (It won't show sda1, as grub4dos works with drives, not partitions). Select “Search this Drive Only” or words to that effect. Grub4dos will create a Menu.lst in its proper format.

Shut down. Remove the USB-Key. Reboot into your new Xenialpup. After you've setup locals, timezone, and if necessary wifi and other basic settings, shutdown/reboot and accept the offer to save your settings. Select the SaveFolder choice. I prefer SaveFiles, but SaveFolder will make your life easier.

Suggest you read the thread “Remove automatic pupsave for frugal installs" http://murga-linux.com/puppy/viewtopic.php?p=662326#662326 but especially, http://murga-linux.com/puppy/viewtopic.php?p=974066#974066.

If you decide you want to remove the Automatic Save, you only need to do two things:

1 Open menu.lst in geany (text editor) and edit the line which currently reads something like:

kernel /xenial/vmlinuz pmedia=atahd psubdir=xenial pfix=fsck

to read:

kernel /xenial/vmlinuz pmedia=ataflash psubdir=xenial pfix=fsck

Note the change from atahd to ataflash. This 'tricks' grub4dos into treating your hard-drive as if it was a flashdrive. A Save Icon will appear on your desktop so that you can Save whenever you want.

Reboot. Open Menu>System>Puppy Event Manager. Click the Save Sessions Tab. Change the Save Interval to 0 (zero). Optionally check the Ask at Shutdown box. Remember to Left-Click the Save Icon on the Desktop.

mikesLr

* According to your screenshot of gparted, sda1 appears to be locked. gparted can't work with it in that condition. If it is locked, close gparted, Right-Click the desktop-drive icon with the label sda1 and select "Unmount sda1". Then reopen gparted.
Back to top
View user's profile Send private message 
mostly_lurking

Joined: 25 Jun 2014
Posts: 274

PostPosted: Thu 12 Apr 2018, 16:39    Post subject:  

mikeslr wrote:
Do you actually mean grub? Or did you mean grub4dos?

Good question. I just remembered seeing some posts about newer versions of Grub4Dos having trouble with creating correct boot menu entries for full installs:

Full installs not booting with Grub4dos generated menu entry
Full install: Bootloader - menu.lst issue
Problem doing full install of Slacko 6.9.9.9
Xenialpup won't boot with Windows 7 -- is it time to give up
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 12844
Location: Gatineau (Qc), Canada

PostPosted: Thu 12 Apr 2018, 16:52    Post subject:  

In any case, double-check that there are no typos in your menu.lst
(or equivalent) for this entry.

_________________
musher0
~~~~~~~~~~
Fidèle elle commença, ainsi elle restera. (Prov. canadien) /
Faithful she began, so will she stay. (Canadian prov.)
Back to top
View user's profile Send private message 
glenk7901

Joined: 11 Apr 2018
Posts: 3

PostPosted: Thu 12 Apr 2018, 22:01    Post subject: Re: Start From Scratch  

Thank you mikeslr for clearing so much up with the installation instructions- perhaps your info could be posted on the main site.

To try and answer your questions:
Xenialpup 7.5 (off USB) has a menu option of installing legacy (2013) GRUB for the bootloader - that's what I installed, not grub4dos. (you can choose grub4dos as well.)
The install generated the 1st menu.lst, the 2nd was an attempt from research - what others posted for menu.lst online. Perhaps the software has changed so much that they no longer make sense to you.

Yes the installer offers choosing Frugal or Full - it recommends Frugal. You explained why.

This install was done months ago, and I recall getting instructions somewhere, but don't recall any warning for ext4.

I will try the install again soon and get back to you.
Back to top
View user's profile Send private message 
glenk7901

Joined: 11 Apr 2018
Posts: 3

PostPosted: Fri 20 Apr 2018, 20:02    Post subject: followup  

Quite easy to get going. Thx again! Cool
Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 4260
Location: King's Lynn, UK.

PostPosted: Sat 21 Apr 2018, 16:45    Post subject:  

Hallo, glenk7901. And 'Welcome' to the kennels.

Here's one piece of advice I will give you. (And probably every other Puppy 'noob' out there.)

Never, ever bother with GRUB2 or any of its older derivatives. ('Legacy' GRUB included.) It is a complete pain in the ass for newcomers, because it entails jumping in at the deep end and messing around with editing scripts before you even get Puppy booted for the very first time. This is precisely the kind of thing that puts many people off Linux before they even get going.

The reason for this is that 'standard' GRUB 2 simply doesn't 'see' Puppy at all. As jafadmin said in the first reply to you, it expects to find all boot-related files'n'stuff in a folder called /boot at the root of your partition. Puppy doesn't use this. So all GRUB2 (or 'Legacy' GRUB) can do is to put out error messages. It can't very well do anything else, because it's not able to go any further.

When dealing with Puppy, always, always use the included Grub4DOS bootloader config tool. Although it's derived from a project that's no longer actively maintained, Puppy's version of this very definitely is maintained (by our Woof-CE team), and is specially 'tweaked' to work with Pup's somewhat unique method of operation. As Mikeslr says, you can install Pup to a folder inside a partition, or even inside another OS, because Grub4DOS will search two levels deep to find Puppy files.

If it can find the main Puppy SFS file, along with perhaps a 'zdrv' file (containing additional driver modules), vmlinuz (the kernel proper) and initrd.gz (Pup's compressed, 'virtual' RAM-disk, into which the Puppy SFS will be written once it's decompressed).....then Puppy will boot.

You shouldn't have any trouble installing to an SSD. I triple-boot with 3 Pups on a 15-yr old Dell lappie (an original Inspiron 1100, from 2002/3), which I've upgraded from its original 20 GB Hitachi hard drive to a 64 GB, KingSpec IDE/PATA interface SSD. They boot, and run great. No trouble at all.


Mike. Wink

_________________
MY PUPPY PACKAGES | 'Thanks' are always appreciated!
--------------------------------------

Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0982s ][ Queries: 12 (0.0093s) ][ GZIP on ]