Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 23 Apr 2018, 23:14
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
How do I stop screen tearing in Tahr 6.0.5? Solved
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [17 Posts]   Goto page: 1, 2 Next
Author Message
DustyPixel

Joined: 27 Jun 2016
Posts: 18

PostPosted: Tue 12 Dec 2017, 01:37    Post subject:  How do I stop screen tearing in Tahr 6.0.5? Solved
Subject description: Screen tearing in Tahr when playing You Tube videos
 

Is there any way to stop screen tearing in You Tube videos with Puppy Tahr? I read elsewhere that it has something to do with compositing - if so, I don't know what changes to make in the settings to fix this.
This happens in Pale Moon and in Firefox.

Edit: My apologies if this is in the wrong section - I should have posted this in Users Confused

Last edited by DustyPixel on Fri 15 Dec 2017, 05:20; edited 1 time in total
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 10312
Location: Charleston S.C. USA

PostPosted: Tue 12 Dec 2017, 12:30    Post subject:  

What is the computer?
Make and model?
Specs if you know them?

Are you watching using HTML5 or something else.
Usually a YouTube video starts using HTML5.

Tried to change any settings in the HTML5 screen settings?

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
DustyPixel

Joined: 27 Jun 2016
Posts: 18

PostPosted: Tue 12 Dec 2017, 23:06    Post subject:  

Hello bigpup -

The computer is a Gateway laptop, model NV55C 03U, manufactured in 2009.

Here are specs:

Processor : 2x Intel(R) Pentium(R) CPU P6100 @ 2.00GHz
Memory : 2386MB (252MB used)
Machine Type : Physical machine
Operating System : tahrpup - 6.0.5
User Name : root (root)
-Display-
Resolution : 1366x768 pixels
OpenGL Renderer : Mesa DRI Intel(R) Ironlake Mobile x86/MMX/SSE2
X11 Vendor : The X.Org Foundation
-Audio Devices-
Audio Adapter : HDA-Intel - HDA Intel MID
Audio Adapter : PC-Speaker - pcsp
Audio Adapter : USB-Audio - USB Sound Device
-Input Devices-
Power Button
Lid Switch
Sleep Button
Power Button
AT Translated Set 2 keyboard
USB Sound Device
PC Speaker
Video Bus
1.3M WebCam
Acer WMI hotkeys
Acer BMA150 accelerometer
ETPS/2 Elantech Touchpad
-Printers (CUPS)-
CUPS-PDF : <i>Default</i>
-SCSI Disks-
MATSHITA DVD-RAM UJ890AS

-Version-
Kernel : Linux 3.14.56 (i686)
Version : #1 SMP PREEMPT Mon Dec 21 14:52:08 GMT 2015
C Library : GNU C Library version 2.19 (stable)
Distribution : tahrpup - 6.0.5
Desktop Environment : Unknown (Window Manager: JWM)
-Misc-
Load Average : 0.17, 0.12, 0.14

I am running Tahr in 4.1G RAM with 3.9G free.

The hard drive crashed a few days ago, so the only memory left is RAM.

I am using HTML5, no Flash Player installed. YT videos play correctly in VLC player, but I hate to have to copy and paste the URL into VLC every time.

As for changing settings in the HTML5 screen settings - do you mean in about:config or Tools, in the Puppy Tahr settings, or in the You Tube settings?

I've seen fixes for several other versions of Linux where lines of code are added and/or modified in the OS but nothing specifically for Puppy Tahr.
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 10312
Location: Charleston S.C. USA

PostPosted: Wed 13 Dec 2017, 00:40    Post subject:  

Quote:
As for changing settings in the HTML5 screen settings - do you mean in about:config or Tools, in the Puppy Tahr settings, or in the You Tube settings?

On the HTML5 viewing window is a settings icon on the lower right.
Left click on it with the video stopped to see the menu.

Try adjusting the speed and quality settings.

On old video hardware that does not have the latest features. The quality setting has a big affect on how the video plays.

I have a very old graphics hardware on one of my old computers. I have to set the quality to 360p or even lower to get good viewable play.
capture15114.jpg
 Description   
 Filesize   27.61 KB
 Viewed   358 Time(s)

capture15114.jpg


_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
DustyPixel

Joined: 27 Jun 2016
Posts: 18

PostPosted: Wed 13 Dec 2017, 03:21    Post subject:  

I tried changing the speed/quality settings as suggested and nothing helped.

The thing is, this happens in both HD and lower quality videos. I never had issues with this until I started using Linux. I initially started working with the Linux OS by using Puppy Precise, Lucid and Tahr on this computer. All had the same problem with screen tearing. It originally came with Windows 7 and that OS never had any problems playing videos smoothly, as long as i didn't go above 720p. Above that it would start to skip frames and start buffering.

I installed Lubuntu Xenial Xerus on the hard drive earlier this year. I noticed this same problem with the video and after researching online found a way to fix it by copy/pasting some code into a folder then modifying a couple of lines in it in Lubuntu. It reconfigured some of the compositing settings. Also, I was not using Flash Player in Lubuntu Xenial - the videos played fine without it.

But since the hard drive has crashed I have to use another OS and deal with it again. This was not caused by the fix - after I installed Lubuntu Xenial, it had a problem with frequent screen freezing as well as other issues before and after I fixed the video.

This computer is eight years old but can still handle regular and HD video with the right software. Is there any way to change Puppy Tahr's configuration settings to do this?

Last edited by DustyPixel on Thu 14 Dec 2017, 09:50; edited 1 time in total
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 10312
Location: Charleston S.C. USA

PostPosted: Wed 13 Dec 2017, 09:32    Post subject:  

Let's see exactly what you are using for graphics hardware.

menu>System>Pup-Sysinfo>Devices>Display>Video-info

Copy and past what it reports.

Need to know the hardware. What driver and settings it is using. This should tell me.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
Sailor Enceladus

Joined: 22 Feb 2016
Posts: 1476

PostPosted: Wed 13 Dec 2017, 15:09    Post subject:  

DustyPixel wrote:
I am using HTML5, no Flash Player installed. YT videos play correctly in VLC player, but I hate to have to copy and paste the URL into VLC every time.

So you're saying that the screen tearing happens only in the browser, not in VLC? In my experience the browser does take more CPU or GPU to play videos. I have seen screen tearing before in some games, I believe I had to use double-buffereing or adjust the vsync. I would also check in CPU Frequency Tool that you are able to hit 2GHz and not stuck at 800MHz or whatever the lowest speedstep is.

edit: I wonder of turning on or off graphics acceleration in the browser would help too
https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration#w_turning-off-hardware-acceleration
Back to top
View user's profile Send private message 
DustyPixel

Joined: 27 Jun 2016
Posts: 18

PostPosted: Wed 13 Dec 2017, 18:41    Post subject:  

bigpup:

VIDEO REPORT: tahrpup, version 6.0.5

Chip description:
VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

Requested by /etc/X11/xorg.conf:
Resolution (widthxheight, in pixels): 1366x768
Depth (bits, or planes): 24
Modules requested to be loaded: synaptics dbe

Probing Xorg startup log file (/var/log/Xorg.0.log):
Driver loaded (and currently in use): intel
Loaded modules: dbe dri2 extmod glx kbd mouse synaptics

Actual rendering on monitor:
Resolution: 1366x768 pixels (361x203 millimeters)
Depth: 24 planes

Sailor Enceladus:

Here's the result from CPU frequency tool:

Intel Pentium CPU P6100
Current Speeds (MHz) Core 0:933 1:933
Scaling driver: 'acpi-cpufreq' governor: 'ondemand'

I tried turning off the hardware acceleration - nothing changed.

Last edited by DustyPixel on Thu 14 Dec 2017, 09:43; edited 1 time in total
Back to top
View user's profile Send private message 
DustyPixel

Joined: 27 Jun 2016
Posts: 18

PostPosted: Thu 14 Dec 2017, 09:39    Post subject:  

I remembered what I did to fix this problem in Lubuntu Xenial Xerus - I installed Compton.
I installed the compton PET package from PPM and followed the same procedure as for Lubuntu.
How do I disable the current composite manager and make Compton the default?
EDIT: I haven't fixed the problem yet. Any existing display compositing has to be turned off first before this will work properly. (Hopefully!) Smile
If I type compton into terminal the message is 'Another composite manager is already running'.
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3171
Location: wales

PostPosted: Thu 14 Dec 2017, 12:47    Post subject:  

hi DustyPixel m

this might work....
create a blank file /etc/X11/xorg.conf.d/20-intel.conf
and add
Code:
Section "Device"
  Identifier  "Card0"
  Driver      "intel"
  VendorName  "INTEL Corporation"
  Option "DRI" "3"
  Option "TripleBuffer" "true"
  Option "TearFree" "true"
EndSection
and restart X

if it doesn't work it could cause X not to start, if so just delete it and X should work
Code:
rm /etc/X11/xorg.conf.d/20-intel.conf

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
DustyPixel

Joined: 27 Jun 2016
Posts: 18

PostPosted: Thu 14 Dec 2017, 13:40    Post subject:  

Hi 666philb -

This is simple enough but I must be doing something wrong. I know how to open a blank file by right clicking and how to copy/paste code but I'm having trouble with the /xorg.conf.d/20-intel.conf part.
EDIT: I should have done this in terminal. I'm brushing up on simple command line stuff like mkdir - I haven't done much of it in Puppy Linux.
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3171
Location: wales

PostPosted: Thu 14 Dec 2017, 17:21    Post subject:  

hi DustyPixel,

the mouse way is to navigate to /etc//X11/xorg.conf.d right click and choose 'new' then 'blank file' and call it '20-intel.conf'
then open the file (left click or right click & open as text ) and paste the code in and save.

or the terminal way ...
Code:
echo 'Section "Device"
  Identifier  "Card0"
  Driver      "intel"
  VendorName  "INTEL Corporation"
  Option "DRI" "3"
  Option "TripleBuffer" "true"
  Option "TearFree" "true"
EndSection' > /etc/X11/xorg.conf.d/20-intel.conf


the above worked for me on an intel graphics based PC

and the combi way ... high-lite the code above and use middle click (or both mouse buttons at once) to paste into a terminal .

write down on a some paper the path to the file ....
/etc/X11/xorg.conf.d/20-intel.conf
so you can delete it from the terminal if X doesn't start
rm /etc/X11/xorg.conf.d/20-intel.conf

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
DustyPixel

Joined: 27 Jun 2016
Posts: 18

PostPosted: Fri 15 Dec 2017, 02:17    Post subject:  

There was no xorg,conf.d folder listed so I just created one and put the file in it.
It worked!!! Very Happy
For some reason yesterday it wasn't letting me create new folders or files, and I kept getting error messages - I had been trying to get Compton to work so maybe some of the stuff I downloaded and created files for messed up some functions....
Thanks very much for your help, 666philb, and thanks to bigpup and Sailor Enceladus for your suggestions and feedback.
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 10312
Location: Charleston S.C. USA

PostPosted: Fri 15 Dec 2017, 13:04    Post subject:  

Thanks 666philb for this fix!

DustyPixel,
Thanks for sticking with finding an answer to this problem!
It should be helpful to others with hardware similar to yours.

We are Puppy.
Resistance is futile!

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
DustyPixel

Joined: 27 Jun 2016
Posts: 18

PostPosted: Fri 15 Dec 2017, 20:29    Post subject:  

No problem, bigpup. I didn't want to waste anyone elses time on this thread if I could get a program I've already used with success - Compton - to work with Tahrpup. That turned out to be a bigger hassle than I expected, so thanks again to 666philb for this simple fix. Smile

UPDATE: Earlier this morning, I shut down and rebooted Tahrpup. Since I didn't have a xorg.conf.d folder I took a shortcut and did the following:

I copied the code provided by 666philb, opened up xorg.conf, and pasted the code starting at line 152 (between #EndSection at line 150 and Section "Screen" at line 161). I then clicked save and restarted X.

This fixed the video, but I went ahead and tried 666philb's method again with a new folder, then restarted X. I didn't delete the pasted code from xorg.conf first, which skewed the results when I checked the videos again and they played correctly.

I thought that the new folder/file version of the fix worked so I shut down. Today shortly after reboot I recreated the folder/file figuring I'd still get the same result. I went to You Tube a few minutes ago. The screen tearing was back, so I tried my version of the fix again, copying and pasting the code in xorg.conf. The videos played correctly again.

I just wanted to update this and clarify what worked for me. Sorry for any confusion.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [17 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0610s ][ Queries: 14 (0.0098s) ][ GZIP on ]