Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 19 Oct 2018, 07:21
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
LegacyOS - Cannot install gtk-youtube-viewer package
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
fatguy


Joined: 25 Nov 2017
Posts: 15

PostPosted: Sat 25 Nov 2017, 17:58    Post subject:  LegacyOS - Cannot install gtk-youtube-viewer package
Subject description: Cannot install gtk-youtube-viewer package
 

Greetings,

I am trying to install the youtube-viewer application but I am not getting anywhere.


I ran the installer through ROX via right clicking the tar.gz and "installing" it, however no icon shows up anywhere indicating that it has been successfully installed, and attempting to run it via command line in terminal results in

"command not found" for both of the following entries,
gtk-youtube-viewer-3.3.1 and youtube-viewer


I found scripts for it on the system storage device and attempted to install them by hand using Perl commands to which Perl responds,

Code:

sh-3.00# perl Build.PL

Perl v5.10.0 required--this is only v5.8.4, stopped at Build.PL line 4.
BEGIN failed--compilation aborted at Build.PL line 4.




I dont know how active these forums are, but I sure hope someone can help.
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 1840
Location: lincoln, uk

PostPosted: Sat 25 Nov 2017, 18:20    Post subject:  

where is the package from? filename?

Smile
Back to top
View user's profile Send private message Visit poster's website 
fatguy


Joined: 25 Nov 2017
Posts: 15

PostPosted: Sat 25 Nov 2017, 18:28    Post subject:  

ally wrote:
where is the package from? filename?

Smile



here's the link,
http://puppylinux.org/wikka/GtkYoutubeViewer

takes one to here,
http://www.murga-linux.com/puppy/viewtopic.php?t=76835


which leads to here,
https://github.com/trizen/youtube-viewer




I am convinced that the version of Perl used in LegacyOS is not the appropriate version to install this application based off of the output errors earlier presented.



If that is the case how can I update Perl? we dont have apt-get on this.
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 1840
Location: lincoln, uk

PostPosted: Sat 25 Nov 2017, 18:58    Post subject:  

I understand that you can play youtube videos in vlc by copying the URL

somebody should confirm but I'm pretty sure that youtube viewer needs a recent copy because of changes within youtube so may be a moving target

john biles the author of legacy would have put it in if it were feasible

https://lifehacker.com/5577212/play-youtube-videos-directly-in-vlc-media-player

maybe some info here:

http://www.murga-linux.com/puppy/viewtopic.php?t=111457

Smile
Back to top
View user's profile Send private message Visit poster's website 
fatguy


Joined: 25 Nov 2017
Posts: 15

PostPosted: Sat 25 Nov 2017, 19:20    Post subject:  

I dont know if VLC still supports youtube playback. The bundled version with LOS doesn't open youtube streams. While I was formerly aware of its ability, I think that fell off later through time. I cannot confirm this however, all I can confirm is that on my end it doesnt do anything.


I still think the issue I am having is related to Perl, but cannot confirm that, either. Again I reference the output error in question,

Code:

sh-3.00# perl Build.PL

 Perl v5.10.0 required--this is only v5.8.4, stopped at Build.PL line 4.
 BEGIN failed--compilation aborted at Build.PL line 4.



Thank you for linking to the thread about LOS. I may try there if noone else tries here.







ally wrote:
I understand that you can play youtube videos in vlc by copying the URL

somebody should confirm but I'm pretty sure that youtube viewer needs a recent copy because of changes within youtube so may be a moving target

john biles the author of legacy would have put it in if it were feasible

https://lifehacker.com/5577212/play-youtube-videos-directly-in-vlc-media-player

maybe some info here:

http://www.murga-linux.com/puppy/viewtopic.php?t=111457

Smile
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 1840
Location: lincoln, uk

PostPosted: Sat 25 Nov 2017, 19:23    Post subject:  

put a question in the legacy thread, JB may watch that one

Smile
Back to top
View user's profile Send private message Visit poster's website 
ally


Joined: 19 May 2012
Posts: 1840
Location: lincoln, uk

PostPosted: Sat 25 Nov 2017, 19:29    Post subject:  

long thread but look here:

http://www.murga-linux.com/puppy/viewtopic.php?t=76835

according to the git pages you need libwww-perl

https://metacpan.org/release/libwww-perl

Smile
Back to top
View user's profile Send private message Visit poster's website 
fatguy


Joined: 25 Nov 2017
Posts: 15

PostPosted: Sat 25 Nov 2017, 21:47    Post subject:  

and thats fine, I get that dependencies need to be met,

so how to I fulfill the dependencies?

I am used to apt-get and everything being simple.


I have worked with arch (and slack variantes and a few other odd linux's) before, and can fully get things installed with a good thred post.

I need guidance. so, how do we *anything* from the bash terminal included with pup which does not have something as simple as aptitude?
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0408s ][ Queries: 11 (0.0100s) ][ GZIP on ]