Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

  New Forum: http://forum.puppylinux.com
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 12 Aug 2020, 18:58
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Moderators: Flash, JohnMurga
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 3 of 4 [46 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Author Message
Dry Falls

Joined: 16 Dec 2014
Posts: 616
Location: Upper Columbia

PostPosted: Thu 03 May 2018, 11:00    Post subject: version upgrade  

version upgrade. Maybe beta quality. Seems stable (for now)
Issues: PPM needs work, although gslapt is the prefered package manager;
rox starting to freeze up with heavy use. go to menu|Desktop|applets|RefreshDrives;
Almost gtk3 ready.

Base file got fat. now contains webkit-gtk, python, perl and qt4-lite. 291M.

Just-Lighthouse64-801.iso | md5: 57c53c29eb866a26459de1b16c0b90c6
Devx-JL64_801.sfs | md5: 05938efcb896207378e7b47fe89cf5cd
kernel_sources-4.16.5-JLx86_64.sfs | md5: 06d3404b4ff53ac1c4ec6b1106fcf324
NLS_base-JL64_801.sfs | md5: 8dfaba8e3e39bfcf0d30d3ad0ec669f3
Back to top
View user's profile Send private message 
Dry Falls

Joined: 16 Dec 2014
Posts: 616
Location: Upper Columbia

PostPosted: Sun 27 May 2018, 02:30    Post subject:  

new iso uploaded:

Just-Lighthouse64-801B2.iso 345M see opening post.

Last edited by Dry Falls on Thu 31 May 2018, 23:46; edited 1 time in total
Back to top
View user's profile Send private message 

Joined: 04 May 2012
Posts: 1352

PostPosted: Thu 31 May 2018, 17:47    Post subject:  

Dry Falls wrote:
new iso uploaded:

Just-Lighthouse64-801B2.iso 345M see opening post.
The link name says *B2, but the target file name is *B1, and so is the name+link in the opening post. I guess B2 is a typo.
Back to top
View user's profile Send private message 
Dry Falls

Joined: 16 Dec 2014
Posts: 616
Location: Upper Columbia

PostPosted: Thu 31 May 2018, 23:59    Post subject: oops  

Thanks Step! fixed link. B2 is right - now 324M
a80d7f22b354f3cc83ef5ccaa186f527 Just-Lighthouse64-801B2.iso

Edit: Oh, It was a typo. Just hadn't posted the most recent till now!

Back to top
View user's profile Send private message 

Joined: 08 May 2009
Posts: 264
Location: Utah, USA

PostPosted: Wed 27 Jun 2018, 17:05    Post subject: 64-801B2 Not working for me  

Hello Dry Falls.

I want to thank you for keeping lighthouse pup alive. It is my favorite puppy.

I downloaded this new version 801fB2 and did a frugal install. Perhaps I did the frugal install wrong,
because, I am not having a good time with it. I redownloaded it and checked the md5 to see if that was the problem, but it was not.

So maybe you could give me a walk through on a frugal install as a first step in solving my issues.

Things I seeing.

1- Xfce desktop. I like to add my own icons, but it does not allow that. I don't mind using the other desktop but I need one that I can add
icon links to without too much geekiness.

2- I cannot get most of the 801.sfs' to work. For example firefox. i had to go and find a deb for firefox. It worked, but it said it was missing
some files. Now it only works in Spot and refuses to be the default browser.

3- Could not get the libreoffice pet and others to work at all.

4- I get no sound.

I am typing this from another puppy right now. This evening I will get back in to Just lighthouse and give you more details.

I know that Just lighthouse is really for folks who are more geeky, but I would love to have it work for me.

All this could be user error. I am hoping that with a little help, I can get it going to my liking.
Back to top
View user's profile Send private message 

Joined: 27 Jun 2013
Posts: 2572
Location: In The Way

PostPosted: Thu 28 Jun 2018, 06:32    Post subject:  

Hi Dry Falls

Downloaded, and installed manual frugal and running well.

Here is some hopefully useful feedback.
I installed my Wifi-TrayNet app and connected to network perfectly!
opened browser and foud webpage using duckduckgo homepage. My laptop is 1920x1080, normally I zoom in, geany/browser, using ctrl++ or ctrl and two fingers on trackpad, but no go, could be keyboard layout, I will try others, mine is GB. I also use pinch to zoom on touchscreen, in browser, geany and image viewers, no go.

I was editing a script, which gained full executable permissions, I was not able to change permissions using the properties gui nor in term.

On shutdown I created save file using simple encryption, it seemed to complete, but it didn't ask for password and no file was created, in sdb2 (ext).

I will have a play around, see what I can find!

Back to top
View user's profile Send private message MSN Messenger 

Joined: 18 Mar 2014
Posts: 9

PostPosted: Fri 29 Jun 2018, 17:11    Post subject: LH64-801
Subject description: full install fails

Hello Dry Falls.

how to get a full install on LightHouse64-801? the live CD runs
fine (well, no trackpad and cannot read the sd card slot) but the
full install fails misserably. the install runs, and i get a few
files copied to the partition. my grub2 menu boots it into a kernel
panic. even a frugal install on my Acer VX 15 fails. any ideas?

here is the inxi report...

System: Host: Mariner18014 Kernel: 4.16.8 x86_64
____(64 bit gcc: 7.3.0) Desktop: Openbox 3.6.1
____Distro: Just-Lighthouse64 Linux Linux 4.16.8 [ arch]
Machine: System: Acer (portable) product: Aspire VX5-591G v: V1.03
____Mobo: KBL model: Wish_KLS v: V1.03 Bios:
____Insyde v: V1.03 date: 01/26/2017
Battery BAT1: charge: 42.9 Wh 95.6% condition: 44.9/46.0 Wh (97%)
____model: COMPAL PABAS0241231 status: Discharging
CPU: Quad core Intel Core i7-7700HQ (-HT-MCP-) cache: 6144 KB
____flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx)
____bmips: 22464 clock speeds: max: 3800 MHz 1: 1306 MHz
____2: 3167 MHz 3: 3189 MHz 4: 2953 MHz 5: 3215 MHz
____6: 3307 MHz 7: 3290 MHz 8: 3169 MHz
Graphics: Card-1: Intel Device 591b bus-ID: 00:02.0
____Card-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile]
____bus-ID: 01:00.0
____Display Server: X.org 1.20.0 drivers: nouveau,intel
____(unloaded: nv,vesa) tty size: 124x24
____Advanced Data: N/A for root
Audio: Card Intel CM238 HD Audio Controller driver: snd_hda_intel
____bus-ID: 00:1f.3 Sound: ALSA v: k4.16.8
Network: Card-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network
____Adapter driver: ath10k_pci bus-ID: 02:00.0
____IF: N/A state: N/A mac: N/A
____Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit
____Ethernet Controller
____driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 03:00.0
____IF: enp3s0 state: down mac: <filter>
Drives: HDD Total Size: 516.2GB (5.4% used) ID-1:
____/dev/sda model: HFS512G39TND size: 512.1GB
____ID-2: USB /dev/sdb model: USB_Flash_Drive size: 4.1GB
Partition: ID-1: swap-1 size: 16.78GB used: 0.00GB (0%)
____fs: swap dev: /dev/sda5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 40.0C mobo: N/A gpu: 38.0
____Fan Speeds (in rpm): cpu: N/A
Info: Processes: 193 Uptime: 7 min Memory: 347.3/15906.8MB
____Init: SysVinit runlevel: 5 Gcc sys: N/A
____Client: Shell (bash 4.4.191) inxi: 2.3.0

ubuntu 18.04 installed and runs fine on my hardware (after i loaded
the nvidia drivers cause it could not even shutdown without it). i
tried bionicDog64 (based on 18.04) and it has simmilar challenges
on frugal and full install on my hardware.

i have always run puppies on old hardware. this year i treated
myself to a new machine - the cheapest gaming i7-7700 i could find
- and i cannot get a puppy to run :( xenial64_7.5 does run but i
have not been able to get the track pad or sd reader working.

puppy with jwm and rox has been my development system since 2009.
i cannot even think of doing it any other way. thanks "Dry Falls"
and to everybody who has ever had a hand in puppy creation. i love
Back to top
View user's profile Send private message 
Dry Falls

Joined: 16 Dec 2014
Posts: 616
Location: Upper Columbia

PostPosted: Thu 05 Jul 2018, 00:21    Post subject:  

Sorry to have taken so long to answer these.

@Pete (& TWIMC): Thanks for sticking with my project! I've had no problems using or making new frugal save-file installs. In fact, it seems to me better at finding the base sfs and save files than ever. Of course, I use grub2 and have no access to a 64bit legacy boot machine. It does work in qemu but that is no test for booting a save file. I'm assuming the problem you experience must be related to the isolinux.cfg. It probably needs tweaked. Remember that the install must be in the top of the partition or no more than One directory deep! If it is a usb partition, make sure the append line contains "pmedia=usbflash" and NOT "cd".

There is a section on boot parameters in Lighthouse faqs.

In xfce desktop, I've no problem changing the icon theme from the xfce-settings application (to an installed icon theme). However, there seems no option to change individual icons like there is in kde except for *.desktop files which can be edited.

Firefox is a whoops on my part (bad symlink in the sfs) fix it with
rm -f /usr/bin/firefox
sleep .5
ln -s /usr/lib64/firefox/firefox /usr/bin/firefox

What other sfs files have you had a problem with? The directory structure is basically unchanged since Tazoc created Lighthouse, which means most pets for woofCE puppies won't work in lighthouse without some editing. Always check the lighthouse repo first and slackware second. Also advise using *.txz packages and right-click 'install-txz' instead of petget. (It's on my todo list to change the default for .txz in mime-types)

On the topic of browsers, as has been the case for as long as I've been involved with lighthouse, browsers accessed from the menu run as spot. Root is accessed from wbar or the terminal. You can also edit the .desktop file in /usr/share/applications.

The easiest frugal install is manual. If it is to usb media, 'pmedia=usbflash' (or usbssd) is essential. Otherwise, open the drive/partition you want to use with rox-filer and drag the base, initrd.xz and vmlinuz files there and edit your pre-existing boot menu accordingly. Even more sure-fire is to install to a directory with the psubdir=myuniquefoldername. Extra sfs files can be located in that folder or on the top of the partition.

I've fixed the sound issues with
chmod -x /etc/rc.d/rc.alsa
. It was confusing pulse, which handles sound. Make adjustments with Pulse-audio volume control from the menu or 'Sound' from wizardwizard (setup) or right-click the speaker tray-icon (left-click in xfce).

@Stemsee: Greetings. Surf browser zoom-in is <control shift k> and out is <control shift j>. Keyboard shortcuts are found in /usr/share/doc/surf/surf.1 (also in the man directory). A location bar of sorts (dmenu) is called up with <control g>. Terminal is probably the easiest. Wbar "Surf" icon runs it as root. Surf is not multiuser friendly (spot can't download anything).

Can't replicate the permissions problem you described. Not sure what's up with that.

The encrypted save-file is something I've never played with, but I remember hearing it is restricted to ext2. Even so, the code is partially in both the init script and rc.shutdown and is untouched from the original. It may be broken since gcrypt has been upgraded several times since.

Thanks for testing. Soon I'll have an updated version uploaded with new sfs files. Having some problems with the devx since the gcc-8.1.1 upgrade.

@chrabak: Lighthouse is meant to run in ram. A full install is not recommended. The closest option which is supported is pupmode 6 (save to partiition). If you still want a full install, there is a good help file in the fatdog faqs, although I don't think they support it. I think you could make an install to partition and then delete the initrd folder. Unsquash the base sfs there and the system might read it as a full install, but I wouldn't count on it.

I think you've already discovered one issue: nvidia.

Below is a package (getnvidia) for lighthouse (click to unzip). It's built into the next release.

edit: Yes, encrypted pupsave is broken. Errors seem to point to losetup. fails to mount.
Description  click to unzip

Filename  getnvidia-1.0-64.txz.gz 
Filesize  96.45 KB 
Downloaded  158 Time(s) 
Back to top
View user's profile Send private message 

Joined: 01 Aug 2018
Posts: 1

PostPosted: Wed 01 Aug 2018, 15:10    Post subject:  

Just stopped in to say thanks man. I've always loved Puppy but what you've done with Tazoc's gift to the Linux universe, was to make it best of breed.

I'm kind of a Linux novice but I tossed JL on a USB stick and plugged it in to a Winmate tough book clone I got from work, and pretty much everything just worked. Drives, Ethernet, WiFi, touch pad, hell, even the touch screen was calibrated.

I'm sure there are issues that my novice rear hasn't noticed yet , but If I could only have one pup, it would easily be this one. Keep up the great work brudda, because like Michael Angelo, this distro really is a Puppy masterpiece.
Back to top
View user's profile Send private message 

Joined: 04 May 2012
Posts: 1352

PostPosted: Fri 03 Aug 2018, 07:16    Post subject:  

Hi Dry Falls,

error 404 for the devx and kernel sources links in this post of yours http://www.murga-linux.com/puppy/viewtopic.php?p=990616#990616.

Back to top
View user's profile Send private message 

Joined: 19 May 2012
Posts: 1983
Location: lincoln, uk

PostPosted: Fri 03 Aug 2018, 07:41    Post subject:  



Back to top
View user's profile Send private message Visit poster's website 
Dry Falls

Joined: 16 Dec 2014
Posts: 616
Location: Upper Columbia

PostPosted: Sat 11 Aug 2018, 01:20    Post subject:  

Thanks all. Been a bit under the weather lately and fighting with gdrive and my isp. got an iso up yesterday and finally some sfs files. One should really start a new save file with this one or run in ram.

Just-Lighthouse64-801B3.iso with 3_dev_801.sfs (python, perl, gcc etc) and webkitgtk3-x86_64-JL64-2.sfs (with midori & surf).
md5 checksum: 6901cf8ccddbdbe941c6c8f6666a3140

These are (so far) uploaded:

And two browsers at the opposite extremes (I myself use neither):

Back to top
View user's profile Send private message 

Joined: 29 Jul 2016
Posts: 1141

PostPosted: Sat 11 Aug 2018, 15:17    Post subject: little first report  

Hello Dry Falls
I had just installed version 801B2 yesterday. LOL
Good idea to build with slackware current. This is the second one that does that, the other one being LxPupSc from peebee. It's also the reason it got my attention.
I've read something that Patrick Volkerding is preparing slackware 15 now.

Anyway. You've made a very beautiful Spup! I have it installed on a fairly new i5 laptop next to windons10 and win10 looks very shabby Very Happy JLH is perfect for this new laptop!
I am a bit surprised that it does not come with a big browser by default. Firefox would be my choice.

I had some trouble with wifi.
First I had to add iwlwifi-7265D-26.ucode to /lib/firmware/ . I have to do that in almost all Puppies, no problem.
But then SNS and frisbee did not manage to connect. Dougal did, but on reboot connection takes about 2 minutes.
I had similar problems on this machine with earlier Puppies, but rerwin has been looking into it and recent woofCE builds give good wifi connection for me now with SNS.
I think these improvements from woofCE did not get into JLH yet?
That makes me wonder how you make this build.
Oh, and I had to think of putting up the firewall myself after setting up the wifi connection.

I also noticed that a pupsave directory is not possible.

I will be looking around in JLH to dicover what is in it and report. At first site it looks like quite a rich distro according to Puppy's standards.
Back to top
View user's profile Send private message 
Dry Falls

Joined: 16 Dec 2014
Posts: 616
Location: Upper Columbia

PostPosted: Sun 12 Aug 2018, 04:47    Post subject:  

Hi foxpup, and thanks for testing. The most recent version has a bit different kernel configuration for wifi and slightly different firmwre package. There is a firmware sfs at gdrive, but I've yet to be able to upload the latest sfs which is from July 29. It includes proprietary realtek firmware from arch linux instead of the stock linux versions. iwlwifi-7265D-10.ucode is included in the build as is. Glad to hear you got wifi working.

The default frisbee is from Jemima as edited by Tazoc (along with rc.network. It's worked pretty consistently for my box (wired eth) and a borrowed laptop (wifi). You can switch to rerwin's frisbee with boot manager (uncheck Frisbee and check frisbee.sh) - rc.network should accomodate either. That package is from 2017. Running wifi, there is a wifi-keep-alive which also should be enabled (in /etc/init.d).

In theory, dhcp and wpa/ifplug should connect at startup and the default connection manager kick in if those fail. I think only fatdog has got the wpa-gui working correctly (and automatically).

But lighthouse is not a woofCE build nor a dog. It has grown steadily from the original woof (puppy 400 series, I think). PPM is a bit of a morph and I've got it to work somewhat, but I don't recommend using it. JL64 is built to accomodate slapt-get/gslapt for slackware package management and lighthouse update for sfs files.

On a side note, Stemsee's wifi-tray sfs works as-is under lighthouse and is, I think quite matured. I do recommend it.

Lighthouse has pupmode6 which is save-to-partition. I've yet to see an advantage to save-to-directory, and to change the init script to accomodate it will break certain other functions unique to lighthouse. This is not to say there is no compatibility with woofCE - I've borrowed quite a bit from them. Just be advised it's sometimes hit or miss.

I've always wanted to have a build script for lighthouse, but my skill level for such things is still in its infancy. I can say that the init script by Tazoc is 99% of the os and JL64 is still full of his scripts and modifications. They are also interconnected so express an ecology of sorts.


ps, The idea on browsers is that the iso has the means to download the browser of your choice. It includes midori as a light starter. I have to keep the iso as small as I can because of isp quota constraints and google intolerance of satelite connections. There is likewise no word processor program but they are available from the repo.
Description  click to unzip Stemsee's package

Filename  Wifi-TrayNet_v4.3.sfs.gz 
Filesize  144.58 KB 
Downloaded  133 Time(s) 
Back to top
View user's profile Send private message 
Dry Falls

Joined: 16 Dec 2014
Posts: 616
Location: Upper Columbia

PostPosted: Sun 02 Sep 2018, 14:12    Post subject:  

delta-tar.gz slackware64-current updates & bugfixes

tarbil with delta file. upgrade iso to Just-Lighthouse64-801B4. check sfs-update or gdrive repo (see opening post) for new sfs files. 84M
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 4 [46 Posts]   Goto page: Previous 1, 2, 3, 4 Next
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0977s ][ Queries: 13 (0.0345s) ][ GZIP on ]