Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 16 Dec 2017, 06:51
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Lecteurs multimédia mpv-0.14 et mpv-0.27 pour xenialPup-7
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message
musher0


Joined: 04 Jan 2009
Posts: 11280
Location: Gatineau (Qc), Canada

PostPosted: Sat 11 Nov 2017, 01:58    Post subject:  Lecteurs multimédia mpv-0.14 et mpv-0.27 pour xenialPup-7  

Pour la version 0.27 voir trois messages plus bas, ici :
http://murga-linux.com/puppy/viewtopic.php?p=974099&sort=lastpost#974099


~~~~~~~~~~~~~~~~~~~~~~~~
Bonsoir à toutes et à tous.

xenialPup-7
http://augras.eu/puppy_linux/?dir=musher0/xenialPup-706-k41/distro
a une toute nouvelle application mpv, mpv-0.14, assemblée à partir des dépôts
ubuntu, à
http://augras.eu/puppy_linux/?dir=musher0/xenialPup-706-k41/Multim%C3%A9dias

J'ai dû le faire parce que 1) mpv est un excellent lecteur et que 2) la version
(caduque, d'ailleurs) pour Precise a été retirée de notre dépôt à ibiblio. En d'autres
mots, nous Puppyistes n'avions plus cet excellent lecteur média à notre disposition.

Ce n'est ni une archive pet, ni une sfs. C'est un zip contenant des fichiers deb...
Je vois vos visages s'allonger ! Smile

Désolé de bousculer ainsi les habitudes, mais pourquoi déballer les archives deb
pour les ré-emballer sous forme d'archives pet alors que petget et un script adapté
peuvent faire le boulot.

S'il y a une demande, j'assemblerai ce paquet sous forme d'archive sfs.

Comment faire : En bref,
-- téléchargez le zip ci-dessus dans un endroit commode et sûr.
-- Dézippez-le.
-- Un répertoire nommé < mpv-xenialPup7-install/ > sera créé.
-- Entrez dedans ce répertoire.
-- Rendez le script < installe-mpv-pr-xenialPup.sh > exécutable à l'aide de la
commande
Code:
chmod +x installe-mpv-pr-xenialPup.sh
-- Puis lancez ce script.

Pour ne pas encourager la paresse, le script ne lance pas mpv à votre place ! Wink

Veuillez lire l'extrait suivant du script si vous avez besoin de plus d'info.
Quote:
#!/bin/sh
# $PWD/installe-mpv-pr-xenialPup.sh
#
##################
# Français (English follows)
#
# Objectif : installer le lecteur de médias mpv et les biblios
# nécessaires à son fonctionnement sur le Puppy dit « xenialPup ».
#
# Prérequis : le fichier « liste ». # (Devrait être joint. Vérifiez ! Smile )
#
# Mode d'emploi --
# Ouvrez une console dans le répertoire où vous avez déballé l'archive
# et tapez, sans les chevrons : < installe-mpv-pr-xenialPup.sh >.
#
# L'installateur habituel de Puppy apparaîtra pour chaque archive.
# Répondez à ses invites avec votre curseur, comme d'habitude.
#
# Le présent script installe aussi un fichier desktop supplémentaire
# permettant une entrée dans le menu, et les icônes et le script
# correspondants.
#
##################
# NOTE --
# Les archives *.deb ci-jointes, énumérées dans le fichier « liste »,
# proviennent du site pkgs.org, qui référence vers les dépôts ubuntu.
#
# Par exemple, la biblio « » libguess » :
# http://archive.ubuntu.com/ubuntu/pool/universe/r/
# rubberband/librubberband2v5_1.8.1-6ubuntu2_i386.deb
# (Concaténer les deux lignes précédentes pour recréer l'URL.)
#
# Semblablement pour les autres archives.(,,,)
#
# musher0, 10 nov. 2017. GPL3
####(...)
Le zip comprend aussi une page de forum sur le lancement de films sur dvd
Code:
mpv dvd://
et un extrait de la page man de mpv, de:
https://unix.stackexchange.com/questions/265874/using-mpv-to-play-dvd-movies
(Pour changer de langue une fois le film chargé dans mpv, taper sur le dièse [ # ].)

À la bonne vôtre.
mpv-xenialPup7.jpg
 Description   
 Filesize   203.98 KB
 Viewed   139 Time(s)

mpv-xenialPup7.jpg


_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)

Last edited by musher0 on Sun 12 Nov 2017, 10:07; edited 2 times in total
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 11280
Location: Gatineau (Qc), Canada

PostPosted: Sat 11 Nov 2017, 06:44    Post subject:  

À toute personne qui contestera que cette version soit la dernière disponible :

Certes mpv est rendu à la v. 0.27 chez github.

Mais pour xenial, dans le dépôt ubuntu, au moment d'écrire ces lignes, on a
effectivement seulement la version 0.14 de disponible. Voir ici :
https://pkgs.org/download/mpv. Je joins en outre une image de cette page,
relevée aujourd'hui cinq minutes avant l'heure d'enregistrement de ce message.

Si, chère personne qui contestez que la version 0.14 soit la dernière disponible
pour xenial, vous voulez vous risquer à compiler la version 0.27 à partir de zéro
au profit des Puppy-istes, vous êtes la bienvenue, et je vous souhaite la meilleure
des chances.

Bien à vous.
mpv-dispo-pour-xenial.jpg
Description 
jpg

 Download 
Filename  mpv-dispo-pour-xenial.jpg 
Filesize  219.05 KB 
Downloaded  14 Time(s) 

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
hamoudoudou


Joined: 24 Jul 2014
Posts: 235
Location: rabat

PostPosted: Sat 11 Nov 2017, 12:02    Post subject: MP3 et MP4 sont testés OK  

la version mpv-0.1.4 testée sur Artfulpup. la version 0.14 fonctionne très bien. DVD sous la main sont vus et revus, pas à moi d'ailleurs, un western et 2 DVDs films enfants. Pas de DVD récents à tester donc, bluetooth pas prevu.

MP3 et MP4 sont testés OK
Par contre le PPM Artfulpup en est bien a la version 0.26 (72MB décompressée) , pas essayée. Présentation minimaliste qui pèse plus lourd que Gnome-mPlayer !
PS la 26 fonctionne sur Artfulpup. Mais avec ces libavcodecs qui changent constamment. La version 0.14 ira partout.
Ubuntu : Il y a quatre dépôts principaux, mais pas que. Le dépôt officiel devient miséreux,
La version Ubuntu avril 2018 sera LTS et intégrera mpv nouvelle version, peut-être. Zesty et Artful l'intégraient, mais ce sont des seasonal releases, ephémères donc.
mpv c'est pour se faire plaisir en utilisant des logiciels minimalistes pour se rappeler le temps de nos 20 ans. Un peu masochiste, nostalgique beaucoup. Les DVDs sont encors une Idée de Cadeau, mais les famillles souvent visionnent les films en ligne, pour 5 euros. ou moins.
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 11280
Location: Gatineau (Qc), Canada

PostPosted: Sun 12 Nov 2017, 10:05    Post subject:
Subject description: mpv-0.27 sous forme de sfs
 

Rebonjour, les amateurs de films et de musique !

Je vous apporte ce matin mpv-0.27, sous forme de sfs. Ici :
http://augras.eu/puppy_linux/?dir=musher0/xenialPup-706-k41/Multim%C3%A9dias

C'est certainement une version bêta. Elle fonctionne bien chez moi, avec divers
pupsaves, sous icewm et sous echinus, et dans des environnements linguistiques
anglais et français.

À vous de me dire, maintenant, si elle fonctionne chez vous !

Un détail important : après avoir chargé le sfs, on doit utiliser le script
ci-joint. Ce script établit trois liens symboliques importatns, deux pour le
« libcrypto » d'openssl, et un pour le « navigateur » de menus dvd.
Code:
#!/bin/sh
# complement_mpv-0.27_sfs.sh
# (c) musher0, 12 nov. 2017. GPL3
####
cd /usr/lib

ln -r -s -f libcrypto.so.1.1.0f /lib/libcrypto.so.10
ln -s -f libcrypto.so.1.1.0f libcrypto.so.10

rm -f /usr/lib/libdvdnav.so.4
ln -s -f libdvdnav.so.4.1.2 libdvdnav.so.4

sleep 0.5s
Joint zippé. (Déballer dans /root/my-applications/bin, rendre exécutable et exécuter.)

Ces liens sont dans le sfs, mais ils refusent de faire leur job. Si quelqu'un peut
m'expliquer pourquoi, je lui paye une bière virtuelle ! Donc il faut utiliser ce script.

En passant, puisque ce mpv-0.27 fonctionne sur xenialPup, il devrait fonctionner
sur des Puppys ayant une version glibc égale ou supérieure à 2.23.

J'attends de vos nouvelles avant de publier la version définitive de ce paquet.

Merci d'avance.
mpv-Coeur_regulier-799x449.jpg
 Description   Isabelle Carré dans une scène au début du film. Synopsis à http://www.allocine.fr/film/fichefilm_gen_cfilm=235700.html
 Filesize   120.11 KB
 Viewed   52 Time(s)

mpv-Coeur_regulier-799x449.jpg

complement_mpv-0.27_sfs.sh.zip
Description 
zip

 Download 
Filename  complement_mpv-0.27_sfs.sh.zip 
Filesize  360 Bytes 
Downloaded  11 Time(s) 

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0400s ][ Queries: 14 (0.0053s) ][ GZIP on ]