Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 21 Nov 2017, 02:27
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Krack krack
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [1 Post]  
Author Message
fabrice_035

Joined: 28 Apr 2014
Posts: 433

PostPosted: Tue 17 Oct 2017, 11:51    Post subject:  Krack krack
Subject description: du bazard à s'y retrouver
 

Salut,
A propos de la faille découverte dans WPA2, je ne sais si vous avez essayé de trouver un patch, moi oui et malheureusement on s'y perd dans toutes ces distributions Evil or Very Mad sous Linux.

Et pour ajouter à la difficulté, j'ai lu que pour vérifier la version de wpa_supplicant il suffit de faire un

Code:

root# wpa_supplicant -v
wpa_supplicant v2.1
Copyright (c) 2003-2014, Jouni Malinen <j@w1.fi> and contributors


Si je vais sur le site d'ubuntu, ici https://launchpad.net/~ubuntu-security-proposed/+archive/ubuntu/ppa/+build/13583529 et que je prends la dernière version (elle date du 16 oct. 2017) et que je vérifie la version après décompressée l'archive

Code:

root# echo $PWD
/root/Downloads/wpasupplicant_2.1-0ubuntu1.5_i386.deb.extracted/sbin
root# ./wpa_supplicant -v
wpa_supplicant v2.1
Copyright (c) 2003-2014, Jouni Malinen <j@w1.fi> and contributors


Bravo hein... on voit de suite la différence Shocked Confused Confused

Alors je fonctionne avec une Tahrpup 6.0.6, j'ai donc récupéré (un peu au bonheur la chance)

https://launchpad.net/ubuntu/+archive/primary/+files/wpa_2.1-0ubuntu1.5.debian.tar.gz

Code:

Uploaded by:
    Marc Deslauriers on 2017-10-16

wpa_2.1-0ubuntu1.5.debian.tar.gz    105.8 KiB    718bd00293e9e67a98f63bb8ff77346fb21041216bc721926489fae0475a7a6e


Extraction de l'archive, lecture du README, il est dit qu'il faut faire un
Code:
cp defconfig .config

...et un
Code:
make


Après la compilation, ça donne
Code:

root# ./wpa_supplicant -v
wpa_supplicant v2.4
Copyright (c) 2003-2015, Jouni Malinen <j@w1.fi> and contributors


J'ai copié wpa_supplicant et wpa_cli dans le dossier /sbin (après avoir renommé les fichiers d'origine), essai de connexion ok.

Bon je pense que c'est une version patchée, dommage qu'il n'est pas possible de la savoir Sad

Si vous avez des commentaires, je suis preneur Smile
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [1 Post]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0285s ][ Queries: 13 (0.0050s) ][ GZIP on ]