Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 12 Dec 2017, 23:56
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Barry's Easy Linux 4.0 + XFCE
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message
belham2

Joined: 15 Aug 2016
Posts: 1355

PostPosted: Mon 18 Sep 2017, 14:13    Post subject:  Barry's Easy Linux 4.0 + XFCE  

Well, never thought I'd say the above in the same sentence, lol. One of Barry's newer creations and XFCE? No way Shocked Anyhow, got it to work (the pics are below) and can find no hiccups with it after using it quite a bit these past 2 days. All I can say is this: dam#, Battleshooter, chuffed is off the table and serious accolades are due!! Wink
Barry's-EasyLinux-4.0-with-XFCE.png
 Description   
 Filesize   167.15 KB
 Viewed   632 Time(s)

Barry's-EasyLinux-4.0-with-XFCE.png

Screenshot.png
 Description   
 Filesize   158.46 KB
 Viewed   626 Time(s)

Screenshot.png

Screenshot(1).png
 Description   
 Filesize   195.41 KB
 Viewed   626 Time(s)

Screenshot(1).png

Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 8345
Location: Perth, Western Australia

PostPosted: Mon 18 Sep 2017, 21:50    Post subject:  

Looks nice, very interesting that you are using it without any gotchas!

Did you install XFCE from Ubuntu DEBs, or compile it?

Hey, it would be great, but Easy has not yet reached version 4.0! Only 0.4

_________________
http://barryk.org/news/
Back to top
View user's profile Send private message Visit poster's website 
belham2

Joined: 15 Aug 2016
Posts: 1355

PostPosted: Tue 19 Sep 2017, 06:42    Post subject:  

BarryK wrote:
Looks nice, very interesting that you are using it without any gotchas!

Did you install XFCE from Ubuntu DEBs, or compile it?

Hey, it would be great, but Easy has not yet reached version 4.0! Only 0.4



Hi Barry,

Me, compile a DE like XFCE? Are you crazy (j/k ya Wink ). Seriously, though, that's a bit above my pay grade. What I did do was take one of my Easy 'frugal' installs, after I did everything I wanted to that frugal install, and added Battleshooter's new xfce-pet (on v4 now):

http://www.murga-linux.com/puppy/viewtopic.php?t=111458

Since he did it for phil's Xenial64, I thought to myself, well heck Barry is using Ubuntu in Easy, so give it a go. At first, after installing the pet, the screen went all crazy, then came back like it was dead, but yet a terminal worked. I just logged out, and logged back in, and I was greeted with the pics as I showed in the previous post.

With XFCE installed, I have been through a lot of stuff, program-wise and file manager-wise and adding more stuff throughout (why in the heck didn't you include "grub4dosconfig" in Easy"---it's a pain in the butt to install, lol, and i use it all the time setting up usb/sdcards/etc/)----anyway, I haven't come across any real gotchas yet. Only thing is the shutdown gui, is still a bit buggy (using terminal works fine, though), but this shutdown problem existed in Xenial and Battleshooter's almost got it fixed.

So, that's it!! I'm sure I'll come across something---haven't been brave enough to use PPM and actually install something from it (always go to the source, and then do everything via terminal, safer to me in case I goof something up).

I'll keep at it and see how it works---but it honestly took everything, and I mean everything, that was in the Easy Menu and transferred it to XFCE Menu (I know rg66 helping out with Battleshooter has something to do with this working so good now). And stuff just launches and runs.




P.S. Not sure if you're aware, or maybe you are, but there's a problem with the Containers & using Seamonkey-----it just displays bad behavior when you are having to login to any site. It will randomly and at any moment wipe your login while logged in, or it will cause login,php handling at the moment of logging-in to go quirky, and/or a few other things (uploading pics, hitting back arrow in Seamonkey---all things that cause Seamonkey in a Container to just not work correctly. Heck, it was so bad 3 days ago that i thought the murga-forum login had been hacked, then i realized this morning that it was really the Containers. This occurs in original 'frugal' installs of Easy (no XFCE or anything else).
Also, another issue, trying to run the remaster from a 'frugal" Easy install---fails every time. After you set things up, configure boot-specs and all, you'll get this message every boot:


Code:
cp: can't stat /q_ro/q.sfs/etc/DISTRO_SPECS:  No such file or directory
/init: .: line 235: can't open '/q_ro/q_sfs/etc/DISTRO_SPECS'


Looked and realized when you remaster from a running 'frugal' install that you've already setup, the remaster script takes the ".../etc/...." above and DOES NOT rename it to "..../er-etc that is required because remastering sets it up that way. Even if I rename etc to er-etc in the init script, which I did, boot still fails at near same point.
Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1368
Location: Australia

PostPosted: Wed 20 Sep 2017, 08:55    Post subject: Re: Barry's Easy Linux 4.0 + XFCE  

belham2 wrote:
Well, never thought I'd say the above in the same sentence, lol. One of Barry's newer creations and XFCE? No way Shocked Anyhow, got it to work (the pics are below) and can find no hiccups with it after using it quite a bit these past 2 days. All I can say is this: dam#, Battleshooter, chuffed is off the table and serious accolades are due!! Wink


Wow Belham, thank you for the accolades Very Happy

I think I'm just as surprised it's working here as you are Laughing

One thing I can see from the screenshots, it looks like the GTK theme isn't working, I think maybe one of the GTK engines Numix depends on isn't included in Easy. Should be resolved by just picking a different GTK theme or installing the missing engine I think.

BarryK wrote:
Did you install XFCE from Ubuntu DEBs, or compile it?


Compiled it all using the LFS scripts bossman, except GVFS which was just downloaded from the PPM.

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0399s ][ Queries: 12 (0.0045s) ][ GZIP on ]