Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 17 Aug 2019, 23:28
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Create Debian 9 (Stretch) minimal ISO similar to DebianDog
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 95 of 99 [1477 Posts]   Goto page: Previous 1, 2, 3, ..., 93, 94, 95, 96, 97, 98, 99 Next
Author Message
rijsmier

Joined: 12 Oct 2017
Posts: 9
Location: Harties, South Africa

PostPosted: Thu 22 Nov 2018, 10:27    Post subject:  

Sorry for the delay, had other things to do.


@rcrsn51

Thank you for your reply - but I could not get peasywifi to work.


@fred

Thank you, your frisbee-2018 version works correctly.


*But* I had to go straight into your github Included file to get it. Neither apt-get install or synaptic could find frisbee-2018 - after update or reload.

What I see in synaptic (Origin) is testing/Unknown and testing/main for fredx181.github.io . So it looks to me as if your Included file is not being looked into where frisbee-2018 is.

synaptic reports frisbee-2018 as the installed version and frisbee-2017 as the latest version.

All the above applies to DDog and ObDog for both the Stretch and Devuan builds.

-----------------------------------------

On another subject. I had a look at ceni and it works perfectly for usb tethering. Unfortunately it pulls in a lot of other files.
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4017
Location: holland

PostPosted: Thu 22 Nov 2018, 14:17    Post subject:  

rijsmier wrote:
Thank you, your frisbee-2018 version works correctly.

*But* I had to go straight into your github Included file to get it. Neither apt-get install or synaptic could find frisbee-2018 - after update or reload.


Glad it works for you now.

Yes, that's right, I assumed 2018 version would be seen as newest but obviously not.
Made it now version 1.2-20181120-dd and it shows as upgradable in Synaptic.
(for you it makes no difference because the package is exactly the same as you have now installed)

Thanks for reporting.

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
wiak

Joined: 11 Dec 2007
Posts: 1567
Location: not Bulgaria

PostPosted: Fri 23 Nov 2018, 20:17    Post subject:  

Doglover wrote:
Woefully audio doesn't work in youtube. Audacious works fine. My laptop likes pulseaudio, so I installed all I could find, but pulse still doesn't work. Won't connect to server. Arrrggggg!


Hi Fred,

I'm coming back to this old post despite pulseaudio working fine for me on my XenialDog64 system with pulseaudio --start (despite a root user warning message).

On some other systems, for example, BionicPup64, I found a /etc/pulse/default.pa configuration issue that was preventing pulseaudio daemon starting up (resulting in a E: error message). Details here:

http://murga-linux.com/puppy/viewtopic.php?p=1011109#1011109

Note that the above 'fix' is probably just for systems that don't have console-kit installed or installed correctly. I haven't tested that. As I say, I don't need any of the above on XenialDog64 or BionicDog64; on these systems module-console-kit seems to load just fine anyway.

wiak
Back to top
View user's profile Send private message 
belham2

Joined: 15 Aug 2016
Posts: 1667

PostPosted: Sat 24 Nov 2018, 08:06    Post subject:  

Hi Fred & all,

Family member just ran into this updating my Deb 9 (Stretch) build.....never had a problem before using Synaptic to update everything. This is a first. Here's a pic, of the update using terminal, to show what the problem is, occurred on trying to update chromium (which always worked no problems before):
chromium70-update-fail-2018-11-24.jpg
 Description   
 Filesize   169.69 KB
 Viewed   687 Time(s)

chromium70-update-fail-2018-11-24.jpg

Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4017
Location: holland

PostPosted: Sat 24 Nov 2018, 18:47    Post subject:  

Hey Belham,

Sorry, I can't reproduce your issue, tried by first installing chromium 69, reboot with save and then install v70, no problem for me.

Did a web search for: dpkg "unable to make backup link of" , not much info (and I can't test), maybe you can try ?

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
belham2

Joined: 15 Aug 2016
Posts: 1667

PostPosted: Sun 25 Nov 2018, 06:58    Post subject:  

fredx181 wrote:
Hey Belham,

Sorry, I can't reproduce your issue, tried by first installing chromium 69, reboot with save and then install v70, no problem for me.

Did a web search for: dpkg "unable to make backup link of" , not much info (and I can't test), maybe you can try ?

Fred



Hi Fred,

Thanks for trying. This one had and has me stumped.

Since I run everything as frugal with Porteus boot, and that I always keep back ups from when the build was pristine, I tried the following:

So, brand new frugal folder, set the menu.lst entry with the normal porteus entries I've always used, and started her up.

Opened Synaptic, all set all updates, and purposely forbid Chromium to update. And everything worked like a charm. The Stretch64 build brought everything up to date.

Then, I installed Chromium 69 (like you), which went well and it runs like crazy, real good.

Then opened Synaptic, hit "refresh", then "mark all upgrades", and the only upgrade was to Chromium 70.

And sure enough, the exact same dpkg:error message showed up.

Me thinks it is something in the debian repo and/or how they packaged Chromium 70. I can't figure out what else it would be.

Anyhow, just ditched Chromium, and installed the latest Google Chrome, and, weirdly, all is good now (or at least I think, haha Wink ). I just added Google's PPA and gpg key, so the updates will happen automatically now from Synaptic.


Hope you are doing well, Fred, and in good health. They're saying we're (Benelux) are gonna get creamed this winter in terms of possible record cold temperatures along lack of precipitation.

Dang, after this very dry (low rain), high temp past summer, which nearly killed my garden and all my neighbors gardens, now we are supposed to get hit with a dry, brutally cold winter???

This is not gonna be fun! Who knew water (or lack of it, for gardens and drinking) would become such a huge issue to two countries like ours that are right beside the oceans! Incredible. I bet Denmark and Lux is gonna get hit too, maybe most of northern Germany.....hope so, misery always needs company (lol).

Be safe and good, and have a Happy Holidays (if I forget to come on here and say so Smile )
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4017
Location: holland

PostPosted: Mon 10 Dec 2018, 08:21    Post subject:  

Some updated (custom) deb packages in repositories:

* xlunch, version 4.1.1
-- Generating entries is very fast now, by using Xlunch-menu (included in package),
-- Converting svg icons to .png will be done automatically (needed, because xlunch doesn't support .svg icons).
See about xlunch: Xlunch on Github and Xlunch website

* create-portable, v1.0.3
-- Can now create portable appimage directly from .squashfs or .sfs module (chroot mode only)
-- Doesn't depend on python anymore
Topic : http://murga-linux.com/puppy/viewtopic.php?t=114821

* redshift-gui-lite , v0.0.4
Fixed permission problem when running as normal user
See about redshift-gui-lite also here:
http://murga-linux.com/puppy/viewtopic.php?t=114353

Install or upgrade with Synaptic or apt-get.

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 1726
Location: GERMANY

PostPosted: Sun 16 Dec 2018, 04:52    Post subject:  

Hi Fred !

Create-portable.
Really great......if not outstanding.
No Doubt .
Another "State of the Art Product out of Fred`s Laboratory .
Surely an Award winning Gadget from your Product Line .Did not test up till now but as a big Fan of your Inventiveness/ Creativity i will do as soon as i can .

Cheers !
Back to top
View user's profile Send private message 
johnywhy


Joined: 20 Aug 2011
Posts: 882

PostPosted: Sun 16 Dec 2018, 05:37    Post subject:  

hi y'all

i'm getting back into Devuan/Stretch after being away for about 6 months. Starting at square one, kinda.

seems like fred has been busy since i've been gone. The script has some updates! Smile

trying to to follow the examples from the isodata folder made by the script. but i noticed my grub doesn't understand the (hd0) syntax. One of my old working entries is:

Code:
# DevuanLive_ascii-i386-jwm-xfce
menuentry "DevuanLive_ascii-i386-jwm-xfce" {
    search -f /DevuanLive_ascii-i386-jwm-xfce/live/vmlinuz1 --set=root
    linux /DevuanLive_ascii-i386-jwm-xfce/live/vmlinuz1 from=/DevuanLive_ascii-i386-jwm-xfce changes=EXIT:/DevuanLive_ascii-i386-jwm-xfce/live/changes.dat
    initrd /DevuanLive_ascii-i386-jwm-xfce/live/initrd1.xz}


does that mean i'm running a different version of grub than expected by the script?

i modified the first example given in the script, from:

Code:
title Debian-PorteusDog (sda1)
root (hd0,0)
kernel (hd0,0)/live/vmlinuz1 noauto from=/ changes=/live/
initrd (hd0,0)/live/initrd1.xz


to:

Code:
menuentry "Devuan will create automatically /live/changes" {
    search -f /Devuan/live/vmlinuz1 --set=root
    linux /Devuan/live/vmlinuz1 noauto from=/ changes=/live/
    initrd /Devuan/live/initrd1.xz}


not booting. I'm getting something like "can't find vmlinuz1". Which makes sense-- there's no vmlinuz in the isobooter folder created by the script.

what was my error?

thx!

_________________
Now: X-Tahr 2.0! StretchDog! DevuanDog!
Tops: TarhNOP Vlina-R2 Racy
Used: Puppeee Precise Lucid Wary Tahrpup Quirky Slacko MacPup Saluki Puppy Studio LxPupTarh Lina-Lite Lina
i ♥ Puppy
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4017
Location: holland

PostPosted: Sun 16 Dec 2018, 08:08    Post subject:  

Hi johnywhy, welcome back !

Assuming you did create "Devuan" folder and placed the live folder inside, this should work with GRUB2:

Code:
menuentry "Devuan will create automatically /Devuan/live/changes" {
    search -f /Devuan/live/vmlinuz1 --set=root
    linux /Devuan/live/vmlinuz1 noauto from=/Devuan/ changes=/Devuan/live/
    initrd /Devuan/live/initrd1.xz}


There should be vmlinuz1 in the "live" folder, if not, something went wrong with the build, I guess.
The from=... needs to be parent of "live", so in this case: from=/Devuan
And note that changes folder works only on ext2/3/4

EDIT:
Quote:
seems like fred has been busy since i've been gone. The script has some updates! Smile


Not that I know of Rolling Eyes

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
johnywhy


Joined: 20 Aug 2011
Posts: 882

PostPosted: Sun 16 Dec 2018, 14:06    Post subject:  

thx Fred!

i made this devuan as:
- xfce
- 32-bit option checked
- removed conky.
- xz compression

yep, i created Devuan and put live folder (output by your script) inside it. It doesn't contain vmlinuz. Here's my dir:

12/15/2018 10:29 AM 3,796,992 01-filesystem.squashfs
12/16/2018 12:42 AM <DIR> base
12/14/2018 06:32 PM 136 initrd.img
12/14/2018 06:32 PM 1,021,796 initrd1.xz
12/16/2018 12:42 AM <DIR> modules
12/16/2018 12:42 AM <DIR> optional
12/16/2018 12:42 AM <DIR> rootcopy
05/26/2015 02:45 AM 437 stretch-i486.sgn
05/26/2015 02:45 AM 437 stretch-x86_64.sgn
11/16/2018 12:51 PM 32,768 zz_xfce_config.squashfs
7 File(s) 4,853,438 bytes
6 Dir(s) 17,435,467,776 bytes free

i just tried again, and still no vmlinuz.

in the past, have used Devuan successfully on my NTFS drive. Is ext a new requirement?

didn't you update in october? my last tries were a few months prior.

cheers!

Update: Just tried again, without 32bit checked. Got these errors:

Code:
...
/usr/sbin/debootstrap: 1456: /usr/sbin/debootstrap: cannot create /media/johny/Docs/Downloads/Linux/Devuan/stretch/chroot/test-dev-null: Permission denied
E: Cannot install into target '/media/johny/Docs/Downloads/Linux/Devuan/stretch/chroot' mounted with noexec or nodev
....
Saving to: ‘isodata-stretch.tar.gz’

isodata-stretch.tar 100%[===================>] 158.07K   497KB/s    in 0.3s   

2018-12-16 10:26:59 (497 KB/s) - ‘isodata-stretch.tar.gz’ saved [161859/161859]

OK
Extracting...
OK
Copy scripts, required for porteus-boot, to the chroot...
OK
mount: chroot/proc: mount point does not exist.
mount: chroot/dev: mount point does not exist.
mount: chroot/sys: mount point does not exist.
mount: chroot/dev/pts: mount point does not exist.
chroot: failed to run command ‘/bin/bash’: No such file or directory
Unmounting mount binds in chroot
umount: chroot/proc: no mount point specified.
umount: chroot/dev/pts: no mount point specified.
umount: chroot/dev: no mount point specified.
umount: chroot/sys: no mount point specified.
Start extracting and creating new 'live' initrd files...
mv: cannot stat 'chroot/boot/initrd.img-*': No such file or directory
FAILED
gzip: initrd.img.gz: No such file or directory
cpio: premature end of archive
Creating initrd.img, please wait...
OK
Copy kernel modules, contents of lib/modules, from extracted 'live-boot' initrd
 to extracted 'porteus-boot' initrd skeleton, initrdport/lib/modules/ ...
cp: cannot stat 'initrdlive/lib/modules/*': No such file or directory
FAILED
Creating initrd1.xz, please wait...
OK
Copy initrd.img, initrd1.xz to isodata/live...
OK
Move vmlinuz, from chroot/boot/, to isodata/live/vmlinuz1 ...
mv: cannot stat 'chroot/boot/vmlinuz-*': No such file or directory
FAILED
mv: cannot stat 'chroot/var/cache/apt/archives/*.deb': No such file or directory
If configured, download extra .squashfs modules to isodata/live...

still no vmlinuz in live folder.

i remounted the partition without "nodev", and tried again. No longer getting the errors!
is this a new requirement?
will tell you shortly if i got vmlinuz, but looking good so far.

thx!

_________________
Now: X-Tahr 2.0! StretchDog! DevuanDog!
Tops: TarhNOP Vlina-R2 Racy
Used: Puppeee Precise Lucid Wary Tahrpup Quirky Slacko MacPup Saluki Puppy Studio LxPupTarh Lina-Lite Lina
i ♥ Puppy
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4017
Location: holland

PostPosted: Sun 16 Dec 2018, 15:07    Post subject:  

Hi johnywhy,

Quote:
still no vmlinuz in live folder.


Yes, your output is full of errors, I suspect you did something unsupported, please give more details, e.g:
- from what type filesystem you ran the script (should be linux filesystem, e.g. ext3 or ext4)
Code:
cannot create /media/johny/Docs/Downloads/Linux/Devuan/stretch

- You have full write permissions to that directory ? (seems not, looking at your output)
- From which OS you ran the script

Quote:
in the past, have used Devuan successfully on my NTFS drive. Is ext a new requirement?


Not new, changes folder is (and was) only supported on ext

Quote:
didn't you update in october? my last tries were a few months prior.

Ah, yes, update was changing package sources.

EDIT:
Quote:
/usr/sbin/debootstrap: 1456: /usr/sbin/debootstrap: cannot create /media/johny/Docs/Downloads/Linux/Devuan/stretch/chroot/test-dev-null: Permission denied


No idea where this "test-dev-null" comes from, you have any clue ?

EDIT2:
Quote:
i remounted the partition without "nodev", and tried again. No longer getting the errors!
is this a new requirement?
will tell you shortly if i got vmlinuz, but looking good so far.


Didn't read your last comment, sorry, I don't know about that 'nodev'.

Fred

Last edited by fredx181 on Sun 16 Dec 2018, 15:30; edited 1 time in total
Back to top
View user's profile Send private message 
johnywhy


Joined: 20 Aug 2011
Posts: 882

PostPosted: Sun 16 Dec 2018, 15:29    Post subject:  

deleted
_________________
Now: X-Tahr 2.0! StretchDog! DevuanDog!
Tops: TarhNOP Vlina-R2 Racy
Used: Puppeee Precise Lucid Wary Tahrpup Quirky Slacko MacPup Saluki Puppy Studio LxPupTarh Lina-Lite Lina
i ♥ Puppy

Last edited by johnywhy on Sun 16 Dec 2018, 15:35; edited 1 time in total
Back to top
View user's profile Send private message 
johnywhy


Joined: 20 Aug 2011
Posts: 882

PostPosted: Sun 16 Dec 2018, 15:31    Post subject:  

i remounted the partition without "nodev", and tried again. No longer getting the errors!
is this a new requirement?
will tell you shortly if i got vmlinuz, but looking good so far.

fredx181 wrote:
changes folder is (and was) only supported on ext

ok, but just changes folder? or entire install, and also running the script?

_________________
Now: X-Tahr 2.0! StretchDog! DevuanDog!
Tops: TarhNOP Vlina-R2 Racy
Used: Puppeee Precise Lucid Wary Tahrpup Quirky Slacko MacPup Saluki Puppy Studio LxPupTarh Lina-Lite Lina
i ♥ Puppy
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4017
Location: holland

PostPosted: Sun 16 Dec 2018, 16:03    Post subject:  

johnywhy wrote:
ok, but just changes folder? or entire install, and also running the script?


Yes , just changes folder and also running the script.
The entire install can be also on NTFS or FAT but then for changes you need to create save file, e.g. changes.dat

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 95 of 99 [1477 Posts]   Goto page: Previous 1, 2, 3, ..., 93, 94, 95, 96, 97, 98, 99 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1694s ][ Queries: 12 (0.1047s) ][ GZIP on ]