Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Jan 2020, 23:28
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Create Debian 9 (Stretch) minimal ISO similar to DebianDog
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 94 of 103 [1533 Posts]   Goto page: Previous 1, 2, 3, ..., 92, 93, 94, 95, 96, ..., 101, 102, 103 Next
Author Message
zagreb999

Joined: 11 Apr 2014
Posts: 546
Location: Yugoslavija

PostPosted: Sat 27 Oct 2018, 11:50    Post subject: DebianDog-Wheezy-openbox_xfce-2015-09-02-PAE.iso, gnome apps  

DebianDog-Wheezy-openbox_xfce-2015-09-02-PAE.iso, gnome apps
file-roller,
gnome search tool...

this iso is great, works great

why gnome apps
file-roller,
gnome search tool...

can not work?
regards!
Back to top
View user's profile Send private message 
s243a

Joined: 02 Sep 2014
Posts: 2364

PostPosted: Sat 03 Nov 2018, 01:40    Post subject:  

fredx181 wrote:
Hi, s243a

The debootstrap package from devuan should be downloaded and installed from the script.
They changed address, but still works for me (redirect)

Code:
--2018-10-23 09:57:01--  https://packages.devuan.org/devuan/pool/main/d/debootstrap/debootstrap_1.0.87%2Bdevuan1.1_all.deb
Resolving packages.devuan.org (packages.devuan.org)... 46.105.191.77, 2001:41d0:8:2c55::a2
Connecting to packages.devuan.org (packages.devuan.org)|46.105.191.77|:443... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://packages.roundr.devuan.org/devuan/pool/main/d/debootstrap/debootstrap_1.0.87%2Bdevuan1.1_all.deb [following]
--2018-10-23 09:57:01--  https://packages.roundr.devuan.org/devuan/pool/main/d/debootstrap/debootstrap_1.0.87%2Bdevuan1.1_all.deb


But apparently doesn't work for you, anyway, re-attached here with changed address to: http://pkgmaster.devuan.org
http://murga-linux.com/puppy/viewtopic.php?p=996908#996908

So the debootstrap part of the new script is:
Code:
# download and install devuan debootstrap deb
wget --no-check-certificate http://pkgmaster.devuan.org/devuan/pool/main/d/debootstrap/debootstrap_1.0.89-devuan2.1_all.deb -O debootstrap_1.0.89-devuan2.1_all.deb
dpkg -i debootstrap_1.0.89-devuan2.1_all.deb    # install devuan debootstrap

########## Set up debootstrap ##########
echo -e "\e[0;36mSetting up debootstrap in stretch/chroot\033[0m"
echo -e "\e[0;36mThis may take a while...\033[0m"
mkdir -p stretch/chroot && cd stretch &&
debootstrap --arch=$ARCH --variant=minbase --include=apt-transport-https,ca-certificates ascii chroot http://pkgmaster.devuan.org/merged/


I'm tyring the script now on TazPup.
http://murga-linux.com/puppy/viewtopic.php?p=1008843#1008843

I'm not booting from it though. I'm using the generated folders for a chroot environment. I didn't see the following packages generated from the build: apt, apt-utils, dpkg, aptitude.

This surprise me because I thought that debootstrap would fetch these packages. Maybe I accidentally deleted them? Anyway, I'm gong to add these packages that I think are missing to the "Base-Install" part of the GUI and see what happens. Smile

Quote:

EDIT: Reading your post again, I think you didn't run the mklive-devuan script, but ran debootstrap command only, if so, see above for the code.
(and, as discussed earlier in this thread, the Devuan debootstrap package has support for Debian also, so no problem to have it installed (replacing the Debian package))

Fred

That's correct. At first I just tried the debootstrap command. I want to learn the differences between your script and the instructions at:
https://devuan.org/os/documentation/dev1fanboy/jessie-minimal-install

Edit: I think the problem was that I needed to install perl.

Edit2 I might have to install dpkg-deb or create a wrapper function for busybox. I get the following error running the dpkg command:

Quote:

dpkg-deb: unrecognized option '--fsys-tarfile'

Command line: dpkg-deb --fsys-tarfile .//var/cache/apt/archives/base-files_9.9+devuan2.5_all.deb

BusyBox v1.27.2 (2018-06-04 11:30:05 CEST) multi-call binary.

Usage: dpkg-deb [-cefxX] FILE [DIR]

Perform actions on Debian packages (.deb)

-c List files
-f Print control fields
-e Extract control files to DIR (default: ./DEBIAN)
-x Extract files to DIR (no default)
-X Verbose -x
tar: This does not look like a tar archive
tar: Exiting with failure status due to previous errors


Edit 3
both dpkg and util-linux-bash-completion were available via the tazpup package manager. I'll try again Smile
Back to top
View user's profile Send private message Visit poster's website 
fredx181


Joined: 11 Dec 2013
Posts: 4252
Location: holland

PostPosted: Sat 03 Nov 2018, 07:04    Post subject:  

Hi s243a, out of curiosity I tested on tazpup.
Indeed perl and dpkg are required, and to make the mklive script run properly, also wget and cacerts need to be installed from package manager.
Also when I tried on my sda5 partition I got a permission error (although logged in as root), didn't investigate that further (maybe needed to remount different way ?) so did the build in /root and went fine.

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
zagreb999

Joined: 11 Apr 2014
Posts: 546
Location: Yugoslavija

PostPosted: Sun 04 Nov 2018, 19:51    Post subject: mobile browser, Opera Mini  

how run
mobile browser, Opera Mini on dd and sd?

in puppy it works!
http://www.murga-linux.com/puppy/viewtopic.php?t=106514

is it possible to create squashfs?

regards
Back to top
View user's profile Send private message 
dancytron

Joined: 18 Jul 2012
Posts: 1441

PostPosted: Sun 11 Nov 2018, 16:29    Post subject:  

A little upgrade snafu.

A bunch of stuff showed for upgrade today, so I "Marked all upgrades" in synaptic and then his apply.

It aborted the upgrade, and this message popped up.

Quote:
E: /var/cache/apt/archives/gtkdialog_0.8.7-wiak-B_amd64.deb: trying to overwrite '/usr/bin/gtkwialog', which is also in package gtkwialog 0.8.5



Under "details" in the closing dialog, I got this:

Quote:

debconf: unable to initialize frontend: Gnome
debconf: (Can't locate object method "new" via package "Text::Iconv" (perhaps you forgot to load "Text::Iconv"?) at /usr/share/perl5/Debconf/Encoding.pm line 65, <> line 30.)
debconf: falling back to frontend: Dialog
debconf: unable to initialize frontend: Dialog
debconf: (TERM is not set, so the dialog frontend is not usable.)
debconf: falling back to frontend: Readline
Preconfiguring packages ...
setting xserver-xorg-legacy/xwrapper/allowed_users from configuration file
(Reading database ... 43295 files and directories currently installed.)
Preparing to unpack .../base-files_9.9+deb9u6_amd64.deb ...
Unpacking base-files (9.9+deb9u6) over (9.9+deb9u5) ...
Setting up base-files (9.9+deb9u6) ...
Installing new version of config file /etc/debian_version ...
(Reading database ... 43295 files and directories currently installed.)
Preparing to unpack .../gtkdialog_0.8.7-wiak-B_amd64.deb ...
Unpacking gtkdialog (0.8.7-wiak-B) over (0.8.3-2) ...
dpkg: error processing archive /var/cache/apt/archives/gtkdialog_0.8.7-wiak-B_amd64.deb (--unpack):
trying to overwrite '/usr/bin/gtkwialog', which is also in package gtkwialog 0.8.5
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/gtkdialog_0.8.7-wiak-B_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:


I unmarked gtkdialog and did "apply" again and the update completed without error.

So it seems there is some sort of versioning conflict between gtkdialog and gtkwdialog.
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4252
Location: holland

PostPosted: Sun 11 Nov 2018, 18:39    Post subject:  

dancytron wrote:
A little upgrade snafu.

A bunch of stuff showed for upgrade today, so I "Marked all upgrades" in synaptic and then his apply.

It aborted the upgrade, and this message popped up.

Quote:
E: /var/cache/apt/archives/gtkdialog_0.8.7-wiak-B_amd64.deb: trying to overwrite '/usr/bin/gtkwialog', which is also in package gtkwialog 0.8.5

.....
.....


Ah, yes, thanks.
The new gtkdialog package (which includes gtkwialog in /usr/bin) should remove older gtkwialog package when installing.
It will do now, if I did right, can you confirm ?

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
dancytron

Joined: 18 Jul 2012
Posts: 1441

PostPosted: Sun 11 Nov 2018, 18:48    Post subject:  

fredx181 wrote:
dancytron wrote:
A little upgrade snafu.

A bunch of stuff showed for upgrade today, so I "Marked all upgrades" in synaptic and then his apply.

It aborted the upgrade, and this message popped up.

Quote:
E: /var/cache/apt/archives/gtkdialog_0.8.7-wiak-B_amd64.deb: trying to overwrite '/usr/bin/gtkwialog', which is also in package gtkwialog 0.8.5

.....
.....


Ah, yes, thanks.
The new gtkdialog package (which includes gtkwialog in /usr/bin) should remove older gtkwialog package when installing.
It will do now, if I did right, can you confirm ?

Fred


Yes it worked.

Before detail message in synaptic:

Quote:
gtkwialog will be removed
precord will be removed
gtkdialog (version 0.8.3-2) will be upgraded to version 0.8.7-wiak-B-1


After details in synaptic:

Quote:
debconf: unable to initialize frontend: Gnome
debconf: (Can't locate object method "new" via package "Text::Iconv" (perhaps you forgot to load "Text::Iconv"?) at /usr/share/perl5/Debconf/Encoding.pm line 65, <> line 1.)
debconf: falling back to frontend: Dialog
debconf: unable to initialize frontend: Dialog
debconf: (TERM is not set, so the dialog frontend is not usable.)
debconf: falling back to frontend: Readline
(Reading database ... 43308 files and directories currently installed.)
Removing precord (9.0.5) ...
Removing gtkwialog (0.8.5) ...
(Reading database ... 43303 files and directories currently installed.)
Preparing to unpack .../gtkdialog_0.8.7-wiak-B-1_amd64.deb ...
Unpacking gtkdialog (0.8.7-wiak-B-1) over (0.8.3-2) ...
Setting up gtkdialog (0.8.7-wiak-B-1) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for desktop-file-utils (0.23-1) ...


Thanks,


Dan
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4252
Location: holland

PostPosted: Sun 11 Nov 2018, 19:53    Post subject:  

dancytron wrote:

....
Removing precord (9.0.5) ...
...


Another consequence of my mistake...
You may not need it, but anyway fixed that by removing precord 9.0.5 from repo, so now 9.0.3 is newest version (that can be installed as it doesn't depend on gtkwialog).
Also added new version package of cast2chrome (was also depending on gtkwialog)

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
wiak

Joined: 11 Dec 2007
Posts: 1862
Location: not Bulgaria

PostPosted: Mon 12 Nov 2018, 04:06    Post subject:  

fredx181 wrote:

Also added new version package of cast2chrome (was also depending on gtkwialog)

Fred


I think you mean removed new version. I'll probably revert both Precord and cast2chrome so both will work with gtkdialog (and thus gtkwialog) now that the -b option is not so important since gtkwialog supports bash on dash systems out of the box now.

Anyway, Precord is the ancestor of weX, hence closely related to it, and a small script really, so likely just to become part of future weX as I've said elsewhere.

wiak
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4252
Location: holland

PostPosted: Mon 12 Nov 2018, 05:23    Post subject:  

wiak wrote:
fredx181 wrote:

Also added new version package of cast2chrome (was also depending on gtkwialog)

Fred


I think you mean removed new version.
....


Hi wiak, no, I bumped up the package version (now 0.0.4-2)
Has in Depends: line : gtkdialog (>= 0.8.7-wiak-B-1)
It's your fixed version (to make it work with gtkwialog 0.8.5 (or higher)):
http://murga-linux.com/puppy/viewtopic.php?p=999458#999458

All a bit confusing maybe because the newest gtkdialog package version (0.8.7-wiak-B-1) contains gtkwialog binary (and gtkdialog is symlink to it)
This construction seemed to me the most logical (and easiest Wink )

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
zagreb999

Joined: 11 Apr 2014
Posts: 546
Location: Yugoslavija

PostPosted: Tue 13 Nov 2018, 20:24    Post subject:  

deblive 32 bit xfce
vlc 3
----------
djview 4.10.6

there is not gtk

both apps can not see hard
drives?!
installed qt5ct-again no hard
drives!!!

what i have to do?
Screenshot_2018-11-12_21-27-26.png
Description 
png

 Download 
Filename  Screenshot_2018-11-12_21-27-26.png 
Filesize  216.88 KB 
Downloaded  103 Time(s) 
Back to top
View user's profile Send private message 
rijsmier

Joined: 12 Oct 2017
Posts: 9
Location: Harties, South Africa

PostPosted: Tue 20 Nov 2018, 04:35    Post subject:  

For my networking I switched to cell phone USB tehering connection. Using ObDog (Devian and Devuan versions) I can connect using frisbee without any problems. I then tried a Xfce4 version and frisbee installs but it does not show or connect when I try to open it. (It needed rfkill to be pre-loaded.)

I also tried connman with the same result.

I can't get peasywifi to work.
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4252
Location: holland

PostPosted: Tue 20 Nov 2018, 07:57    Post subject:  

Hi rijsmier,

I will test later today xfce build + frisbee and edit this post with my findings.

EDIT: Indeed some things are not right with frisbee on xfce4, the network tray icon doesn't show and not all splash dialogs displaying.
I think I've found a fix for it but need to test more, continued tomorrow.
In the meantime, maybe you can make it work using peasywifi (with the help of rcrsn51's suggestions).

Fred

_________________
Dog Linux website
Tinylinux blog by wiak

Last edited by fredx181 on Tue 20 Nov 2018, 18:35; edited 2 times in total
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12939
Location: Stratford, Ontario

PostPosted: Tue 20 Nov 2018, 10:28    Post subject:  

rijsmier wrote:
I can't get peasywifi to work.

USB tethering often works by creating an Ethernet interface named usb0.

Open the Ethernet tab and click the I/F button.

Then use the Names tool to enable it. Follow the instructions. Click Reconnect.

Also, if you are having rfkill problems, install the latest version of peasywifi from Fred's repo.

Check for rfkill blocks using the Status button.
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4252
Location: holland

PostPosted: Wed 21 Nov 2018, 10:32    Post subject:  

rijsmier wrote:
For my networking I switched to cell phone USB tehering connection. Using ObDog (Devian and Devuan versions) I can connect using frisbee without any problems. I then tried a Xfce4 version and frisbee installs but it does not show or connect when I try to open it. (It needed rfkill to be pre-loaded.)

I also tried connman with the same result.

I can't get peasywifi to work.


Perhaps you managed with peasywifi already, but anyway, added new frisbee (fixed) package to repos v 1.2-20181120 , install with Synaptic or apt-get:
Code:
apt-get update   # update package lists
apt-get install frisbee



Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 94 of 103 [1533 Posts]   Goto page: Previous 1, 2, 3, ..., 92, 93, 94, 95, 96, ..., 101, 102, 103 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.2901s ][ Queries: 12 (0.1945s) ][ GZIP on ]